Audiofuse 16Rig not detected by windows 11 anymore... :o(

my Audiofuse 16rig is not detected/supported anymore by windows 11 :
Screenshot 2024-04-30 153146
Windows 11 has the last updates installed

I have restarted teh AF16rig several times and rebooted the PC as well.
I have tried to uninstall the driver and redetect it from the device manager but without success.
When I launch the AFCC it is detecting the audiofuse and managed to “discuss” with it but winodws does not want to recognize it anymore :sleepy:
I have reinstalled the AFCC + the Driver using the last AudioFuse_Control_Center__2_2_1_842.exe file downloaded from Arturia but without success until now…
The AF16Rig is perfectly working isn stand alone as I can here my hardware synths when playing… just windows 11 does lot like it anymore …
Any suggestions are therefore welcome as I have no idea what else could do to fix this.

Thanks in advance for your help.
Cheers, eric

Hi @encore1

Have you tried using a different USB port, i have a synth here that had a notoriously dodgy driver, no it’s not one of Arturia’s, and i find if i use a different USB port the driver will miraculously work again.
Also, if you are using a USB hub, please try plugging your AF 12Rig directly into a USB port and not via the hub.


Please let is know how you get on.

Hello matjones
thanks a lot for your suggestions.
In fact I have tried to connect directly the AF16 rig to the pc yesterday as well (as I had a doubt about my Swissonic USB Hub 1916) but it did not changed anything until… this morning.
I have no idea what was causing the issue (and this is worrying me) but when I started my PC today, strangely everything worked fine.
I just did not had the time yet to come here to add a comment (sorry)
Thanks for your time and suggestiosn anyway.