Astrolab and MIDI continued

Hi Explorers, I had thought that I had solved for a MIDI issue when sending MIDI from a Roland Fantom to Astrolab (hung notes.) But I was overly optimistic, hung notes are back with a vengeance.

To troubleshot further I re-configured to send MIDI from a Behringer Deep Mind 12 and sure enough, hung notes. So now I need some help determining if all Astrolabs are suffering from a poor MIDI implementation or worse, I have a defective unit.

Thanks in advance if anyone can help!

Hi @ndepasquale3 and thanks for posting to see if others are experiencing the same issue with their units.

Have you contacted support yes to let them know?
You can do so here if you haven’t already.

HTH!

Thanks for the note. Kind of, I need to get back with them after thinking that I had solved for the issue.

Update: sending MIDI to AL from a deepmind 12 resulted in hung notes immediately.

I then sent MIDI to AL from a Hydrasynth and it worked perfectly, including sending program change messages.

My dilemma is determining if the AL might have a HW issue rather than this being a young device that will receive ongoing FW updates to address known issues, possibly the MIDI implementation on AL. I would be less
concerned if my first AL did not have a defective rotary encoder. Thanks!