ASIO crashes Analog Lab

Hello forum,

Currently I’m having some strange problems with ASIO drivers and Analog Lab Pro (standalone). I have a Soundblaster AE-5 sound card and use Windows 11. I have been using the AE-5 for over a year and have never had any issues with the native Soundblaster ASIO driver.

To be honest, I also have the same problems with IK multimedia Sample Tank/Pianoverse. In contrast, the “Creative SB/SBX AE Series ASIO” driver works without any problems with Steinberg Cubase 13 and Dorico 5. So it seems to be a problem when Analog Lab retrieves all ASIO drivers with metadata. I have a feeling the cause is a Windows 11 update. It looks like the volume control, mixer, and device output panel on the taskbar have been reworked. Maybe Microsoft has made some changes under the hood too. But Steinberg apps work in contrast.

I can’t even select an ASIO driver because Analog Lab Pro crashes immediately when I select the ASIO “category”. In the IK Mulltimemedia plugin I can at least select the ASIO “category”, but not my Soundblaster ASIO driver.
The strangest thing is that I was able to use the Realtek ASIO driver of my ALC 4080 onboard sound when I connect the headphones to the back. I can even use 48kHz with the native Realtek ASIO driver when the headphones are connected to the back.

The Realtel ASIO drivers have always caused problems and I have never used them. When the headphones are connected to the front I get an error saying the app doesn’t support 176kHz or something similar. That’s because the Realtek 4080’s front panel connector supports up to 176 kHz.

So everything is very strange and the root cause seems to be Windows 11 and the way Analog Lab and other apps handle the ASIO driver stack. In the past (month ago or something like that) everything has worked well.

Greetings,
noob

Personally, I would consider getting an audio interface that comes with native ASIO drivers (like the Arturia MiniFuse series for eg).

I’m talking about a native ASIO driver. Other than Steinberg software, I don’t actually need ASIO. In Analog Lab or another plugin I use the normal Windows Audio API (no exclusive or low latency mode) at 96KHz/32Bit. Thanks to PCIe, I don’t feel any latency, even if I disable direct mode and route everything through the AE-5 sound card’s DSP.

But the AE-5 ASIO drivers always worked. There was no driver update and the Steinberg software continues to work fine with the AE-5 ASIO drivers. If Analog Lab Pro crashes immediately after selecting the ASIO “category”, not even the driver itself, it must be a bug in the app or in a Windows update or both.

Just upvoting this topic, because it’s not only a problem of the Creative ASIO driver.

In Windows, ASIO drivers are published under " HKEY_LOCAL_MACHINE->SOFTWARE->ASIO" in the registry. There are two folders for both Creative ASIO drivers: “Creative SB/SBX AE DSD ASIO Device” and “Creative SB/SBX AE series ASIO Device”. Nothing special about, but there is just the CLSID and a Description in the reg folders.

When i delete both reg folders (i’ve backuped/exported them), then i can select the ASIO category in Analog Pro. Then i can select one of the other ASIO drivers for my onboard Realtek Sound or the other ASIO Wrappers like ASIO4All. When i re-import the reg entries, same problem as expected. Analog Pro crashes immediately after switching to the ASIO “category”.

If i am not modifying the registry i simply can’t use any ASIO driver. But on the other hand, Steinberg Software finds all ASIO drivers and i can even use the Creative ones. So, apparently it’s just a bug in reading all available ASIO drivers and then reading some HW details like sample rate etc. Even if there would be a bug in one ASIO driver it must be possible to select another one.

regards,
noob

My rig has a Soundblaster Audigy 5/RX card. Analog Lab works fine with its Creative Asio driver. Though when I start the program I get a message that Asio 4All was launched with 44Khz. But when I look into settings it is Creative ASIO. I guess Analog Lab just loads just any sound driver at start-up and then switches to your own settings. :man_shrugging:

By the way ASIO4All is inferior to Creative ASIO. It is simply not a viable solution.

pic

More useful answer, have you tried ASIO4ALL? It always used to work for me before I moved to the dark side, whereupon I never worried about OS-related latency/driver crashing issues ever again…

The Creative ASIO drivers worked for me for a year. So you mean i have to switch to Macintosh, because Analog Lab Pro crashes, but not Cubase?

And again, how can i use ASIO4ALL when Analog Lab Pro crashed immediately after selecting the ASIO “category”! The emphasis is on category, not driver!