Arturia Keylab 61 mkii and FL Studio 21

Hi all, I’ve noticed this strange behaviour of my Keylab with FL, basically there are 2 volume faders continously floating up and down while I’m not even touching the keyboard.
I’ve tried searching the forum, upgrading either the keyboard firmware or FL, I’ve tried downgrading the controller but the problem persists.
Can someone help me out?
Thank you in advance.

Hi @DarkAE . Welcome to the community.

It sound like you have automation going on in your DAW that does this. Do you have the behavior, if you open a new project?
Do you have the behavior, if you disconnect your controller?

I can also suggest, you check if your controller output the data. You can for example use MIDI-OX for that when using Windows.
You can download MIDI-OX here:

You should be able to locate, where the problem is doing this.

Hi @LBH , thank you for your reply!
Sorry for not mentioning that the image I took was of a completely empty project, just the default sampler channel of FL but that was empty too.
The problem persists even after disconnecting and reconnecting. It also appears on Reaper and Ableton Live, the latter has other strange things happening like pressing C5 note deletes the selected sample or pattern and there are a lot of added notes after recording a pattern (I’ve tried recording something with Pigments 3).
I’m downloading and trying MIDI-OX and see if I find out something helpful.
Thank you!

Hi again @LBH , I’ve downloaded MIDI-OX, without even touching any of the keys or faders on the keyboard I see a lot of signals in the output, I’m sending an image.
Any clue on how to fix this?
Thank you

Are you using the MIDI-OX without opening your DAW?

What i can say is that the data you see is a note on and a note off event on midi Ch 1 and a Pitchbend event for some reason on midi CH 7.
Never the less - None of this should normally move Volume faders in your DAW.

Are you sure you have set up your controller correct in your DAW?

EDIT: Did you have the volume fader behavior while your controller was disconnected from your computer?
We also have to consider Mackie. EDIT END.

I’ve read a tutorial on how to use it, DAW was closed.
I think it might be a hardware problem, almost the same issues come up in FL, Ableton Live and Reaper.
This evening I’m trying deleting all controller configurations in FL and set it up again.
I’ll let you know what happens, thank you very much.

Yes please tell what you find out.

If you only have the issue, when your controller is connected to your computer, then it indicate the messages causing the issue come from the controller somehow.
It look like it’s something with Mackie though, that your MIDI-OX is’nt set up to read or can’t be set up to read.

You can allways try a factory reset like described in the manual for your controller. I’m not sure you have tried this.

Hi @LBH , I’ve done some tests.
The problem shows up with FL and Ableton and even inside of Analog Lab versions 4 and V.
The slider number 7 and 8 keep floating around without me touching them.
I think it might be some kind of hardware issue at this point.
You are right I haven’t tried the factory reset, I’ll read the manual and try this operation too.
I’ll let you know what happens.
Thank you for all your time, I appreciate it!

Thanks for reporting back @DarkAE,

Based on your MIDI-OX image i think it’s strange, if you have issues with Analog Lab as standalone. However the values in MIDI-OX should not be continueous, and it does look like the controller is the culprit i agree, unless perhaps if some unkown thing that can cause this is going on on your computer.

Hopefully a controller factory reset helps.