16Rig firmware v1.2.2

AudioFuse Control Center prompted me to update to a new firmware version.

I haven’t done it yet… not sure I want to be the guinea pig considering some of the recent quality issues noted with other Arturia software elsewhere in this forum. Has anyone tried it yet?

Here are the release notes from the website:

Bug Fixes

  • Added DC Blocking to analog inputs to eliminate DC offset


  • Optimized line output D/A converters to enhance stability and improve THD
  • Improved firmware update process

I just updated and no problems yet.

1 Like

I did also and so far it seems ok. When I saw “Improved firmware update process”, I had to go for it - I’m tired of being nagged by “you are on version 1.1.9 and 1.1.9 is available - would you like to upgrade?” every time i use AFCC.

1 Like

No issues with the update, but disappointed that it does nothing to address the preset issue that was present in 1.9.1.

Hi everyone,

We are aware that many people are waiting for some fixes on the AFCC/firmware update popup issues (and other…) that were not included in the latest firmware 1.2.2 release.

We are currently working on these fixes, and I hope they will be available soon for all.
The next firmware and AFCC versions should fix a lot of user complaints.



My 16rig won’t turn on after updating. Are there any steps to take?

Edit - turns out it was just the screen+audio, it still showed up in AFCC and running the update again fixed it

Had to install mine twice. First time said successful then it said connect interface after I restarted it so I unplugged the USB C and plugged back in then it said version was out of date and installed again. All is good now.

Lately, it seems like about half the time I power on my 16Rig, my Mac doesn’t recognise it as connected. It doesn’t show up as an audio output device in my Sound settings, and AFCC doesn’t see it. The power/Arturia button on the device is lit up white, as it normally is in USB-connected mode. Usually powering it off and on again fixes it. It might be a coincidence, but I feel like this only started happening after updating to firmware v1.2.2.