16Rig doesn't work via USB hub

So, if I connect my 16rig directly to my mac mini, all works as expected. Audiofuse Studio and MIDI Control Center both see the device just fine. If I attempt to connect it via any USB hub, it is not recognized.

My AF Studio is able to work through the hub just fine. I’ve tested this on multiple machines and multiple USB hubs.

Did I miss something in the manual? Is this supposed to work?


If I remember right, the manual states somewhere not to use it with a USB hub, but I can’t find that statement now that I’m looking for it.

I just did a text search of the manual and I don’t see it either. Definitely should be a bullet item caveat. Thanks!

Hello !

I made a lot of development on the AFCC 16Rig always with the 16Rig connect with a USB hub, so it can work.

Sometimes, hubs can mess a bit with USB, did you try multiple port on this hub ?
Did you try another hub ?
What’s the reference of your hub ?

Cheers !

I tried multiple ports on the hub. I’ve also tried multiple hubs (3 different ones to be exact). As noted, my AudioFuse Studio works just fine through the same hub(s).

I’m okay with this if it’s a limitation (as I’m able to work the combination of hub(s) and direct ports at the moment). Or, if anyone can provide a model hub that is working for them with the 16Rig, that would be greatly appreciated as well.


Some hubs are really bad, can you precise the reference of your current one ?

I personally use an AUKEY CB-H17 (this is an old one, but very similar to this cb-h19)

In combination with a Belkin f4u092:


Both of them are working great for me.

Cheers !

This is what I’d purchased:

TobenONE Powered USB C Hub with Power Adapter, 10Gbps USB C Splitter with 4*USB-C 3.2 for Data&20W Charging, USB C to USB C Hub Multiport Adapter