June 16, 2021, 02:30:40 pm
Welcome, Guest. Please login or register.
Did you miss your activation email
News:

Arturia Forums



Author Topic: Controls not working in Pro Tools 12  (Read 848 times)

rodincoil

  • Apprentice
  • *
  • Posts: 5
  • Karma: 0
Controls not working in Pro Tools 12
« on: December 07, 2019, 03:33:40 am »
I recently upgraded to Pro Tools 12 and Windows 10. While the Keylab worked fantastic on my old Windows 7/Pro Tools 10 computer, I can only achieve the most basic functions with Windows 10/Pro Tools 12. Even after selecting Pro Tools as my DAW, adding Keylab61mkii as a MIDI controller, trying different USB ports and cables, and reading various help/forum information for the last 9 hours or so, I am not able to get it to work.

LBH

  • Hero Member
  • *****
  • Posts: 3.788
  • Karma: 38
Re: Controls not working in Pro Tools 12
« Reply #1 on: December 07, 2019, 01:18:49 pm »
Hi and welcome to Arturia forums.

What functionality has changed?

Have you set up your controller like shown here: https://www.arturia.com/faq/keylabmkii/keylab-mkii-tips-tricks
Do you use the ports MIDIIN2 and MIDIOUT2 in the setup as the note in the directions tell?

Does ProTools 12 have a filter that filter out functionality, but that you by mistake have thought was adding the functionality?

I don't use an Arturia controller or Pro Tools.

rodincoil

  • Apprentice
  • *
  • Posts: 5
  • Karma: 0
Re: Controls not working in Pro Tools 12
« Reply #2 on: December 07, 2019, 01:42:30 pm »
Thank you for your reply.

In my previous setup using Windows 7 and Pro Tools 10, the Arturia Keylab 61 MK II was capable of operating Pro Tools (play, record, etc.) as well as the built-in functions with the Arturia V Collection (cutoff, resonance, etc.). With Pro Tools 12, none of those functions work outside of the basic function of triggering VST notes on the keyboard. I have selected DAW / Pro Tools in the Arturia Keylab as well. (forgot to mention having tried HUI and M-Audio Keyboard options in Pro Tools)

I am unable to set up the controller as shows in the keylab-mkii-tips-tricks link because MIDI Control Center does not find the Keylab (listed under "Disconnected").

I am unable to use ports MIDIIN2 or MIDIOUT2 as Pro Tools only sees Keylab mkii 61 [Emulated] and MIDIIN2 (Keylab mkii 61 [Emulated]). Neither work properly. The sliders trigger random changes in Pro Tools or in the VST. One even caused the mix window to resize.
« Last Edit: December 07, 2019, 01:50:06 pm by rodincoil »

rodincoil

  • Apprentice
  • *
  • Posts: 5
  • Karma: 0
Re: Controls not working in Pro Tools 12
« Reply #3 on: December 07, 2019, 02:19:29 pm »
Just as an experiment, I pulled out my Nektar Impact LX88+ and plugged it into the usb cord. I opened up Pro Tools 12, selected the lx88+ in MIDI controllers, and it worked great...including faders/knobs that controlled the Arturia V Collection. On one hand, I am glad the LX88+ worked. On the other hand, it is incredibly frustrating that the Keylab isn't working. :( Since so many tech problems are generally 99% User Error, I sincerely hope this can be sorted out as I loved the Keylab when it was working and the V Collection is amazing.

LBH

  • Hero Member
  • *****
  • Posts: 3.788
  • Karma: 38
Re: Controls not working in Pro Tools 12
« Reply #4 on: December 07, 2019, 03:37:08 pm »
I am unable to set up the controller as shows in the keylab-mkii-tips-tricks link because MIDI Control Center does not find the Keylab (listed under "Disconnected").
I assume the device should show as connected to work properly. If it does'nt, then i guess this is the culprit.

Have you tried to remove the device in Windows Device Manager and then reconnect it after a restart of the system?

Is there a firmware upgrade availble for you Keylab, that adresses issues like this on Windows 10, if there have been any?

Which USB port types do you use? Is it compatible with your Keylab MKII?

EDIT: Also perhaps a Keylab system reset can help. EDIT END.
« Last Edit: December 07, 2019, 03:43:40 pm by LBH »

rodincoil

  • Apprentice
  • *
  • Posts: 5
  • Karma: 0
Re: Controls not working in Pro Tools 12
« Reply #5 on: December 07, 2019, 04:49:02 pm »
First, thank you so much for offering to help. It is greatly appreciated!

I have removed the device multiple time (as well as others), rebooted and had no luck.

The firmware is 1.1.3, which I believe is the same version available for download, but I may be wrong. I can't install it anyway as the Arturia MIDI Control Center doesn't see the Keylab in the first place.

All USB ports on the new computer are 3.0. The older box had 2.0. I'm going to purchase and attempt to try a 2.0 powered hub and see if that makes any difference.

I've also tried the system reset twice to no avail. Thank you again for your time. It means a lot to me. For an old IT guy, this has me wanting to bang my head against a wall. :)

rodincoil

  • Apprentice
  • *
  • Posts: 5
  • Karma: 0
Re: Controls not working in Pro Tools 12
« Reply #6 on: December 07, 2019, 09:56:17 pm »
This has been solved. I connected the Keylab to a powered USB 2 hub. Still had a problem. MCC found the device, but said it couldn't connect because it may be in use by something else. I read a thread somewhere discussing how Windows MIDI is easily hijacked, so I started disconnecting everything that was non-essential, and shutting down any processes that were audio-related. I had turned off the Keylab, uninstalled the driver, uninstalled the MIDI Control Center, and rebooted. I then installed the MIDI Control Center and turned on the Keylab. It connected to the device, so I ran the firmware update. After selecting the DAW in the MCC, I opened Pro Tools and it didn't find the device. I shut down Pro Tools, closed the MCC, then re-opened Pro Tools. It finally found the Keylab and is currently working.

Maybe this will help someone else. Hopefully they don't have to also jump through any flaming hoops or catch a bullet with their teeth. :D

Thank you, LBH. Your replies gave me just enough determination to push through this and figure it out. That made the difference. Cheers!

LBH

  • Hero Member
  • *****
  • Posts: 3.788
  • Karma: 38
Re: Controls not working in Pro Tools 12
« Reply #7 on: December 07, 2019, 10:45:25 pm »
Your welcome. Sometimes things react strange. Glad it work now.
Thanks for reporting back. That can indeed turn out to be helpful for some.

Cheers.

 

Carbonate design by Bloc
SMF 2.0.17 | SMF © 2019, Simple Machines