July 04, 2020, 06:30:35 am
Welcome, Guest. Please login or register.
Did you miss your activation email
News:

Arturia Forums



Author Topic: BBD Regeneration Distortion with v2  (Read 545 times)

endreola

  • Full Member
  • ***
  • Posts: 148
  • Karma: 3
BBD Regeneration Distortion with v2
« on: December 02, 2019, 12:58:03 am »
Am curious if others are experiencing distorted sound while using the BBD in v2?

It's been a while but I recall reading in other forums that others had complained about the audio quality of the BBD in the prior firmware.  And as such they opted to use external effects instead of the internal BBD circuitry.  I guess I was lucky and don't recall having that issue.

Now with v2, it's a different story.  There's a few patches where the degraded sound quality is pronounced, for example that new awesome The LFO Anthem patch (A5).  After playing a few notes the sound slowly diminishes away off into the distance which is when the distortion is most noticeable, similarly to overdriving a circuit or the crackling sound from a splitting speaker voice coil.  Lowering the Regeneration level certainly produces a cleaner sound but where's the fun in that?  It's also pretty reproducible from reinitializing a patch and running it thru the effects module.

I believe the BBD is all analog circuitry, right?  But had tried reloading the firmware on the Effects module nontheless but that unfortunately didn't help.

« Last Edit: December 06, 2019, 11:50:22 am by Edouard_Arturia »

STM

  • Apprentice
  • *
  • Posts: 34
  • Karma: 1
Re: BBD Regeneration Distortion with v2
« Reply #1 on: December 02, 2019, 10:32:26 pm »
Others are having the same issue.
On my first try pressing 'record + 1/32' it did go away, but it's back after powering it up 2 days later

https://forum.arturia.com/index.php?topic=98460.0

endreola

  • Full Member
  • ***
  • Posts: 148
  • Karma: 3
Re: BBD Regeneration Distortion with v2
« Reply #2 on: December 05, 2019, 01:21:55 am »
Yes, thank you for providing that link.  I did see that thread but didn't want to contribute since my issue was a bit off-topic.

endreola

  • Full Member
  • ***
  • Posts: 148
  • Karma: 3
[Solved] BBD Regeneration Distortion with v2
« Reply #3 on: December 06, 2019, 09:08:21 am »
So I decided to backrev the MxB from v2 to v1.1.0.73 (which retained its v2 patches) and took that opportunity to compare the same A5 patch.  The patch played as distorted as it did in v2.  Granted my prognosis was done by ear, (no scopes or distortion meters) but I can conclude that this it isn't a v2 thing.  Guess I hadn't tried pushing the EFX module that hard before.

STM

  • Apprentice
  • *
  • Posts: 34
  • Karma: 1
Re: [Solved] BBD Regeneration Distortion with v2
« Reply #4 on: December 06, 2019, 01:55:29 pm »
Guess I hadn't tried pushing the EFX module that hard before.

I had the same thought, but didn't try to revert to a v1 firmware.

At least i learned that the FX needs way more time to warm up than i assumed :)

Processaurus

  • Newbie
  • Jr. Member
  • *
  • Posts: 58
  • Karma: 0
Re: BBD Regeneration Distortion with v2
« Reply #5 on: December 14, 2019, 07:49:25 pm »
My BBD effects sound obviously distorted as well. Iíve built guitar pedals and with analog delays you have to bias each bbd chip to the middle of its operating range with a trimpot and an oscilloscope. I didnít see a bunch of trim pots in the pictures on gearslutz of the circuit boards, on the board with all of the bbd chips. Iím not sure how they do the biasing. It is possible everything is biased to the middle of its range, but the bbd is simply being overdriven? Thatís the best you can do with bbd chips, is just bias them to the middle of their range, so if they clip, it is symmetrical. The way to tell if the biasing is right is to look on an oscilloscope or zoomed to a recording of a daw, to a recording of a 100% wet triangle wave, force it to overdrive the bbd (but not the filter!)  and see if the clipping is even on the top and bottom of the wave.

Juanma

  • Apprentice
  • *
  • Posts: 3
  • Karma: 0
Re: BBD Regeneration Distortion with v2
« Reply #6 on: March 06, 2020, 12:18:14 am »
Hello! I have the same problem!!
When upgrading to V2.0 it seemed that everything was going well... But a few days ago the pot of "regeneration" especially in the presets with "Stereo Delay", sound with horrible feedback!!
To give two examples of the 32 presets of the V2 bank: A01 and A05
Although it also happens with other banks "Beyond the Matrix" etc ...

It has nothing to do with analogue warming, it has been on all day.
This is a very serious problem that must be solved.
Can someone from Arturia please tell us?
Thanks!

(Sorry for my English)

yeskeys

  • Apprentice
  • Jr. Member
  • *
  • Posts: 80
  • Karma: -2
Re: BBD Regeneration Distortion with v2
« Reply #7 on: March 08, 2020, 03:33:00 am »
BBDs don't sound like the delays we've become accustomed to since the 80's.  They've never sounded that great.
What is typical for this Arturia project is they are deaf to the ramifications to a typical end user:  Turn on your MB - it should boot up in patch A1.  Play a note.   Walk away and make a coffee.   Come back and the delay will still be repeating a click type sound.  Regeneration is set to full.  It'll click all day after that unless you do something to make it stop.

 

Carbonate design by Bloc
SMF 2.0.13 | SMF © 2016, Simple Machines