September 17, 2019, 10:16:00 am
Welcome, Guest. Please login or register.
Did you miss your activation email
News:

Arturia Forums



Author Topic: Problem With Beatstep Pro Encoders. Bourns/ALPS Part Numbers?  (Read 111 times)

theguvnor

  • Newbie
  • *
  • Posts: 1
  • Karma: 0
Problem With Beatstep Pro Encoders. Bourns/ALPS Part Numbers?
« on: August 25, 2019, 08:09:37 am »
Hi,

I am having skipping problems with a number of the encoders on my Beatstep Pro.  The values are skipping all over the place when a few encoders are rotated, and sometimes glitching when left at certain positions. Some of the faulty encoders are those used to set pitch (30-detent ones) and some are the non-detent type (Swing and Rate/Fine encoders).

It is definitely a hardware issue, as my other Beatstep Pro with the same same Firmware version works fine.

Do any of you know high quality replacement part numbers for these (Bourns/ALPS) for purchasing online?

Thanks!

EB5AGV

  • Newbie
  • *
  • Posts: 2
  • Karma: 0
Re: Problem With Beatstep Pro Encoders. Bourns/ALPS Part Numbers?
« Reply #1 on: September 08, 2019, 12:40:58 am »
Hi,

I am having skipping problems with a number of the encoders on my Beatstep Pro.  The values are skipping all over the place when a few encoders are rotated, and sometimes glitching when left at certain positions. Some of the faulty encoders are those used to set pitch (30-detent ones) and some are the non-detent type (Swing and Rate/Fine encoders).

It is definitely a hardware issue, as my other Beatstep Pro with the same same Firmware version works fine.

Do any of you know high quality replacement part numbers for these (Bourns/ALPS) for purchasing online?

Thanks!

Are you sure it is not a problem of too high touch sensitivity?. Some units have it, some don't, so the same firmware could act differently. I have one very sensitive unit and it was hard to use until I fixed it following the published procedure.

Jose

 

Carbonate design by Bloc
SMF 2.0.13 | SMF © 2016, Simple Machines