September 18, 2019, 12:10:49 am
Welcome, Guest. Please login or register.
Did you miss your activation email
News:

Arturia Forums



Author Topic: I am a newbie so forgive my simple question  (Read 89 times)

DJ Alfie T

  • Newbie
  • *
  • Posts: 1
  • Karma: 0
I am a newbie so forgive my simple question
« on: August 22, 2019, 11:10:22 pm »
I purchased a mini brute 2s to get into learning synths. Used a little but then ended up moving and cannot find my power cord. I purchased on amazon what should be a compatible 12 V power cord but I seem to get a low electric hum when synth is turned on.
Could this be the power cord or another issue? Sorry its pretty basic but driving me nuts

terrym

  • Global Moderator
  • Hero Member
  • *****
  • Posts: 1.361
  • Karma: 36
    • soundcloud.com/logicaldream
Re: I am a newbie so forgive my simple question
« Reply #1 on: August 23, 2019, 03:21:01 pm »
HI
The 2s needs 2.5 Amp 12volt  if your getting a hum it may be a earth mains loop  try the unit on its own without any cables connected see if you can hear the hum on headphones then plug the audio lead in. if the hum is there without any other leads plugged in them its the power unit.
TerryM
ARTURIA Tester for Audiofuse, Micro freak,Kl49mkII,DrumBrute,Spark,Analog lab3,KLE ,kl88,matrix12,Semv,Beatstep,Minibrute.se,
ASC,Vcol6, Beatstep pro, VCOL5, Synclavier v.Minibrute2s

zedius

  • Full Member
  • ***
  • Posts: 152
  • Karma: 9
Re: I am a newbie so forgive my simple question
« Reply #2 on: August 24, 2019, 12:32:08 am »
The user manual says it needs 12VDC, center pin positive, 2A. Terry, can you confirm it actually needs 2.5A? In that case the manual may need to be updated. See page 27 section 4.6.5.

DJ Alfie T can you provide a link to the exact power supply you got off of Amazon? That could help us verify.

 

Carbonate design by Bloc
SMF 2.0.13 | SMF © 2016, Simple Machines