September 19, 2019, 09:01:57 pm
Welcome, Guest. Please login or register.
Did you miss your activation email
News:

Arturia Forums



Author Topic: Pigments demo doesnt launch in Mojave  (Read 147 times)

inn3rs3lf

  • Apprentice
  • *
  • Posts: 8
  • Karma: 0
Pigments demo doesnt launch in Mojave
« on: August 03, 2019, 12:45:28 pm »
Hey guys.

So I just purchased a keylab essential 49. I have downloaded all new drivers for my mac and installed all the free products that came with it. Analogue lab 4 works fine, but pigments demo and mini v both crash as soon as you launch it. Meaning, the program doesn't even open and throws out a failure to launch error.

I have uninstalled them, restarted my mac, and installed them again. Restarted again, the same problem.



Anyone have a fix?

LBH

  • Hero Member
  • *****
  • Posts: 2.335
  • Karma: 50
Re: Pigments demo doesnt launch in Mojave
« Reply #1 on: August 03, 2019, 01:55:48 pm »
Have you just downloaded you products? Is it the latest versions?
When you have installed the applications, then what does Arturia Software Center (ASC) say about the status for Analog Lab, Pigments and Mini V?

I don't think there should be any compatibility problems or technical issues.
What does the detailed error report tell?

Perhaps you have to contact Arturia support directly through your account about this.
I'm on Windows.

inn3rs3lf

  • Apprentice
  • *
  • Posts: 8
  • Karma: 0
Re: Pigments demo doesnt launch in Mojave
« Reply #2 on: August 03, 2019, 03:33:15 pm »
Yeah, everything is up to date and online.

Error report:

Process:               Pigments [622]
Path:                  /Applications/Arturia/Pigments.app/Contents/MacOS/Pigments
Identifier:            Pigments
Version:               1.2.1.617 (???)
Code Type:             X86-64 (Native)
Parent Process:        ??? [1]
Responsible:           Pigments [622]
User ID:               501

Date/Time:             2019-08-03 15:38:02.419 +0200
OS Version:            Mac OS X 10.14.5 (18F132)
Report Version:        12
Anonymous UUID:        7E95ACB4-48EB-160C-253D-3891896FFA83


Time Awake Since Boot: 110 seconds

System Integrity Protection: enabled

Crashed Thread:        0  Juce Message Thread  Dispatch queue: com.apple.main-thread

Exception Type:        EXC_CRASH (SIGABRT)
Exception Codes:       0x0000000000000000, 0x0000000000000000
Exception Note:        EXC_CORPSE_NOTIFY

Application Specific Information:
terminating with uncaught exception of type boost::filesystem::filesystem_error: boost::filesystem::create_directory: Permission denied: "/Library/Arturia/Pigments/tmp"
abort() called

Thread 0 Crashed:: Juce Message Thread  Dispatch queue: com.apple.main-thread
0   libsystem_kernel.dylib           0x00007fff6a34d2c6 __pthread_kill + 10
1   libsystem_pthread.dylib          0x00007fff6a408bf1 pthread_kill + 284
2   libsystem_c.dylib                0x00007fff6a2b76a6 abort + 127
3   libc++abi.dylib                  0x00007fff67493641 abort_message + 231
4   libc++abi.dylib                  0x00007fff674937c7 default_terminate_handler() + 243
5   libobjc.A.dylib                  0x00007fff68a46eeb _objc_terminate() + 105
6   libc++abi.dylib                  0x00007fff6749f19e std::__terminate(void (*)()) + 8
7   libc++abi.dylib                  0x00007fff6749ef86 __cxxabiv1::failed_throw(__cxxabiv1::__cxa_exception*) + 27
8   libc++abi.dylib                  0x00007fff67491f99 __cxa_throw + 113
9   Pigments                         0x000000010cc6c448 0x10c0b0000 + 12305480
10  Pigments                         0x000000010c0dfdb1 0x10c0b0000 + 196017
11  Pigments                         0x000000010c0dfa94 0x10c0b0000 + 195220
12  Pigments                         0x000000010c0dcb6a 0x10c0b0000 + 183146
13  Pigments                         0x000000010ca91e96 0x10c0b0000 + 10362518
14  Pigments                         0x000000010cbf69db 0x10c0b0000 + 11823579
15  Pigments                         0x000000010ca91caa 0x10c0b0000 + 10362026
16  Pigments                         0x000000010ca91c23 0x10c0b0000 + 10361891
17  Pigments                         0x000000010c0b7104 0x10c0b0000 + 28932

Thread 1:
0   libsystem_pthread.dylib          0x00007fff6a4053f0 start_wqthread + 0

Thread 2:
0   libsystem_pthread.dylib          0x00007fff6a4053f0 start_wqthread + 0

Thread 3:
0   libsystem_pthread.dylib          0x00007fff6a4053f0 start_wqthread + 0

Thread 0 crashed with X86 Thread State (64-bit):
  rax: 0x0000000000000000  rbx: 0x0000000112f055c0  rcx: 0x00007ffee3b4e798  rdx: 0x0000000000000000
  rdi: 0x0000000000000307  rsi: 0x0000000000000006  rbp: 0x00007ffee3b4e7d0  rsp: 0x00007ffee3b4e798
   r8: 0x00007ffee3b4e660   r9: 0x00000000000007fb  r10: 0x0000000000000000  r11: 0x0000000000000206
  r12: 0x0000000000000307  r13: 0x0000003000000008  r14: 0x0000000000000006  r15: 0x000000000000002d
  rip: 0x00007fff6a34d2c6  rfl: 0x0000000000000206  cr2: 0x00007fffa0b78188
 
Logical CPU:     0
Error Code:      0x02000148
Trap Number:     133



External Modification Summary:
  Calls made by other processes targeting this process:
    task_for_pid: 0
    thread_create: 0
    thread_set_state: 0
  Calls made by this process:
    task_for_pid: 0
    thread_create: 0
    thread_set_state: 0
  Calls made by all processes on this machine:
    task_for_pid: 266
    thread_create: 0
    thread_set_state: 0

VM Region Summary:
ReadOnly portion of Libraries: Total=462.4M resident=0K(0%) swapped_out_or_unallocated=462.4M(100%)
Writable regions: Total=558.6M written=0K(0%) resident=0K(0%) swapped_out=0K(0%) unallocated=558.6M(100%)
 
                                VIRTUAL   REGION
REGION TYPE                        SIZE    COUNT (non-coalesced)
===========                     =======  =======
Activity Tracing                   256K        1
CoreUI image file                  332K        3
Kernel Alloc Once                    8K        1
MALLOC                           164.2M       17
MALLOC guard page                   16K        4
MALLOC_NANO (reserved)           384.0M        1         reserved VM address space (unallocated)
STACK GUARD                       56.0M        4
Stack                             9752K        4
VM_ALLOCATE                         44K        2
__DATA                            31.2M      274
__FONT_DATA                          4K        1
__LINKEDIT                       222.9M        3
__TEXT                           239.5M      272
__UNICODE                          564K        1
mapped file                       41.2M        7
shared memory                      632K        9
===========                     =======  =======
TOTAL                              1.1G      604
TOTAL, minus reserved VM space   766.4M      604

Model: MacBookPro12,1, BootROM 184.0.0.0.0, 2 processors, Intel Core i5, 2.7 GHz, 8 GB, SMC 2.28f7
Graphics: kHW_IntelIris6100Item, Intel Iris Graphics 6100, spdisplays_builtin
Memory Module: BANK 0/DIMM0, 4 GB, DDR3, 1867 MHz, 0x80CE, 0x4B3445364533303445452D45474346000000
Memory Module: BANK 1/DIMM0, 4 GB, DDR3, 1867 MHz, 0x80CE, 0x4B3445364533303445452D45474346000000
AirPort: spairport_wireless_card_type_airport_extreme (0x14E4, 0x133), Broadcom BCM43xx 1.0 (7.77.61.2 AirPortDriverBrcmNIC-1305.8)
Bluetooth: Version 6.0.12f1, 3 services, 27 devices, 1 incoming serial ports
Network Service: Wi-Fi, AirPort, en0
Serial ATA Device: APPLE SSD SM0256G, 251 GB
USB Device: USB 3.0 Bus
USB Device: Bluetooth USB Host Controller
Thunderbolt Bus: MacBook Pro, Apple Inc., 27.1

LBH

  • Hero Member
  • *****
  • Posts: 2.335
  • Karma: 50
Re: Pigments demo doesnt launch in Mojave
« Reply #3 on: August 03, 2019, 04:14:53 pm »
To me it look like you have a permission issue regarding the library.
I can't help with that, as i'm not a MAC user.

You did'nt tell what ASC tells about status. But if you are running demos, and if you can't fix the permission issue, then i suggest you contact Arturia support and/ or perhaps find som Apple support about issues like this.

inn3rs3lf

  • Apprentice
  • *
  • Posts: 8
  • Karma: 0
Re: Pigments demo doesnt launch in Mojave
« Reply #4 on: August 05, 2019, 05:57:09 pm »
Got this sorted via the helpdesk.

Thank you so much guys!

LBH

  • Hero Member
  • *****
  • Posts: 2.335
  • Karma: 50
Re: Pigments demo doesnt launch in Mojave
« Reply #5 on: August 05, 2019, 06:00:44 pm »
Got this sorted via the helpdesk.

Thank you so much guys!
I'm only one person. But great it work now. Thaks for reporting back. It's allways good a thread show if things is solved and how.

 

Carbonate design by Bloc
SMF 2.0.13 | SMF © 2016, Simple Machines