December 09, 2019, 05:13:49 pm
Welcome, Guest. Please login or register.
Did you miss your activation email
News:

Arturia Forums



Author Topic: KS should please stop on DAW/MIDI Stop (instead of PAUSE)  (Read 324 times)

MultipleChoice

  • Apprentice
  • *
  • Posts: 16
  • Karma: 1
KS should please stop on DAW/MIDI Stop (instead of PAUSE)
« on: June 08, 2019, 07:27:14 pm »
Even if you have got a BSP as your Master and your KS as slave - if you press stop on your master, the other KS/BSP devices only pause by design (support confirmed this).

So every time you restart a pattern, you have to mind to press stop on all Arturia KS/BSP devices, otherwise their starting position is off...

Interestingly, the KS/BSP interprets song position commands and skips to the right position if the DAW is started in the middle of a loop. But only, if you press stop on the slaves beforehand.

If you have to restart many times during a production, it can be frustrating if you keep forgetting to press stop on each of your Arturia devices synced.

jaytee

  • Apprentice
  • Apprentice
  • *
  • Posts: 12
  • Karma: 0
Re: KS should please stop on DAW/MIDI Stop (instead of PAUSE)
« Reply #1 on: July 19, 2019, 09:29:05 pm »
I am also having trouble with this.

When using the sync output for DIN sync, I am running into an issue where stopping in my DAW pauses Keystep instead of stopping (as described above). Unfortunately, it seems like while paused, the “start/stop” DIN sync line remains high. The result is that my MC-202 will stop wherever it is, even if a note is left hanging, and when I hit play in my DAW again, it starts where it left off instead of restarting. The only workaround I’ve found is to hit stop on my DAW, and then also hit stop on my Keystep.

It would be nice to have the option to change this behavior, either by giving the option for a MIDI stop message to trigger a full stop on the Keystep instead of a pause, or giving the option to allow the “pause” state on the Keystep to bring the sync “start/stop” line low.

I realize this is not the default behavior for most MIDI devices, but the Keystep seems to be marketed primarily on its versatility. I think one or both of the above options would go a long way toward making the Keystep the best possible “brain” for mixed sync/CV/MIDI setups.

gajimicu

  • Apprentice
  • Apprentice
  • *
  • Posts: 7
  • Karma: 0
Re: KS should please stop on DAW/MIDI Stop (instead of PAUSE)
« Reply #2 on: August 30, 2019, 07:58:25 am »
I second this,
I use my keystep with my beatstep pro and when pressing stop on the BSP the Keystep just pauses so I have to press stop on the keystep before I start again, which if you forget to do that between two songs, next song you start is gonna be un-synchronized. Very frustrating!!

fenin

  • Apprentice
  • Apprentice
  • *
  • Posts: 40
  • Karma: 0
Re: KS should please stop on DAW/MIDI Stop (instead of PAUSE)
« Reply #3 on: August 31, 2019, 05:00:43 pm »
are you on latest firmware..
(the update came out just some weeks ago) ?

i think they fixed this ,
when recieve "stop"
keystep will start then on first position...

from update list:
"Start in sync after a stop from master when Midi Slaved"
« Last Edit: August 31, 2019, 05:03:30 pm by fenin »
keep on dubbin

lake33

  • Apprentice
  • *
  • Posts: 13
  • Karma: 0
Re: KS should please stop on DAW/MIDI Stop (instead of PAUSE)
« Reply #4 on: December 03, 2019, 03:05:01 am »
It appears this feature isn't working. I'm using two keysteps and the slave still defaults to pause when stop is pressed on the master.

 

Carbonate design by Bloc
SMF 2.0.13 | SMF © 2016, Simple Machines