September 19, 2019, 11:10:40 pm
Welcome, Guest. Please login or register.
Did you miss your activation email
News:

Arturia Forums



Author Topic: Strange Colored Shapes Appearing--Graphical Bug?  (Read 427 times)

croakascagbaron

  • Apprentice
  • *
  • Posts: 12
  • Karma: 0
Strange Colored Shapes Appearing--Graphical Bug?
« on: May 14, 2019, 05:59:18 pm »
Frequently while playing I get strange colored shapes and lines that cut diagonally across the interface at different angles sometimes completely obscuring, sometimes translucent. I can make them go away by opening any menu or something that "refreshes" the screen. This happens both in Ableton and stand-alone and it seems to happen randomly. I've done a re-install and the problem persists. V-Col synths all run completely fine.

I'm running Windows 10 on an Acer laptop. Has anyone else experienced this?


edit: I'll add an image of the anomaly when I get home--I thought I had saved it to my phone but that is not the case.
« Last Edit: May 14, 2019, 06:05:31 pm by croakascagbaron »

LBH

  • Hero Member
  • *****
  • Posts: 2.336
  • Karma: 50
Re: Strange Colored Shapes Appearing--Graphical Bug?
« Reply #1 on: May 15, 2019, 12:14:25 am »
If possible - Then a screenshot of what you mean would be great?

It does'nt sound like the modulation display animations.

Have you updated you Ableton, Pigments and Graphic driver?

Have you tried to uninstall before you reinstall?
« Last Edit: May 15, 2019, 12:35:31 am by LBH »

croakascagbaron

  • Apprentice
  • *
  • Posts: 12
  • Karma: 0
Re: Strange Colored Shapes Appearing--Graphical Bug?
« Reply #2 on: May 15, 2019, 01:08:21 pm »
I'll post a screenshot this evening--I wasn't able to get to my computer last night. I did a complete un-install before reinstalling but did not think to update my graphics driver so I will give that a shot and report back.

croakascagbaron

  • Apprentice
  • *
  • Posts: 12
  • Karma: 0
Re: Strange Colored Shapes Appearing--Graphical Bug?
« Reply #3 on: May 15, 2019, 11:44:16 pm »
I have updated my gpu driver and the problem persists. I was using it just now and everything was fine for a few minutes up until I tried applying LFO2 to the cutoff via dragging the knob. It seems to happen more frequently when I go to apply modulation to a destination.

Here are two images, let me know if you need any other information.




LBH

  • Hero Member
  • *****
  • Posts: 2.336
  • Karma: 50
Re: Strange Colored Shapes Appearing--Graphical Bug?
« Reply #4 on: May 16, 2019, 12:33:29 am »
Strange.

If Pigments is the only application where you exsperience this, then i suggest you contact Arturia support directly through your Arturia account.

If you have issues with other applications, then it might be your Graphics that have some kind of issue, - or your screen.

Are you sure your Graphics have the specifications to run Pigments? It has to be a at least OpenGL 2.0 compatible GPU.

croakascagbaron

  • Apprentice
  • *
  • Posts: 12
  • Karma: 0
Re: Strange Colored Shapes Appearing--Graphical Bug?
« Reply #5 on: May 16, 2019, 12:46:05 am »
The laptop is running intel HD Graphics 520 which as far as I can tell supports OpenGL 4.4. Pigments is the only software I've ever seen this happen to.

CC4

  • Beta-testers
  • Sr. Member
  • *
  • Posts: 269
  • Karma: 18
Re: Strange Colored Shapes Appearing--Graphical Bug?
« Reply #6 on: May 16, 2019, 03:52:16 am »
Have you tried the checking the Intel Driver & Support Assistant for an updated driver?

croakascagbaron

  • Apprentice
  • *
  • Posts: 12
  • Karma: 0
Re: Strange Colored Shapes Appearing--Graphical Bug?
« Reply #7 on: May 17, 2019, 01:36:21 pm »
It was definitely something fishy with my computer because I believe I have fixed the issue by doing a full system update (which took about an hour to complete). I was able to dink around in Pigments last night for a while without the anomaly appearing.

As for now, everything seems to be working as it should be; I'll report back if it crops up again...

Thanks!

LBH

  • Hero Member
  • *****
  • Posts: 2.336
  • Karma: 50
Re: Strange Colored Shapes Appearing--Graphical Bug?
« Reply #8 on: May 17, 2019, 04:23:27 pm »
Thanks for reporting back.

I think it's the most logic explanation, that this was a local issue. Just strange if only Pigments was affected.

Good luck.

1Composer

  • Newbie
  • Apprentice
  • *
  • Posts: 21
  • Karma: 0
Re: Strange Colored Shapes Appearing--Graphical Bug?
« Reply #9 on: May 18, 2019, 10:18:36 am »
Almost certain that when you did a new install, the latest Intel graphics driver got utilized and that's the fix.

I had the exact same problem with all of the Collection V v.6 this past December.   All of the synth plugins actually worked, but the graphics were so mangled (just like your images you uploaded) that I could barely use them.

I went into Device Manager (Windows 7 Pro 64-bit) and elected to update the driver by allowing the system to search online.  30 seconds later, after the update succeeded, everything graphically in the Arturia Collection was fixed.

 

Carbonate design by Bloc
SMF 2.0.13 | SMF © 2016, Simple Machines