November 17, 2019, 08:36:57 am
Welcome, Guest. Please login or register.
Did you miss your activation email
News:

Arturia Forums



Author Topic: Syncing to OP-Z over USB?  (Read 453 times)

robochase6000

  • Apprentice
  • *
  • Posts: 3
  • Karma: 0
Syncing to OP-Z over USB?
« on: May 13, 2019, 09:13:13 am »
Has anyone gotten this to work well? And if so, could you share both your Microfreak settings + your OP-Z midi json?

I've been messing with this for a few hours today and I can't get these two pieces of equipment to cooperate at all. It's hard for me to really even tell if I'm encountering bugs with one or both pieces of equipment, and I'm frankly pretty much a complete noob when it comes to syncing any kind of gear like this 8)

Germain.arturia

  • Administrator
  • Sr. Member
  • *****
  • Posts: 336
  • Karma: 15
  • arturia test team
Re: Syncing to OP-Z over USB?
« Reply #1 on: May 14, 2019, 02:33:14 pm »
HI robochase6000,
yes some people have reported sync issues with Teenage Engineering devices.
We're currently investigating.
thanks,


Germain.arturia

  • Administrator
  • Sr. Member
  • *****
  • Posts: 336
  • Karma: 15
  • arturia test team
Re: Syncing to OP-Z over USB?
« Reply #2 on: May 14, 2019, 02:44:17 pm »
for the microfreak to master of OP-Z, i would suggest to
 
activate incoming midi clock on opz (with shift +4?)

connect microfreak midi out to opz midi in

on microfreak go in utility/sync/source and set it to "auto" or  internal

******
and if you want the contrary

activate outgoing midi clock on op-z (shift +5?)
connect op-z midi out to microfreak midi in

on the microfreak go in utility/sync/source and set it to "auto" or midi.


robochase6000

  • Apprentice
  • *
  • Posts: 3
  • Karma: 0
Re: Syncing to OP-Z over USB?
« Reply #3 on: May 15, 2019, 04:40:13 am »
Hey thanks, I got this working kinda. So far I've only been able to get the OPZ to control the microfreak over USB which is all i was actually interested in, so 8)

So here's the settings for that if anyone else needs it -

OPZ
go to the MIDI Setup page in the App (or go to the module track (track 14 i believe).  Only check these options, everything else should be disabled I think (I'm not sure what half of these do even)
"Midi Out Enable" - Shift+3 on the OPZ
"Clock Out Enable" - Shift+5 on the OPZ

Microfreak
Utility/Sync/Source - can be USB or Auto
The Input channel you set on the Microfreak is important, and as far as I can tell, doesn't map up with the tracks on the OPZ.  it's possible my MIDI json is messed up on the OPZ, I'll have to take a look, but i get something like the following -

The melody Track on the OPZ (Track #6) is Input Channel 1 on my microfreak
The hi-hat track on the OPZ (Track #3) is Input Channel 6 on my microfreak (i think)

The other input channels are similarly mixed up.  I haven't had time to make a proper mapping of it yet. So yeah basically...once you get the MIDI settings right, set up a sequence on a track on the OPZ, and just keep changing the Input channel on the microfreak til you hear it coming through and you should be in business.

Germain.arturia

  • Administrator
  • Sr. Member
  • *****
  • Posts: 336
  • Karma: 15
  • arturia test team
Re: Syncing to OP-Z over USB?
« Reply #4 on: May 15, 2019, 09:11:51 am »
ok thanks robochase6000,
glad a solution has been found. I keep this info in mind
We're still investigating regarding pocket operators.
cheers,

robochase6000

  • Apprentice
  • *
  • Posts: 3
  • Karma: 0
Re: Syncing to OP-Z over USB?
« Reply #5 on: May 18, 2019, 05:18:19 pm »
OK, at this point i've figured out most of the MIDI config issues I was having. Most of it was me not able to decipher what the MIDI config page on the OPZ was all about. I may try to make a video/writeup about it if I have time, because it's actually quite simple once you understand what's going on.

However, I'm not having much luck playing the keyboard on the microfreak and having that come through clean on the OPZ.  The OPZ is picking up on notes, but the best way I can describe it is that it feels...weak and laggy.  Tapping the PCB keyboard on the microfreak, you'll hear it play on the OPZ maybe 100ms later. It's also really bad at detecting when you've released your finger, and in general the sounds seem kind of muffled in a way. reminder, I'm using a direct USB connection here. perhaps a proper MIDI connect would be better, but I don't have the MIDI module thing for the OPZ right now :/

Any ideas on how to fix this up?  It would be very cool to lay down a beat on the OPZ, then play a lead on the Microfreak and have the OPZ reliably record those notes for playback through the Microfreak synth. Holler also if you think this is more of a problem with the OPZ...I can try their support maybe 8)
« Last Edit: May 18, 2019, 05:20:35 pm by robochase6000 »

 

Carbonate design by Bloc
SMF 2.0.13 | SMF © 2016, Simple Machines