May 24, 2019, 08:55:17 pm
Welcome, Guest. Please login or register.
Did you miss your activation email
News:

Arturia Forums



Author Topic: List of MicroFreak issues  (Read 420 times)

NullDivision

  • Newbie
  • *
  • Posts: 2
  • Karma: 0
List of MicroFreak issues
« on: May 10, 2019, 08:25:59 am »
Hello! I thought I would take the time to list out a few of the issues I've noticed with my MicroFreak in hopes to help Arturia prepare for the next update. But first off I just want to say that so far I'm in love with this synth!!! It really has been amazing and so far one of my favorites! I'm not sure if all these quirks are happening on all the MicroFreak's but this is what I've seen so far.

Before getting started; All the issues I'm listing I've noticed while the MicroFreak has been plugged into the AC power supply and while the device is unplugged from all other external devices (Midi, clock, cv/gate, and USB). Also I've noticed these issues both before and after doing a factory reset and a re-install of the current drivers.

So on to the quirk's.

1.Random potentiometer triggers: I've noticed that randomly some of the potentiometers will trigger, the values dont always change but I have noticed some occasional changes (+/- .01) in the Riser time and the Matrix encoder. I've also noticed this happening on other peoples MicroFreaks (specifically on ones people were reviewing on Youtube).

2. Analog Filter cutoff: When adjusting the cuffoff amount to the left the cutoff will stay for a few seconds then snap to right within a few seconds from being adjusted. This seems to happen on all three of the modes (LPF, BPF, HPF).

3. Envelope and Cutoff Patchpoint: This is probably one of the weirdest I've seen, but basically I've noticed the MicroFreak will add a patch at the Env/cutoff point on the matrix on its own after playing a few keys. I've noticed this both on presets that do not have this patch point (Preset #29 for example) and also on -int- presets.

4. Save button flashing: Personally I feel this is only happening because of the other issue's with the random potentiometer triggers, but basically the save button will flash occasionally, and usually right after the display shows either the riser time or the env/cutoff matrix amount.

Anyways hope this helps other user's in identifying these problems on their own devices, and more impotently I hope this helps Arturia identify the issues for the future firmware updates.

Thanks  :)

Germain.arturia

  • Administrator
  • Sr. Member
  • *****
  • Posts: 338
  • Karma: 15
  • arturia test team
Re: List of MicroFreak issues
« Reply #1 on: May 10, 2019, 11:17:39 am »
Hello Nulldivision, and welcome on this board.
Thanks for your detailed report.


Quote
Random potentiometer triggers: I've noticed that randomly some of the potentiometers will trigger, the values dont always change but I have noticed some occasional changes (+/- .01) in the Riser time and the Matrix encoder. I've also noticed this happening on other peoples MicroFreaks (specifically on ones people were reviewing on Youtube).

yes we're aware of this, and devs are currently working on a firmware fix. Can't give any expected release date, sorry, but it will be shared asap.

Quote
Analog Filter cutoff: When adjusting the cuffoff amount to the left the cutoff will stay for a few seconds then snap to right within a few seconds from being adjusted. This seems to happen on all three of the modes (LPF, BPF, HPF).

It seems a consequence of the issue above

Quote
Envelope and Cutoff Patchpoint: This is probably one of the weirdest I've seen, but basically I've noticed the MicroFreak will add a patch at the Env/cutoff point on the matrix on its own after playing a few keys. I've noticed this both on presets that do not have this patch point (Preset #29 for example) and also on -int- presets.
Please note that if you turn env filter amount knob, it will "create" the connection "env to cutoff" on the matrix, because this is what is really happening inside. But when it does it by itself, it is again a consequence of issue 1

Quote
Save button flashing: Personally I feel this is only happening because of the other issue's with the random potentiometer triggers, but basically the save button will flash occasionally, and usually right after the display shows either the riser time or the env/cutoff matrix amount.

The purpose of making save button quickly blink when turning knobs, is to tell user that the knob reached the value which was stored in the preset. But you're right, when phenomenon occurs by itself, it can be a consequence of issue 1

Thanks for your interest,
cheers,

fano

  • Newbie
  • *
  • Posts: 2
  • Karma: 0
Re: List of MicroFreak issues
« Reply #2 on: May 10, 2019, 01:57:15 pm »
Hey there !

I may have spotted another (minor) bug : when you switch the "panel button" On or Off, the message displayed is still the same : "Panel On" ...

bonym

  • Apprentice
  • *
  • Posts: 3
  • Karma: 0
Re: List of MicroFreak issues
« Reply #3 on: May 13, 2019, 07:45:47 pm »
Now 1.1.2 has been released can we update the issues people are having?

Quote
V 1.1.2
New features
Spice / Dice improvement: Now affects the envelope decay, release and matrix pressure value.
Added program change support
Local control and external CC handling improvement
Real-time recording now enabled when starting the sequencer from the step-recording mode
Matrix amount reset now set to 0.5 seconds instead of 1 second
Bug fixes
Potentiometers stability improvement
MIDI start/stop handling improvement
CPU management and Sync improvement
Negative automation amounts now properly handled
Aftertouch + arpeggiator handling improvement
Real-time recording improvements
Song position pointer sync now preserved upon preset change when slaved
Preset browsing improvement in panel mode
Automatic sync source detection improvement
Parameters initialization improvement on power-up
Sequencer improvements in USB Sync
Arpeggiator to sequencer pattern transfer improvement
Real-time automation recording improvement
Gate length display now accurate
Step-recording display now visible when utility is enabled
Cycling envelope timing display now accurate
Step-browsing display is now refreshed when cycling through Mod slots
Matrix assign display improvements

NullDivision

  • Newbie
  • *
  • Posts: 2
  • Karma: 0
Re: List of MicroFreak issues
« Reply #4 on: May 15, 2019, 05:59:17 am »
Thanks so much Arturia for the quick response and resolve time on the prior MicroFreak issues!!

019297

  • Full Member
  • ***
  • Posts: 101
  • Karma: 2
Re: List of MicroFreak issues
« Reply #5 on: May 15, 2019, 07:53:38 am »
Nice firmware update. The only problem now is the panel mode button is kinda weird now. Or is it supposed to act like this now?

fano

  • Newbie
  • *
  • Posts: 2
  • Karma: 0
Re: List of MicroFreak issues
« Reply #6 on: May 15, 2019, 09:51:33 am »
Definitely a VERY nice update that resoled most of the issues I could have spotted ...

Same question here about the "panel" button which now acts in a really weird way (or does not act at all) ...

bonym

  • Apprentice
  • *
  • Posts: 3
  • Karma: 0
Re: List of MicroFreak issues
« Reply #7 on: May 15, 2019, 07:12:06 pm »
It seems I am still having some petentiometer problems:

I have attached my midi messages and I have a video of the issue here: https://youtu.be/ZlTD4s25QoQ


bonym

  • Apprentice
  • *
  • Posts: 3
  • Karma: 0
Re: List of MicroFreak issues
« Reply #8 on: May 15, 2019, 07:21:55 pm »
An even better example: https://youtu.be/4AcMMoKvizI?t=123

fede bts

  • Apprentice
  • Apprentice
  • *
  • Posts: 40
  • Karma: 3
Re: List of MicroFreak issues
« Reply #9 on: May 15, 2019, 08:17:06 pm »

Same question here about the "panel" button which now acts in a really weird way (or does not act at all) ...

My microfreak has just  arrived. Whenever I am playing a preset, if I press the panel button (which does not stay lit but just flashes once) it turns panel on. If I press it again it doesn't deactivate panel mode, as it does in Matrixbrute, but stays in panel mode. The only solution is to change preset and then reloading it again

Germain.arturia

  • Administrator
  • Sr. Member
  • *****
  • Posts: 338
  • Karma: 15
  • arturia test team
Re: List of MicroFreak issues
« Reply #10 on: May 16, 2019, 11:40:43 am »
Hi everyone on this group. a few words regarding the panel mode, as it is now perceived as buggy for many users all around the world, since the fw 1.1.2 update. I already posted an explanation about this "new" behavior on the main gearslutz thread :

You press this button, preset sound changes accordingly to knobs (pots, not encoders, nor master volume) physical position. The panel button itself now behaves in a "gate" mode. this is exactly what is perceived as a bug , because on previous fw 1.0.5, it behaved in a "toggle" way.

Please consider that the only way to "exit" panel mode, is to load another preset.

I hope this is clearer for you all now. but for sure, for a future update, let's consider this panel mode and other stuff (we've got LOTS of feature requests internally logged).

019297

  • Full Member
  • ***
  • Posts: 101
  • Karma: 2
Re: List of MicroFreak issues
« Reply #11 on: May 17, 2019, 12:43:31 am »
so If i want to stay in panel mode, but want to load another preset (with a new sound or new sequence saved) I have to load the preset first, THEN press panel again every time?

 I guess I can get used to is, but I feel like the old mode was better. If panel was lit, you know the knob positions are what you hear. now the light on the button doesn't serve much of a purpose.

I guess there are cons to both ways it works. Maybe in the future this behavior can be selectable by user in the MCC software?

Pips

  • Apprentice
  • *
  • Posts: 3
  • Karma: 0
Re: List of MicroFreak issues
« Reply #12 on: May 18, 2019, 08:45:57 pm »
The knobs randomly turning on their own is not fixed in the latest firmware.

I was just playing an arp from a preset, and the Filter Amt knob "updated" to it's current position and changed the entire sound while only a single key was being held.

Edit: Please make a better capatcha having to type in these fking letters 10 times just to post on a support forum is BS.

Pips

  • Apprentice
  • *
  • Posts: 3
  • Karma: 0
Re: List of MicroFreak issues
« Reply #13 on: May 19, 2019, 12:12:44 am »
Looking into this more. The manual states that "hook" mode is default, and a knob that is turned should not change anything until you turn to the set amount that the preset loads with.

1. The default for mine was "scale".

2. Hook works for some knobs. But NOT "Filter Amt". This is where the random bug of the pentometers moving will alter the sound drastically. Hook needs to work with "Filter Amt".


Germain.arturia

  • Administrator
  • Sr. Member
  • *****
  • Posts: 338
  • Karma: 15
  • arturia test team
Re: List of MicroFreak issues
« Reply #14 on: May 20, 2019, 10:46:19 am »
Hi everyone,
@pips : yes the current manual contains some errors regarding many topics. Default knob catch mode is scaled. Internal update is currently ongoing, should be released soon.
About the filter amount knob, yes we already confirmed that knob catch mode has no impact for it (always behaving as jump), neither panel mode.

@everyone : i lock this topic, as it is quite hard to take care of different issues inside some generic topic. Thanks in advance for opening one topic per issue.

cheers,

 

Carbonate design by Bloc
SMF 2.0.13 | SMF © 2016, Simple Machines