July 19, 2019, 09:13:36 pm
Welcome, Guest. Please login or register.
Did you miss your activation email
News:

Arturia Forums



Author Topic: Maschine 2.8.2 and Arturia issues  (Read 527 times)

ps003

  • Apprentice
  • *
  • Posts: 4
  • Karma: 0
Maschine 2.8.2 and Arturia issues
« on: April 29, 2019, 06:11:03 pm »
Mac OSX 10.14.4 Mojave
iMac Pro 2017 - 64GB - 18 Cores

Maschine attempts to open the last song I was using and then crashes. I've attached the most recent crash log.

The song worked right before an Arturia update, but another song had a similar issue with an Arturia plugin (Matrix-12)a few weeks ago.

To get the song(s) to open, I go into the Arturia centralized plugin app and uninstall the offending plugin. Then open Maschine again. I repeat this until all plugs that cause an issue are removed and then the song will open.

The first time it was the Buchla-Easel-V.vst3. Then after removing that I see similar errors with the Mini-V3.vst3 as well as the AU component. I copied just the error part.

(
Terminating Process: exc handler [9071]

Thread 0 Crashed:: Dispatch queue: com.apple.main-thread
0 com.Arturia.Mini-V3.vst3 0x0000000153f08e6f 0x153d98000 + 1511023
1 com.Arturia.Mini-V3.vst3 0x0000000153f07702 0x153d98000 + 1505026
2 com.Arturia.Mini-V3.vst3 0x0000000153eed1c6 0x153d98000 + 1397190
3 com.arturia.component.Mini-V3 0x000000014c95e891 0x14c945000 + 104593
4 com.arturia.component.Mini-V3 0x000000014c96758e 0x14c945000 + 140686
5 com.arturia.component.Mini-V3 0x000000014c94e2ee 0x14c945000 + 37614
)

I've had to remove 3 Arturia plugins for this song to open.

To me this seems like Arturia, but didn't the plugs have to pass validation?

I'm open to any suggestions. Thanks in advance for any guidance. I've posted the same in the NI forum.

LBH

  • Hero Member
  • *****
  • Posts: 2.230
  • Karma: 50
Re: Maschine 2.8.2 and Arturia issues
« Reply #1 on: April 29, 2019, 07:09:14 pm »
Hi and welcome to Arturia forums.

I'm not a Machine user and don't know much about it. But afaik it does'nt support VST3 plugins does it?
If Machine does'nt support VST3 plugins, then why are you having a path to VST3 plug-ins? I would remove the path to VST3 plugins if Machine does'nt support them.
« Last Edit: April 29, 2019, 07:22:52 pm by LBH »

ps003

  • Apprentice
  • *
  • Posts: 4
  • Karma: 0
Re: Maschine 2.8.2 and Arturia issues
« Reply #2 on: April 29, 2019, 09:24:14 pm »
Yeah a similar question was asked on the Maschine forum, and all I can say is that the VST3 plugin folder isn't in the path and yet I get those errors.
And it seems to be a red-herring b/c only a couple of the plugins cause issues.

LBH

  • Hero Member
  • *****
  • Posts: 2.230
  • Karma: 50
Re: Maschine 2.8.2 and Arturia issues
« Reply #3 on: April 29, 2019, 09:54:22 pm »
How is it possible for Machine to scan VST3 plugins, if they are'nt on a path Machine is reading?

ps003

  • Apprentice
  • *
  • Posts: 4
  • Karma: 0
Re: Maschine 2.8.2 and Arturia issues
« Reply #4 on: April 29, 2019, 10:35:20 pm »
Sadly, I can't answer that question. I can only tell you what I see in the logs and preference files.
I do appreciate the statement b/c they do seem contradictory.

Termination Signal:    Trace/BPT trap: 5
Termination Reason:    Namespace SIGNAL, Code 0x5
Terminating Process:   exc handler [10985]

Thread 0 Crashed:: Dispatch queue: com.apple.main-thread
0   com.Arturia.Buchla-Easel-V.vst3   0x0000000150172996 0x1500f0000 + 534934
1   com.Arturia.Buchla-Easel-V.vst3   0x000000015017b8b8 0x1500f0000 + 571576

and this is the preferences:

LBH

  • Hero Member
  • *****
  • Posts: 2.230
  • Karma: 50
Re: Maschine 2.8.2 and Arturia issues
« Reply #5 on: April 30, 2019, 12:18:45 am »
Something is wrong if Machine read files in folders it's not set to read. That should not be possible.
 
I'm on windows. And my Arturia VST2 plug-ins does'nt seem to report they are VST3.
So this looks like some kind of install issue. It could perhaps also be a computer bug somehow.

This is what i would ask my self to troubleshoot.

In which folder/ which path are your vst3s installed? Where are your vst2s installed?
Is the paths the same Machine read? The paths you show does'nt tell me, if the plugins is in there or not. Have you checked?

How do you install and how do you update? What is your install paths for your different plug-ins?
Are you moving anything manually after you have installed? If so to where?
Do you have multiple paths to different folder that have the same plug-in inside?
Are old versions of plugins removed?

I can't tell what the numbers in the crash log means. I wonder why there are multiple lines about an applications with the same file extension.

And as i don't use Machine, then i can't tell if there are some settings to look at in there.

Sometimes strange things happens. But i would trubleshoot.

If Arturias plug-ins for some reason give wrong informations on a MAC, then i can't tell. Perhaps other MAC users would report if so.

Vesaa

  • Newbie
  • *
  • Posts: 1
  • Karma: 0
Re: Maschine 2.8.2 and Arturia issues
« Reply #6 on: May 14, 2019, 05:50:19 am »
Hi, I'm only trying to help, not thread hi-jacking...
I have a similar problem with Logic Pro X and Cs-80 plug-in.
Logic does not use vst3's, still the CS-80 crashes a project.
Like this:
Process:               Logic Pro X [2608]
Path:                  /Applications/Logic Pro X.app/Contents/MacOS/Logic Pro X
Identifier:            com.apple.logic10
Version:               10.4.4 (4981.1)
Build Info:            MALogic-4981001000000000~2
App Item ID:           634148309
App External ID:       829681282
Code Type:             X86-64 (Native)
Parent Process:        ??? [1]
Responsible:           Logic Pro X [2608]
User ID:               501

PlugIn Path:             /Library/Audio/Plug-Ins/Components/CS-80 V3.component/Contents/Resources/plugin.vst3/Contents/MacOS/CS-80 V3
PlugIn Identifier:       com.Arturia.CS-80-V3.vst3
PlugIn Version:          3.4.0.2695 (3.4.0.2695)

Date/Time:             2019-05-14 06:59:00.035 +0300
OS Version:            Mac OS X 10.14.1 (18B75)
Report Version:        12
Bridge OS Version:     3.0 (14Y667)

Is there any news on your problem?

LBH

  • Hero Member
  • *****
  • Posts: 2.230
  • Karma: 50
Re: Maschine 2.8.2 and Arturia issues
« Reply #7 on: May 14, 2019, 01:57:37 pm »
Hi and welcome to Arturia forums.

PlugIn Path:             /Library/Audio/Plug-Ins/Components/CS-80 V3.component/Contents/Resources/plugin.vst3/Contents/MacOS/CS-80 V3
Why does this path seems to be to a folder for VST3 plugins, if there is'nt VST3 plugins in it?

PlugIn Identifier:       com.Arturia.CS-80-V3.vst3
This file extension say it's a VST3 plugin. Are you saying it is'nt a VST3 plugin, and if so - how can you tell?

Bridge OS Version:     3.0 (14Y667)
May i ask what this Bridge is?

Do you run 64 bit OS and applications?
Arturia no longer have 32 bit plugins. It has been dropped for the latest updates.

 

Carbonate design by Bloc
SMF 2.0.13 | SMF © 2016, Simple Machines