April 19, 2019, 04:53:50 am
Welcome, Guest. Please login or register.
Did you miss your activation email
News:

Arturia Forums



Author Topic: Minibrute only shows red light over Rate knob when turned on  (Read 161 times)

realtrance

  • Apprentice
  • *
  • Posts: 3
  • Karma: 0
Minibrute only shows red light over Rate knob when turned on
« on: March 16, 2019, 09:04:35 pm »
Hi,

My MB was working fine for years, then I went to replace the sticky side panel (got a new one from Arturia awhile ago), and when I turned it back on, I only get a red, continuous light on the Rate knob, nothing else.

Have checked the KBD-Gate switch, not a factor.

Won't be recognized via USB.

Any suggestions? I have contacted Arturia via email re: this, I'm hoping someone has an idea. Have opened and attempted to reposition the cables, they seem tight so that's not it (also not crushed by reassembly).

Thanks,

RT

realtrance

  • Apprentice
  • *
  • Posts: 3
  • Karma: 0
Re: Minibrute only shows red light over Rate knob when turned on
« Reply #1 on: March 16, 2019, 11:17:22 pm »
Okay, update on this: apparently I apparently lifted a transistor off the mainboard with one of the blue-white wires inside when removing the I/O daughterboard to make sure the cable was on right upon reassembly.

So..... one dead MiniBrute to report.

Can't afford it, but purchased an MB2 to replace it, which I hope has the same characteristic sound and oscillator mixing options!

Nothing for Arturia to do except weep with me for the demise of my Minibrute.

 

Carbonate design by Bloc
SMF 2.0.13 | SMF © 2016, Simple Machines