September 21, 2019, 11:10:32 am
Welcome, Guest. Please login or register.
Did you miss your activation email
News:

Arturia Forums



Author Topic: Initial key press doesn't trigger envelope properly  (Read 559 times)

Biome Digital

  • Jr. Member
  • **
  • Posts: 59
  • Karma: 0
Initial key press doesn't trigger envelope properly
« on: January 16, 2019, 12:09:07 pm »
This is easy to test. You can download this preset attached

The initial key press doesn't trigger envelope properly. I.e, when you press your keyboard the first sound is "soft" then the following pulses are hard. I'm sure the first one should sound like the rest. I can't see any reason why it sounds different. When trying to make a kick drum (for example) the first kick sounds wack! lol  ::)

Sorry if that doesn't explain it well, download the preset and press a key on your midi keyboard.

trippyz

  • Newbie
  • Apprentice
  • *
  • Posts: 11
  • Karma: 0
Re: Initial key press doesn't trigger envelope properly
« Reply #1 on: January 16, 2019, 03:25:49 pm »
I imported the file but I couldn't figure out what the preset name was.  I couldn't locate ENV test anywhere.

What version of Pigments are you running?

Biome Digital

  • Jr. Member
  • **
  • Posts: 59
  • Karma: 0
Re: Initial key press doesn't trigger envelope properly
« Reply #2 on: January 16, 2019, 03:26:52 pm »
latest

Aymara

  • Newbie
  • Apprentice
  • *
  • Posts: 47
  • Karma: -1
Re: Initial key press doesn't trigger envelope properly
« Reply #3 on: January 16, 2019, 03:27:41 pm »
Next question ... did you find any factory preset which behaves the same?
Grretings from Germany
Chris

Biome Digital

  • Jr. Member
  • **
  • Posts: 59
  • Karma: 0
Re: Initial key press doesn't trigger envelope properly
« Reply #4 on: January 16, 2019, 03:30:04 pm »
No, I haven't looked for it.

This is happening when making a preset. It's very easy to reproduce. Can you not select "import" from the file menu to load the preset?

ben arturia

  • Administrator
  • Hero Member
  • *****
  • Posts: 822
  • Karma: 31
Re: Initial key press doesn't trigger envelope properly
« Reply #5 on: January 16, 2019, 03:41:18 pm »
Hi all,
We have been fixing this bug in the latest hotfix version 1.1.1 build 503.
Please update.
best
.......testing.......

Biome Digital

  • Jr. Member
  • **
  • Posts: 59
  • Karma: 0
Re: Initial key press doesn't trigger envelope properly
« Reply #6 on: January 16, 2019, 03:44:39 pm »
No it is not!

Biome Digital

  • Jr. Member
  • **
  • Posts: 59
  • Karma: 0
Re: Initial key press doesn't trigger envelope properly
« Reply #7 on: January 16, 2019, 03:56:28 pm »
Actually, import doesn't import a saved presets????

So, just drop this preset file into the user folder in pigments folder. and use search.

The way pigments imports presets needs improving I think.

Aymara

  • Newbie
  • Apprentice
  • *
  • Posts: 47
  • Karma: -1
Re: Initial key press doesn't trigger envelope properly
« Reply #8 on: January 16, 2019, 04:02:04 pm »
Can you not select "import" from the file menu to load the preset?

So far, no time for that. And the question is, is it reproducable or only an issue with this preset? Thatís why I asked, if there factory presets, that have the same issue.
Grretings from Germany
Chris

Biome Digital

  • Jr. Member
  • **
  • Posts: 59
  • Karma: 0
Re: Initial key press doesn't trigger envelope properly
« Reply #9 on: January 16, 2019, 04:04:51 pm »
I said already it is easy to reproduce. If you look at the preset I sent it really is simple.

I am just going to email Arturia with this to get it confirmed.

ben arturia

  • Administrator
  • Hero Member
  • *****
  • Posts: 822
  • Karma: 31
Re: Initial key press doesn't trigger envelope properly
« Reply #10 on: January 16, 2019, 04:05:10 pm »
You need first to export the preset. Preset are in *.pgtx format.
I've exported your preset correctly. Check attachment.

First "step" created by the function modulates the cutoff frequency and start at one that's why your first step doesn't sound like the other ones.
I might be wrong but there's nothing wrong for me here.

« Last Edit: January 16, 2019, 04:08:06 pm by ben arturia »
.......testing.......

Biome Digital

  • Jr. Member
  • **
  • Posts: 59
  • Karma: 0
Re: Initial key press doesn't trigger envelope properly
« Reply #11 on: January 16, 2019, 04:08:32 pm »
You need first to export the preset. Preset are in *.pgtx format.
I've exported your preset correctly. Check attachment.

OK, Did you test this as you said above it's fixed but it's not. I have latest update.

The preset I attached in the original post does work if you drop it in the presets folder.

Aymara

  • Newbie
  • Apprentice
  • *
  • Posts: 47
  • Karma: -1
Re: Initial key press doesn't trigger envelope properly
« Reply #12 on: January 16, 2019, 04:40:25 pm »
The preset I attached in the original post does work if you drop it in the presets folder.

Did a regular preset export to pgtx file not work or why did you just copy it?
Grretings from Germany
Chris

LBH

  • Hero Member
  • *****
  • Posts: 2.336
  • Karma: 50
Re: Initial key press doesn't trigger envelope properly
« Reply #13 on: January 17, 2019, 12:33:29 am »
The attached sound is a sound very much based on resonance in the Mini filter. And no filter tuning.

When the filter resonance is used like this, then it does introduce some unexspected fade in/ slow attack at initial triggering. I can't tell for certain, if the settings just reinforce a slow attack, that's there but should'nt be there, or it's all about the filter settings.

If all cutoff modulators (Function 1) is removed from cutoff, then you hear a slow attack clearly - also if you only have sustain level. I think this is part of your problem, as the low tone produced by the filter settings (resonance) simply is missing for the cutoff modulation produced by Function 1, because of this slow attack on the initial KBD trigger.

Ben is this intended behavior in Pigments? It's like a groving feedback. But it's not like that in for example Mini V3. And i also know, that there are synths where this behavior is normal.

No matter what, then the initial KBD attack is missing the initial click, the way the sound is designed.
The result is the same if one use a function clock to trigger an ENV to modulate the filter settings as they are.

Perhaps there are other ways to create your sound. I attach 3 presets to point at some directions. They are exported as LBH Test Bank.


BTW: A preset with the extension .FIL is not exported. It require knowleadge to handle this preset file, so perhaps it's best to distribute exported presets, so anyone just can import them thru pigments.
« Last Edit: January 17, 2019, 04:49:23 am by LBH »

Vic-tor

  • Sound designer & Jedi
  • Global Moderator
  • Full Member
  • *****
  • Posts: 116
  • Karma: 22
Re: Initial key press doesn't trigger envelope properly
« Reply #14 on: January 17, 2019, 09:34:05 am »
Hey,

After some discussion and investigations, we believe what we hear is the filter initialising itself on each new key press. Basically the way the polyphony works in Pigments is that the voice is created when you press a key and then is killed when the amp envelope is finished.

So when pressing a key the filter is created, then takes time to adjust and reach its final state (the pure sine tone).

@LBH, I think this is less noticeable in MiniV3 because it is treating polyphony differently, but in fact you can hear the same fade in, when the voices are played for the first time.
Try to import the Mini V preset attached, create a fresh instance of Mini V and load this preset. Play some notes and you will hear the fade on the first 16 notes. Once they have been played once, they still exist in the background so the fade in will not happen. I tested on another famous plug-in from another manufacturer  I had at disposition and it showed the same behaviour.

Back to topic, in Pigments, currently this is behaving slightly differently as the voices are killed and are not processed anymore when the envelope is finished. We will try and investigate to see if this can be worked around, though I can not guarantee anything nor a quick fix.

Hope it clarified the question !

Best,

Victor

 

Carbonate design by Bloc
SMF 2.0.13 | SMF © 2016, Simple Machines