January 20, 2019, 01:39:09 am
Welcome, Guest. Please login or register.
Did you miss your activation email
News:

Arturia Forums



Author Topic: Laboratory - Bad Pot. Cleanable?  (Read 157 times)

JDoo

  • Beta-testers
  • Jr. Member
  • *
  • Posts: 50
  • Karma: 2
Laboratory - Bad Pot. Cleanable?
« on: December 30, 2018, 09:26:14 pm »
I have a years-old Analog Experience The Laboratory 61.  The 'Cutoff' knob/control has ceased working.  If I move it around some... I can see controls in whatever GUI I happen to be using, slightly move - but that's all.  I have mapped cutoff to another knob, but wanted to know if anyone has opened their Laboratory, and attempted to clean pots/etc?  Specifically.. if there are any bits that I should be careful about (like tight ribbon controllers, etc..  Or - even, "Don't do that.  I tried, and wrecked my controller".  :D    Like I said, I have mapped Cutoff to another parameter so it's not critical .

Thanks for any help (or pointer to where a manual for the "61-key universal keyboard controller" that Arturia uses for this, may be picked up?)

Joe

JDoo

  • Beta-testers
  • Jr. Member
  • *
  • Posts: 50
  • Karma: 2
Re: Laboratory - Bad Pot. Cleanable?
« Reply #1 on: January 10, 2019, 09:27:46 pm »
This thread is going to die here, isn't it?   ;D   

If I ever get around to pulling my "The Laboratory" apart -- I'll take pics and share.  In the meantime --- if anyone has an idea where I could download a manual that talks about the hardware... that would be wonderful.

Cheers -

Joe

MajorFubar

  • Apprentice
  • *
  • Posts: 26
  • Karma: 0
Re: Laboratory - Bad Pot. Cleanable?
« Reply #2 on: January 10, 2019, 09:46:36 pm »
I haven't opened this controller specifically, but I've cleaned many a potentiometer in my time and lived to tell the tale.

It will usually be obvious when you take the back off what you're up against. Be wary that the pots might be nutted from the front, pull the knobs off first just to check. They aren't nutted from the front on the KeyLabs, but they might be on this. Disassembly will be a case of carefully removing any ribbon cables connecting the circuit board to the keybed etc and unscrewing a few screws. Whatever you do don't use WD40 as a cleaner though. Use Servisol Switch Cleaner, or similar. Everyone seems to think WD40 is for fixing electrical maladies but it's not, it's a Water Dispersant (clue is in the name) and in fact it purposefully leaves behind a non-conducting layer as it dries.

JDoo

  • Beta-testers
  • Jr. Member
  • *
  • Posts: 50
  • Karma: 2
Re: Laboratory - Bad Pot. Cleanable?
« Reply #3 on: January 11, 2019, 09:26:19 pm »
Thank you!!  This will help tremendously.

Joe

I haven't opened this controller specifically, but I've cleaned many a potentiometer in my time and lived to tell the tale.

It will usually be obvious when you take the back off what you're up against. Be wary that the pots might be nutted from the front, pull the knobs off first just to check. They aren't nutted from the front on the KeyLabs, but they might be on this. Disassembly will be a case of carefully removing any ribbon cables connecting the circuit board to the keybed etc and unscrewing a few screws. Whatever you do don't use WD40 as a cleaner though. Use Servisol Switch Cleaner, or similar. Everyone seems to think WD40 is for fixing electrical maladies but it's not, it's a Water Dispersant (clue is in the name) and in fact it purposefully leaves behind a non-conducting layer as it dries.

MajorFubar

  • Apprentice
  • *
  • Posts: 26
  • Karma: 0
Re: Laboratory - Bad Pot. Cleanable?
« Reply #4 on: January 11, 2019, 09:27:07 pm »
No worries Joe, glad it was of some help.

 

Carbonate design by Bloc
SMF 2.0.13 | SMF © 2016, Simple Machines