November 22, 2019, 11:44:57 pm
Welcome, Guest. Please login or register.
Did you miss your activation email
News:

Arturia Forums



Author Topic: Faders and Knobs responding extremely slow, in Ableton Live 10  (Read 591 times)

kyu

  • Newbie
  • Newbie
  • *
  • Posts: 1
  • Karma: 0
Faders and Knobs responding extremely slow, in Ableton Live 10
« on: November 29, 2018, 06:47:53 pm »
Hi,

I just bought KeyLab Essential 49 last week and I've spent so much time trying to configure this with my Ableton Live 10 and got most issues cleared, but this slow responsive in faders and knobs is beyond usable level, I am starting to think this might be a device issue.

What happens is when I am on Ableton and use faders to try to control the volume, it takes about 5 to 10 seconds of constantly moving the faders up and down until Ableton recognizes the fader movements and then adjust the volume of that track. This is very stressful because I am trying to control the volume as I am playing the song. With this much delay in responsiveness, the faders are useless. The knobs are having the same issue. Once Ableton recognizes the faders or knobs then it is very responsive for about a few minutes, then it loses the responsiveness again. Is this normal? Shouldn't the faders and knobs be "almost" real time responsive?

I have tried this on a Windows 10 computer and on a Windows 7 computer, using both Ableton 10 Suite and Ableton 10 Lite, so I am positive the issue is either with the KeyLab Essential hardware or some wrong configuration.
I am using the default DAW (READ ONLY) profile in the midi control center.
In Ableton - Preference - Link MIDI - I am using KeyLab Essential - Arturia KeyLab Essential 49 (Port 2)

I tried googling and reading on this forum but I haven't found a similar issue.
Does anyone have a similar issue?
Should I go return this product?

dirtydawg

  • Newbie
  • Newbie
  • *
  • Posts: 2
  • Karma: 0
Re: Faders and Knobs responding extremely slow, in Ableton Live 10
« Reply #1 on: December 25, 2018, 11:22:45 am »
FWIW, I had a similar problem in Logic, and the reason is that there is a pretty stupid default in both the KeyLab and Logic that sets faders and knobs to "Pickup" mode. This means that they will not start responding until your knob/fader passes the set value of the instrument parameter you are trying to control.

Combined with the default "many rotations to go from 0-127" setting on the KeyLab (for the knobs at least) this means you will *think* there is something wrong as you turn left/right a bunch of times and sometimes you accidentally will "pick up" the true value and sometimes you won't. Could certainly feel like 5-10 seconds..

It is absolutely mindboggling that it's a default and that it's not mentioned on the front page of the manual or quick start, any user who is not familiar with this will think the controller or the driver is broken.

The KeyLab MIDI Controller software allows you to turn off this "feature" for the faders in the KeyLab. The knobs doesn't do this in the KeyLab side, but in Logic, Logic did it all by itself on its side so I had to find the feature and disabled it there as well. Might be similar in Ableton?


Tragedy

  • Newbie
  • Newbie
  • *
  • Posts: 1
  • Karma: 0
Re: Faders and Knobs responding extremely slow, in Ableton Live 10
« Reply #2 on: January 11, 2019, 01:26:50 pm »
dirtydawg thank you! You are my hero! :)

 

Carbonate design by Bloc
SMF 2.0.13 | SMF © 2016, Simple Machines