October 19, 2019, 09:14:12 am
Welcome, Guest. Please login or register.
Did you miss your activation email
News:

Arturia Forums



Author Topic: Linux support  (Read 2229 times)

BigB

  • Newbie
  • Apprentice
  • *
  • Posts: 3
  • Karma: 0
Linux support
« on: August 06, 2018, 03:46:27 pm »
Hey everyone here, newcomer to this forum and recent owner of a drumbrute. Mostly satisfied with it so far except for one major PITA: you can't configure the midi part without some proprietary software that only runs on Windows and MacOS - bad luck, I'm a Linux user and obviously Arturia don't give a sh... about Linux users. This really pisses me off, to the point I'm considering sending this thing back despite it's other qualities.

The first thing that pisses me off is of course having to use software to configure a piece of hardware - one of the reasons I'm going hardware is to not depend on having a PC up and running. But then I should have to buy Windows, install it along my Linux distro, and stop my session, launch Windows, quit Windows and relaunch my session just to change the midi channel or something ? I spent the same amount of good money as anyone else on this gear, I deserve to be treated the same.  >:(

I__A

  • Newbie
  • *
  • Posts: 1
  • Karma: 0
Re: Linux support
« Reply #1 on: October 21, 2018, 12:50:17 am »
Hi,

I am confronted with the same problem, but I refuse to install Windows at all. So far I managed to install both, the Software Center and the MIDI Control Center, using wine. I use Debian stable, the steps are:

1.) run: $ sudo apt update && sudo apt install wine
2.) run: $ wine

Command 2.) informed me that multiarch support was missing and presented the command to change that. I ran that command as well.

3.) run: $ winecfg

In Debian stable, wine defaults to Win XP, command 3.) opens a window where wine can be set to Win 7, 8.x or 10, which are required for the Arturia software.

At this point one can download the .exe files of the Software Center and MIDI Control Center and install them by navigating to the Download directory and run the following command:

4.) run: $ wine *The.exeYouWantToInstall*.exe

So far, so good. Now here's the problem I'm stuck with: the Drumbrute isn't recognized by the MIDI Control Center. Since I run Debian stable, the wine version is outdated. The wine manual says that in older versions of wine USB ports are not automatically recognized (maybe anyone with a more up-to-date distro can give feedback if updating wine will solve the issue?).

My Drumbrute is directly connected to my laptop, so I went to ~/.wine/dosdevices and entered the USB ports myself (as the wine manual suggests). In my /dev directory I found /dev/ttyS0-3 (my poorish google skills found out that these are supposed to be the mainboard USB ports, is that right?), so I ran:

5.) run: $ ln -s /dev/ttyS0 com1 && ... && ln -s /dev/ttyS3 com4

This created the COM ports 1-4 and linked them to /dev/ttyS0-3. According to the internet, this should have done the trick, but it didn't. I also added my user to the groups "dialout' and 'tty', still the Drumbrute isn't recognized. Anyone have an idea, why the Drumbrute isn't recognized?

And also, isn't there a way to to update the Drumbrute via SYSEX and configure it via MIDI CC?

Cheers,
I__A

ylecun

  • Newbie
  • *
  • Posts: 2
  • Karma: 0
Re: Linux support
« Reply #2 on: January 27, 2019, 10:54:04 pm »
I run Ubuntu (18.04) and I have a MatrixBrute and a BeatStep.
I run MIDI Control Center under Wine.
It recognizes the MatrixBrute and works fine.
But it doesn't recognize the BeatStep.
It would be probably a simple fix, if the folks at Arturia devoted a bit of time to it.

MajorFubar

  • Sr. Member
  • ****
  • Posts: 318
  • Karma: 5
Re: Linux support
« Reply #3 on: January 28, 2019, 12:59:14 pm »
I do feel your pain...but, of all the bugfixes and upgrades people are asking Arturia to address on this forum, ensuring software compatibility with a Windows emulator running on a minority-interest OS is going to be at the bottom of their list. You presumably already knew Arturia doesn't officially warrant their software to work in any desktop OS except Windows and MacOS when you bought it, so it was always a risk.
« Last Edit: January 28, 2019, 06:07:50 pm by MajorFubar »
2011 iMac 27" 2013 MBP 13" V Collection 6 Analog Lab 4 KeyLab 88 KeyLab 49 KeyStep

DarSwanSwede

  • Newbie
  • *
  • Posts: 1
  • Karma: 0
Re: Linux support
« Reply #4 on: July 21, 2019, 05:24:03 am »
Just wanted to Point out that I am running Ubuntu Studio. Fantastic Distro for audio and midi, comes prefilled with tons of synth modules to build your own rack, daws and so forth. I plugged in my Aurturia Beatstep with the latest firmware and it shows up just fine. without any WIndows Pure Linux, Jack and Alsa. its all preconfigured for Plugin Play with any MIDI compliant instrument. I have also plugged in at the same time a Novation LK49 MKII, Akai MPK mini v2, Korg NanoKey2 and a Roland JV-880 rack synths via a Roland UN-ONE USB adapter. worked flawlessly. Try a different distro!


Linux_user

  • Newbie
  • *
  • Posts: 1
  • Karma: 0
Re: Linux support
« Reply #5 on: October 03, 2019, 07:12:42 pm »
Booting a different distro is almost as big a hassle as booting Windows. I've been running OpenSuse since not long after it first appeared about 13 years ago. I don't run Windows and haven't needed to look at it for years.
I have a KeyStep and a MicroBrute and I'm pretty cheesed off that I can't update the firmware on these devices from Linux.
I installed the MIDI Control Center with Wine but it crashes with no real clue as to what I might need to do to progress it.

 

Carbonate design by Bloc
SMF 2.0.13 | SMF © 2016, Simple Machines