September 17, 2021, 03:20:32 pm
Welcome, Guest. Please login or register.
Did you miss your activation email
News:

Arturia Forums



Author Topic: Analog Lab VST not remembering control mapping/MIDI controller setting  (Read 3302 times)

colouredmirrorball

  • Apprentice
  • Apprentice
  • *
  • Posts: 4
  • Karma: 0
I'm using Analog Lab as a VST in REAPER. I also have a Keylab Essential 61 hooked up. KLE is set to mode User 1.

When a track with the VST loaded is armed for recording, the VST software control sliders and knobs will respond to the hardware faders and knobs on the KLE. So far so good.

But, in my situation, I'm not interested anymore in those software faders, when I have found a good setting for the sound. I want to use them to control the volume of the tracks in my project and non-Analog Lab effect parameters. However it is absurdly difficult to convince Analog Lab to ignore these signals. I can set all software knobs and faders to "dot" and then they are disabled. However when I restart REAPER, they will be mapped to their default settings again! I don't want to make 36 clicks in every track where I use Analog Lab every time I reopen a project...

I've found a shortcut though: at the bottom I can set MIDI controller to Default and then the faders and knobs are disabled as well. This requires only two clicks per track but it's still not ideal, as this setting is also forgotten upon a restart. I'll be using this setup for a couple live gigs and it's almost guaranteed that I'll forget to change this, or simply be too busy with, you know, performing live to deal with Analog Lab's shenanigans. It's far preferable if it remembered its settings.

Please let me know when this bug is fixed. Thanks.

LBH

  • Hero Member
  • *****
  • Posts: 3.910
  • Karma: 45
I'm not sure if i understand you. So i will try to answer you the following way.

- If you wan't AL to remember sound parameter settings, then you shall save the settings as a AL preset inside AL.

- If you have edited a AL preset, and you don't save the new settings as a AL preset, then the settings should be saved inside your DAW, when you save the DAW project. If you don't save the DAW project, then the AL settings will be reset to the last saved settings. (I don't know if Reaper can send the current parameter values to your controller.)

- You shall set your controller (Or perhaps your MCC) when you wan't to control your DAW.

- I don't have a Arturia controller. But i think the MIDI controller setting in AL is selected automaticly as the Arturia controller you have. I don't know if this can be changed, so it stays on "default" controller, if you wan't that.

Have you read the manuals and such for your controller, your MCC, your AL and your DAW? If not, then that may help.

In generel i can imagine your troubles is'nt about AL at all. It may be about using your controller and your DAW correct. But if you think i'm wrong, then please create some step by step examples of what excactly you are doing, so it's easier to follow you.
For the time being, i don't think the behaviors you mention is about a AL bug.


gphantom

  • Sr. Member
  • ****
  • Posts: 255
  • Karma: 2
I have the same problem with Analog Lab as well and, the only way to solve the problem (Which I did successfully) was to save the preset as a new one.
For example, if I had a piano sound I liked but had to adjust the volume, I'd save it as "FAV PIANO" bank and "_KEYS" Type.  The _ used for Key was so that it wouldn't appear twice in the list.  That way, I could select KEYS or if I wanted my own saved selections, select _KEYS to get to my list.
IF you have the actual instruments (the V collection as an example,) you can always EDIT the preset into the instrument itself and resave it.

I asked if it were possible to make a modification in their firmware or Analog lab version to read the sliders and adjust AL's knobs but, apparently, it can't be done.

LBH

  • Hero Member
  • *****
  • Posts: 3.910
  • Karma: 45
@gphantom

Did'nt your DAW save the edits for a AL preset, when you saved the DAW project? It should.

How does you set your Arturia controller to work for your DAW parameters only? When using the controller for DAW parameters, then it should not change AL or any other plug-in parameters.

Do you wan't to be able to control a KeyLab Encoder with a KeyLab Slider? How would that solve the issues? As i see it, then it only will make it possible to use multiple hardware controls to control one parameter from a current setting. But a wrong current setting seems to be the issue, as i understand the issue - (beside the DAW controlling issue).
« Last Edit: March 23, 2018, 06:26:32 pm by LBH »

colouredmirrorball

  • Apprentice
  • Apprentice
  • *
  • Posts: 4
  • Karma: 0
This is how to reproduce the bug, step by step:

- Hook up the KLE to the computer
- Enable the KLE in the preferences window (ctrl+p, under midi devices)
- Open a new project in REAPER
- Right click in the dark grey area on the left, click "Insert virtual instrument on new track". This automatically sets the correct settings: arm for recording, enable monitoring and opens the VSTi selection window.
- Select Analog Lab 3, it should now load with the Keylab Essential layout
- Play some notes and move some faders to confirm the KLE is detected by REAPER
   - In Analog Lab mapping on the KLE, the faders/knobs adjust the faders/knobs in Analog Lab
   - In DAW mapping, the faders/knobs adjust the track volume/pan
   - In the User mappings, the faders/knobs also adjust the faders/knobs in Analog Lab! This is unwanted behaviour for my applications.

To prevent the KLE from adjusting faders/knobs in Analog Lab, I tried the following without success:

- Set all faders and knobs to the "." setting, which disables their effect. They still respond to the KLE faders/knobs but at least the instrument sound remains unchanged.
- After saving the project, restarting REAPER and reopening the project however, this setting is lost (bug 1). All faders/knobs are now back at their preset mapping and moving faders/knobs changes the sound...

- Set the MIDI controller at the bottom of the Analog Lab GUI to Default. This causes the faders to no longer respond to the KLE (yay!) however, the knobs are still responsive.
- Save the REAPER project and reopen the program. The MIDI controller is now back at KeyLab Essential (bug 2) instead of Default.

These two bugs could be caused by either REAPER or Analog Lab.

After LBH's suggestions, I tried these things:

- Set all faders and knobs to the "." setting
- Click Save As and save as new preset in Analog Lab
- All faders and knobs mapping immediately revert to their default setting! (bug 3)

This bug is definately in Analog Lab.

- Set MIDI Controller to Default
- Save as a new preset in Analog Lab
- Save project and restart REAPER
- MIDI Controller is now back to Default, MIDI Controller setting is not saved in preset (looks related to bug 2)

- Set all faders and knobs to "." (yet again)
- Export preset to file in Analog Lab
- Load it back in
- Faders and knobs back to default mapping (bug 4)

- Set all faders and knobs to "."
- Click the UI button in REAPER, this switches to a raw fader view of all VST parameters
- Click UI again to bring the Analog Lab GUI back
- All fader/knob mappings are back to default setting :(

And I saved the best one for last:

- Set all faders and knobs to "."
- Close the VST window
- Reopen it
- All fader/knob mappings are back to default setting!!!

Fortunately, when closing the window, it remembers its settings. Only opening the Analog Lab GUI causes it to load in the default fader/knob mapping.

I don't think there is a way to prevent REAPER from sending CC values to the VST but let notes through. And if it did exist, it would disable pitch/mod wheel which is also not very ideal.

Maybe the easiest workaround for Arturia would be to have a toggle to enable/disable auto mapping of CC to the faders/knobs AND have this toggle be a VST variable so its state can be stored in REAPER.

EDIT: directly after posting this, I got the idea to adjust the fader/knob mapping in MIDI Control Center. Set the knobs/faders CC numbers to something else. It works in that Analog Lab no longer responds to the faders but now shows erratic behaviour, eg. moving a knob would switch to the next preset. Evidently I have mapped some knobs to Analog Lab's control inputs. Is there a list of which CC numbers Analog Lab uses so I can avoid this?
« Last Edit: March 26, 2018, 06:00:48 pm by colouredmirrorball »

LBH

  • Hero Member
  • *****
  • Posts: 3.910
  • Karma: 45
Yes. In AL3 each knob and fader have a dropdown list where you can choose a parameter for that control. The last one "-" is empty and thus choose no paramater to control.
It's correct that this setting is'nt saved neither when saving the preset in AL3 or when saving the DAW project, but all other settings are saved.
I also consider this as a AL3 bug or function that's missing Arturia. It should be possible to not assign and save a empty parameter to a virtual control in AL3 just like it is with any other parameter selection. Should'nt it be possible?
This is actually the problem for nearly all the reported bugs, if i understand corrrect.


About the AL3 Controller Layout setting, then i don't consider that a bug.
The manual say this:
"The button shown here displaying ‘Minilab’ can be used to select which MIDI controller
you have connected. If you are using one of Arturia’s own MIDI controllers it will be
auto-detected and the layout of the software changed automatically. If you select Default
Controller you may need to make your own assignments to set up MIDI control maps."

That make sense to me. If one have an controller, then why not have the layout selected automaticly, if all other functionality does'nt depend on a need to change this setting?


About knowing CC numbers for a hardware control, then i think you can see them in MCC map section.
But you can also use a MIDI monitor to see the CC numbers. Perhaps Reaper allready have a MIDI monitor. A MAC have one, and for Windows you for example can use MIDI-OX http://www.midiox.com/ .

I suggest you look in the manuals for your KLE, the MCC and the AL3. Perhaps you also can find useful info in Arturias tutorial videos https://www.arturia.com/keylab-essential-49/keylab-essential-49-tutorials .


- In the User mappings, the faders/knobs also adjust the faders/knobs in Analog Lab! This is unwanted behaviour for my applications.
I don't know if you can unassign A CC from a control unless when using MIDI learn. I guess you can.  But check it out in MCC.


As said, then i don't have the DAW and controller you have. But as it is, then i only see one thing i consider a bug or function that's missing, and that's the AL3 empty parameter selection bug i started out with in this post.
« Last Edit: March 26, 2018, 09:39:12 pm by LBH »

 

Carbonate design by Bloc
SMF 2.0.17 | SMF © 2019, Simple Machines