July 19, 2019, 08:29:16 am
Welcome, Guest. Please login or register.
Did you miss your activation email
News:

Arturia Forums



Author Topic: Spurious Pitch Bend applied at random times (AU in Logic Pro X)  (Read 605 times)

spride

  • Apprentice
  • Apprentice
  • *
  • Posts: 10
  • Karma: 0
Spurious Pitch Bend applied at random times (AU in Logic Pro X)
« on: February 02, 2018, 03:39:31 pm »
When playing back a Logic project that includes the Jup-8 V3, the Jupiter part(s) will sometimes be out of tune. On opening the plugin window, the Pitch Bend control will be between 13% or 17% sharp (see screenshot). The longer Logic has been running, the more likely this is to happen.

I do not recall this behavior with any other plugin. I do have external MIDI devices that conceivably could be faulty and emitting spurious pitch bends but this happens whether they are plugged in or not.

There are no Pitch Bend events in the Event List, and running MIDI monitor never shows any Pitch Bend events coming from elsewhere in the environment. All of this is making me suspect that it's down to a bug somewhere in the stack, but I lack the resources to debug further.

I know that Arturia (still) says they are evaluating the stability of Analog lab 5 (sic) with Mac OS X 10.13, and I recently and reluctantly upgraded to 10.14 because of worries that fixes for Meltdown/Spectre would not be back-ported to 10.12. (Apple did subsequently release patches for 10.12 and 10.13, but of course that was after this upgrade).


Is anyone else seeing this? If not - Arturia, are there any logging and debugging steps I can take to catch this the next time it happens?


Logic Pro 10.4.0
Jup-8 V3.2.0.1183
Mac OS X 10.13.3

spride

  • Apprentice
  • Apprentice
  • *
  • Posts: 10
  • Karma: 0
Re: Spurious Pitch Bend applied at random times (AU in Logic Pro X)
« Reply #1 on: February 02, 2018, 05:44:50 pm »
I do not recall this behavior with any other plugin. I do have external MIDI devices that conceivably could be faulty and emitting spurious pitch bends but this happens whether they are plugged in or not.

WRONG! I just caught two devices emitting Pitch Bends while I wasn't even using them: See screenshot.

What the hell is going on with my stuff…?


LBH

  • Hero Member
  • *****
  • Posts: 2.227
  • Karma: 50
Re: Spurious Pitch Bend applied at random times (AU in Logic Pro X)
« Reply #2 on: February 02, 2018, 06:30:29 pm »
I don't know what your MIDI interface is.
But i assume Impulse is Novation controller.
It's possible to have a pitchbend that's not calibrated or is faulty. On my Novation SL MKII i can calibrate my pitchbender. I don't know if this is possible in Impulse. You can look at that. It should be possible to read about it in the Impulse manual, if it's possible.
But it can be a faulty bender.

You can try and use MIDIOX http://www.midiox.com/ to see if you controllers pitchbend send out pitchbend values that can explain the behavior.

This is only to see if the issue is  about your hardware. But if so, then how can you say you only have issues with JUP-8? The issue should apply to any plug-in that is set to use pitchbend in some amount, if it's a harware issue. And i assume it should be recorded.

spride

  • Apprentice
  • Apprentice
  • *
  • Posts: 10
  • Karma: 0
Re: Spurious Pitch Bend applied at random times (AU in Logic Pro X)
« Reply #3 on: February 03, 2018, 03:32:42 pm »
Thanks, LBH. It is indeed the Novation Impulse 49 that was sending random pitchbends! See the second post in the topic where I have a screenshot catching it in the act1 from MIDI Monitor, which is the equivalent of MIDIOX for Macs.

I'll be diving into the manual and Novation forums today. Thanks and congratulations on a brilliant diagnosis! :)


1 The reason why "MIDI Interface" also appears earlier in that list is that "MIDI interface" is how the Arturia Microbrute's MIDI Out characterizes itself over USB, and I also had a standard 5-pin MIDI cable connecting the Impulse to the Microbrute for "live" control of the Brute, and the Pitch Wheel event was being echoed to the Brute which was effectively doing a MIDI THRU and sending that out over USB

spride

  • Apprentice
  • Apprentice
  • *
  • Posts: 10
  • Karma: 0
Re: Spurious Pitch Bend applied at random times (AU in Logic Pro X)
« Reply #4 on: February 03, 2018, 03:36:48 pm »
Quote
But if so, then how can you say you only have issues with JUP-8? The issue should apply to any plug-in that is set to use pitchbend in some amount, if it's a harware issue. And i assume it should be recorded.

…and you're entirely correct that it wasn't just about the Jupiter-8; it was just that in every case, a Jup-8 track was the one that had the focus in Logic (I have one lead and four pad parts that use it), so that was the one that was getting the Pitch Wheel events. Thanks for the correction.

 

Carbonate design by Bloc
SMF 2.0.13 | SMF © 2016, Simple Machines