December 14, 2017, 08:26:23 pm
Welcome, Guest. Please login or register.
Did you miss your activation email
News:

Arturia Forums



Author Topic: (new problem) Keylab is not controlling Analog Lab 2 without FL Studio  (Read 370 times)

Junno_C

  • Apprentice
  • *
  • Posts: 6
  • Karma: 0
I just bought a Keylab Essential 61, I've been with it since October 6th. Today I was testing him with my Daws, and loading analog Lab 2 in FL studio and I can't control analog lab 2 with Keylab within FL Studio 12.5. Simply the Mídis signals are sent but it does not work. Already add Mackie control I can only control the Daw but the function of working with Analog Lab 2 by Keylab is lost, simply when I am inside the FL using Analog Lab 2 I can not control by Keylab. Already on Platinum and Live Sonar and still get the gifts and names remain intact in ProTools control but the names of the presets disappear.
« Last Edit: October 13, 2017, 05:01:28 am by Junno_C »

Matt Arturia

  • Administrator
  • Sr. Member
  • *****
  • Posts: 318
  • Karma: 32
Re: Keylab is not controlling Analog Lab 2 without FL Studio
« Reply #1 on: October 12, 2017, 04:58:09 pm »
Hi,

This could be a simple configuration issue. First, is your Keylab Essential correctly set on the MIDI setup of FL Studio ? It should be the same as the first attached screenshot.

Then when you insert AnalogLab  2 inside Fl Studio, click on the "Detailed settings" on the upper left corner, go to the VST Wrapper Settings (2nd icon), then set Input port to 1.

I hope it will solve your issue.

Regards,

Matthieu

Junno_C

  • Apprentice
  • *
  • Posts: 6
  • Karma: 0
Re: Keylab is not controlling Analog Lab 2 without FL Studio
« Reply #2 on: October 12, 2017, 10:41:45 pm »
 ;D ;D ;D Thank very much, It ok! This is Works with FL Studio ( Analog Lab 2 + Keylab its ok with FL)  ;D ;D ;D
Thanks for Great Support. Keylab Essential 61 is GREAT midi controller

Junno_C

  • Apprentice
  • *
  • Posts: 6
  • Karma: 0
Re: Keylab is not controlling Analog Lab 2 without FL Studio
« Reply #3 on: October 13, 2017, 04:59:58 am »
 :( A new problem has appeared in FL Studio. When I put the Analog Lab on port 1 and add another instrument to play on a different channel, the analog lab sound plays together, I can only make the channels play separately if I do not add the Analog Lab on channel 1 in the VST Wrapper Settings. How can I solve this other problem?  ???

Junno_C

  • Apprentice
  • *
  • Posts: 6
  • Karma: 0
Re: (new problem) Keylab is not controlling Analog Lab 2 without FL Studio
« Reply #4 on: October 16, 2017, 03:27:55 am »
I still have this additional problem in FL, after making the analog lab 2 work I can not make the distinct channels play the sound separately. I need help!

Matt Arturia

  • Administrator
  • Sr. Member
  • *****
  • Posts: 318
  • Karma: 32
Re: (new problem) Keylab is not controlling Analog Lab 2 without FL Studio
« Reply #5 on: October 16, 2017, 11:34:05 am »
Hi Junno_C,

I can't tell you more than we are investigating. However the problem seems to be more related to how FL Studio handles MIDI Input. We are looking for a solution.

Regards,

Matthieu

Junno_C

  • Apprentice
  • *
  • Posts: 6
  • Karma: 0
Re: (new problem) Keylab is not controlling Analog Lab 2 without FL Studio
« Reply #6 on: October 23, 2017, 08:03:21 am »
Solution of my problem ?

Junno_C

  • Apprentice
  • *
  • Posts: 6
  • Karma: 0
Re: (new problem) Keylab is not controlling Analog Lab 2 without FL Studio
« Reply #7 on: November 22, 2017, 08:52:52 pm »
I am waiting for the solution to this day. And they still can not solve it? ???

Guillaume Arturia

  • Administrator
  • Full Member
  • *****
  • Posts: 204
  • Karma: 15
Re: (new problem) Keylab is not controlling Analog Lab 2 without FL Studio
« Reply #8 on: November 23, 2017, 10:07:31 am »
Hi Junno_C,

Sorry for this inconvenience.

I would suggest you to try this :

- Let your device set as indicated in our FAQ article.

- Then do not define any "Midi input" port on your different midi tracks (Let them set to --)

- From there the midi notes should only trig the selected track.

- Then in order to have your knobs and faders working you'll have to assign them manually on each track :

- First, move the plugin function that you want to assign to your controller

- Second, right-click on the "Multilink to controller" button (with a knob icon in the middle of the FL-Studio interface)

- In the menu appearing select in the left part "Link to controller" and finally move the knob on your controller that you want to assign to it

- Repeat the steps for each function that you want to assign to your plugin

- On an Analog Lab track (if you're using one instance of the plugin) you can set the midi input port to use the predefined mapping but if you need multiple tracks you'll have to remove the midi input port and do the same steps than for the other plugins (manually assign your knobs and faders).

Keep me informed if it works on your side.

Best regards,
Guillaume

 

Carbonate design by Bloc
SMF 2.0.13 | SMF © 2016, Simple Machines