December 15, 2017, 12:15:02 am
Welcome, Guest. Please login or register.
Did you miss your activation email
News:

Arturia Forums



Author Topic: Windows 10 - standalone instruments won't connect to controllers  (Read 187 times)

Ilgrazza

  • Apprentice
  • *
  • Posts: 16
  • Karma: 0
Windows 10 build 15063.483; Keylab 49, Beatstep and Akai LPK25; V collection 3 and 4

Everything working normally as VSTs within my DAW (Cakewalk Sonar x3). However, Analog Lab, Lab2 and all of the individual synths in standalone mode won't connect to the Keylab or any other controller.  When I call up the audio and midi settings dialogue, the Keylab (and other controllers) are recognised, and I can select them, but when I close the dialogue with the 'OK' button, the controllers are inactive.  Re-opening the settings dialogue shows no midi device selected.  There does not seem to be any hardware problem (everything works within a DAW) and everything works normally under an older build of Windows 10.

Has the latest build of Windows brought a compatibility problem with Arturia software?

Ilgrazza

  • Apprentice
  • *
  • Posts: 16
  • Karma: 0
Re: Windows 10 - standalone instruments won't connect to controllers
« Reply #1 on: July 24, 2017, 08:58:57 pm »
Update: uninstalled and re-installed all Arturia software - no change...
Installed on a different PC with same build of Windows 10 - working normally.  Something may have gone wrong with the latest Windows 10 upgrade - will try a repair installation of Windows.

Ilgrazza

  • Apprentice
  • *
  • Posts: 16
  • Karma: 0
Re: Windows 10 - standalone instruments won't connect to controllers
« Reply #2 on: July 24, 2017, 10:16:03 pm »
Update 2

Repair installation of Windows seems to have solved the problem - something had gone awry in the USB configuration.

 

Carbonate design by Bloc
SMF 2.0.13 | SMF © 2016, Simple Machines