February 26, 2020, 09:09:51 pm
Welcome, Guest. Please login or register.
Did you miss your activation email

Arturia Forums

Author Topic: Broken Already?  (Read 3888 times)


  • Newbie
  • Newbie
  • *
  • Posts: 1
  • Karma: 0
Re: Broken Already?
« Reply #15 on: December 23, 2018, 09:19:10 pm »
mine is dead too, just came back from a recording. have used it less than 20 times??? nothing of the above helps. its just dead. the A blinked a little bit , but its gone. I am not letting this go easy.


  • Sr. Member
  • ****
  • Posts: 388
  • Karma: 5
Re: Broken Already?
« Reply #16 on: December 24, 2018, 12:43:58 pm »
Re: faulty hardware.

I really don't think the 'technical issues' section on this forum is the best place for helping people with obviously faulty hardware. And if you've tried the hard reset outlined on page one, a faulty unit is probably what you're looking at.

Assuming you've bought it new and it's still under warranty, surely it's best to reach out to the store or online vendor where you purchased it and ask for an exchange/repair under the obligations of your country's consumer rights or trading standards, rather than post here and wait for an official response. Just take it back/send it back. It's what your consumer rights and warranties are for.

Hope that helps.
2011 iMac 27" 2013 MBP 13" V Collection 6 Analog Lab 4 KeyLab 88 KeyLab 49 KeyStep


  • Newbie
  • *
  • Posts: 1
  • Karma: 0
Re: Broken Already?
« Reply #17 on: January 23, 2019, 11:16:06 pm »
Experiencing the same problem. The A flashed for a bit, but now then unit won't turn on. No luck with either the power supply or USB cable. The emergency firmware reboot and factory reset didn't do anything. Contacted Arturia support about the issue and received an email about troubleshooting the problem. None of their suggestions work, currently waiting to hear back from them. Understood about contacting the retailer, but I just want to know, has anyone had any luck with Arturia fixing the issue?


  • Newbie
  • *
  • Posts: 1
  • Karma: 0
Re: Broken Already?
« Reply #18 on: January 16, 2020, 01:55:44 pm »
I have just got a second-hand audiofuse but it didn't come with its original USB cable. I somehow managed to upgrade the FW to 1.1 using the recommendations from this thread but I still don't manage to get any sound when using a generic mini USB cable. Same when I tried with the power supply on and the green mode enabled. The device lits up and is seen by my mac ( only with the power supply  )  but no sound. I submitted a ticket but no replies so far. Any help/tips / suggestions would be welcome. Thanks in advance.


  • Global Moderator
  • Hero Member
  • *****
  • Posts: 1.406
  • Karma: 40
    • soundcloud.com/logicaldream
Re: Broken Already?
« Reply #19 on: January 16, 2020, 07:37:12 pm »
Hi, if using a standard usb lead you will need to use the psu for it to function. did you try a factory reset after installing the Fw?
To do this hold down the main mono button and cue and power up.

Hope this helps
ARTURIA Tester for Audiofuse, Micro freak,Kl49mkII,DrumBrute,Spark,Analog lab3,KLE ,kl88,matrix12,Semv,Beatstep,Minibrute.se,
ASC,Vcol6, Beatstep pro, VCOL5, Synclavier v.Minibrute2s


Carbonate design by Bloc
SMF 2.0.13 | SMF © 2016, Simple Machines