November 13, 2019, 03:47:19 pm
Welcome, Guest. Please login or register.
Did you miss your activation email
News:

Arturia Forums



Author Topic: MiniLab keys not working  (Read 6752 times)

tobyboi

  • Newbie
  • *
  • Posts: 1
  • Karma: 0
MiniLab keys not working
« on: December 22, 2016, 11:21:06 am »
Hey, guys!
I've been using my minilab with Cubase Elements for some time and everything was always fine. Today I plugged it in an my C and E keys don'r work. (both the Cs and both the Es). Whenever I plug it in, I'm able to play the notes once and then the keys stop working. Any idea as of which could be causing it and how to get it back to normal? :/

au85

  • Apprentice
  • Apprentice
  • *
  • Posts: 4
  • Karma: 0
  • Italy, EU
Re: MiniLab keys not working
« Reply #1 on: January 28, 2017, 12:25:25 am »
Hi! This exact thing has just happened to me right now!  ???

Actually, in my case all C, E and G# keys do the same: after a keyboard power cycle they can each send a midi ON command once, then after that they don't respond anymore. I even tried to reupload the firmware (3.0.0.5 for 'N' not 'O' serial number), without success.

As my unit is still under 2 years old it is luckily still covered by the EU customer warranty so if Arturia doesn't respond quickly to this post I will return it for a replacement.

[edit:]
After some software updates and playing a bit with the keyboard, I found out the following things:
1) that when C E and G# keys don't work, also encoders #1 and #9 don't.
2) that sometimes it spontaneously start to work properly again. It happened first a couple times when working with the just installed Analog Lab 2. then stopped working again. Then I decided to log all incoming midi commands (with 'MIDI Monitor' for MAC OSX) and touching every single knob, key, pitch/mod strips, pads... all of a sudden, after having touched everyting, it started working properly again! and when keys C E G# were pressed for the first time after such spontaneous reactivation, their first response was a note OFF message on release, and after that they could be pressed and send midi ON and released and send midi OFF.
3) that sometimes when working properly it can spontaneously generate a mess and then stop working: I was playing in Analog Lab 2, but suddenly it started changing patch spontaneously, as if someone were turning knob #1 in random directions. Then after quite a bit of this behaviour, the well known keys stopped working. Fortunately MIDI Monitor was active so I have a log of the whole process (incoming and outcoming MIDI messages).
« Last Edit: May 28, 2017, 12:45:26 am by au85 »
* this message was written on 100% recycled electrons

JohanBach

  • Newbie
  • *
  • Posts: 2
  • Karma: 0
Re: MiniLab keys not working
« Reply #2 on: March 14, 2017, 06:56:13 pm »
I have the same issue.
4 or 5 keys not working. It had the best of cares but after 2 years this plastic keyboard is no more.
It sends note-on messages and then nothing on release, and the Keys wonīt respond again.
I have dissasembled it and cleaned all the contact parts with alocohol carefully, but they were super clean. Tried different rubbers and still the same error. So the problem is with the circuit board. Apparently everything looks good, capacitors etc. but this keyboard is begging for the paperbin.

Any responses from Arturia?

dmontesi

  • Apprentice
  • Apprentice
  • *
  • Posts: 3
  • Karma: 0
Re: MiniLab keys not working
« Reply #3 on: March 15, 2017, 01:45:46 am »
Having the same issue as well. The keys that don't work for me are both Ds, F#s, and A#s. If I unplug the keyboard, and plug it back in, all keys start working for a few seconds, but then the 6 keys stop responding. I tried upgrading the software, as well as Arturia's Analog Lab, and is still happening. Really strange issue, and very frustrating. Any workarounds yet?

JohanBach

  • Newbie
  • *
  • Posts: 2
  • Karma: 0
Re: MiniLab keys not working
« Reply #4 on: April 18, 2017, 04:17:51 pm »
Itīs a shame how Arturia staff donīt even respond to this problem. Whatīs the forum for? I didnīt believe that much when people started complaining about the bad quality of Minibruteīs keyboards, but itīs proven itīs a general characteristic of their products; bad plastic and bad components. The Minilab is a piece of crap.
I wonīt buy their controllers ever again.
Thanks and bye.

au85

  • Apprentice
  • Apprentice
  • *
  • Posts: 4
  • Karma: 0
  • Italy, EU
Re: MiniLab keys not working
« Reply #5 on: May 28, 2017, 01:04:39 am »
Hi everybody,

I apologize for not updating. The reason was that my Minilab started working again properly within a day, after several random attempts at updating, syncing with the Midi Control Center and using a Midi Monitor. 

Meanwhile I had also raised a ticket with Arturia support and received the following reply:

Quote
Please update your MiniLab firmware by doing as follow:
1/ Download the latest version of the unified MIDI control center:
==>  http://www.arturia.com/downloads/mccu/

2/ Select "Device" menu
3/ Click on "Firmware Upgrade"
4/ Follow the procedure

Feel free to come back to me if still any problem or misunderstanding.
Yours Musically,
Signy.
I also asked them to intervene in the forum, but apparently they didn't. Moreover, the link in their reply is dead.

I am however back here because the problems are back, even though the device firmware has been reuploaded (anyway as of today it's still the same version number as in January).

I am rather sure it's mainly a firmware issue but I'm not that sure that the current firmware can solve it.

What about your situations? Did they solve spontaneously after a while?
* this message was written on 100% recycled electrons

dmontesi

  • Apprentice
  • Apprentice
  • *
  • Posts: 3
  • Karma: 0
Re: MiniLab keys not working
« Reply #6 on: May 29, 2017, 01:53:31 am »
It's still happening to me. Haven't been using it that much ever since the first time I wrote on this forum, but decided to give it another try and still having the same problem with it. I also imagine is something related to their firmware. It'd be good if they care to help. :(

au85

  • Apprentice
  • Apprentice
  • *
  • Posts: 4
  • Karma: 0
  • Italy, EU
Re: MiniLab keys not working
« Reply #7 on: May 29, 2017, 06:14:56 pm »
The keys that don't work for me are both Ds, F#s, and A#s.
It's funny that our rebel keys are different! (mine are always C, E and G#, maybe a different firmware or hardware version?) Does anything happen on any of the encoders as well? In my case the two leftmost encoders stop responding.

If I unplug the keyboard, and plug it back in, all keys start working for a few seconds, but then the 6 keys stop responding.
What actually happens (at least in my case) is that the controller sends a MIDI ON message when you press the key for the first time after power-on, and no MIDI OFF when you depress. So they only work once, leaving any note on, then they stop responding at all.

Any workarounds yet?
By random trial and error, a workaround that apparently works in my case is: press/rotate/slide EVERY key/pad/encoder/slider on the controller. I usually check on a Midi Monitor that they actually send out a message, and I believe that encoders and sliders are the ones to try first, as pressing keys only isn't enough. This somehow fixes the issue. You may need to repeat that after a short while, but after one or two repeats the fix lasts for much longer. Much closer to sorcery than to science! :)

Let me know if this works for you as well.

Summing up, if this hopefully fixes the situation temporarily, that's good. As it is not on the user manual I still however consider this a major defect and would consider applying for a return under the EU 2-year warranty. The issue might however be difficult to reproduce at will.

As the new minilab MkII is out, I feel that the support team won't bother helping us seriously.


« Last Edit: May 29, 2017, 06:21:39 pm by au85 »
* this message was written on 100% recycled electrons

dmontesi

  • Apprentice
  • Apprentice
  • *
  • Posts: 3
  • Karma: 0
Re: MiniLab keys not working
« Reply #8 on: May 31, 2017, 01:36:11 am »
Quote
By random trial and error, a workaround that apparently works in my case is: press/rotate/slide EVERY key/pad/encoder/slider on the controller. I usually check on a Midi Monitor that they actually send out a message, and I believe that encoders and sliders are the ones to try first, as pressing keys only isn't enough. This somehow fixes the issue. You may need to repeat that after a short while, but after one or two repeats the fix lasts for much longer. Much closer to sorcery than to science! :)

That worked!, I tried it once, and it worked for a minute, then remembered what you said about having to repeat it, and instead I tried each of the pads, and noticed that just by pressing the "shift" button all of the keys would start working again. At least that seems to have fixed it for me. Thanks for the workaround!  :)

au85

  • Apprentice
  • Apprentice
  • *
  • Posts: 4
  • Karma: 0
  • Italy, EU
Re: MiniLab keys not working
« Reply #9 on: June 14, 2017, 07:31:03 am »
Happy to know!
In my case I have singled out encoder #13 as the one to turn first to unlock keys.
* this message was written on 100% recycled electrons

gudulezzz

  • Newbie
  • *
  • Posts: 1
  • Karma: 0
Re: MiniLab keys not working
« Reply #10 on: October 24, 2017, 11:56:44 am »
Hi guys ! It's my first post here. I arrived here because i had the same kind of problems (keys not working).
I thought first it was my fault, because i smoke close to my keyboards (shame on me !). Then, as i did with some other keyboards, i've opened it to clean the contacts. When i tried the muted keys, they worked... once only. Then, i suspected a software problem. The not working keys were too much regular on the keyboard : One bad key, three good, one bad, three good, and so on (C#, F, A, ...).
Thanks to au85, I've downloaded Midi Monitor from OBD Software and tried all knobs, pads and keys. The wrong keys began by sending a not off message.
All is in order now. I don't know for how long but I keep this solution in my mind.

Thank you for your help and sorry for my approximative english (I've got some frogs to eat  ;D )

UHF

  • Newbie
  • *
  • Posts: 2
  • Karma: 0
Re: MiniLab keys not working CAUSE & SOLUTION
« Reply #11 on: January 26, 2019, 05:10:59 am »

 

Carbonate design by Bloc
SMF 2.0.13 | SMF © 2016, Simple Machines