July 03, 2022, 09:21:16 am
Welcome, Guest. Please login or register.
Did you miss your activation email
News:

Arturia Forums



Author Topic: Help! I burned out the fuse, fixed it, and the thing won't work now. [See pics]  (Read 1202 times)

Brendan McGillicuddy

  • Newbie
  • *
  • Posts: 1
  • Karma: 0
Hey everyone, I've tried everything possible, and now I'm at a total loss. To begin, my Microbrute does not have a warranty, so anything that goes wrong, I have to fix myself.
Last week, I accidentally plugged an 18v power supply into my microbrute, only to realize that I literally burned the internal fuse to a crisp. After opening it up, I soon discovered that my model DOES NOT use the standard glass fuses that early models were originally designed with with, but a small, soldered-on square. I desoldered this and got to work adapting it to use replaceable glass fuses, seeing as the fuse housing leads still exist on the circuit board. I soldered on 2 wires to the leads on the board, and the other ends to the leads on the fuse housing.
Here's where I'm stumped: the circuit is completed, as I can tell by the lights that light up on the front panel, but I can't actually interact with it in any way. Instead, a persistent clicking noise can be heard, and is generated independently without any input you give it. Please see the attached video to see and hear what I mean. I love this thing, and I refuse to accept it is broken for good. What do I do?

Here are the pictures detailing what I did: http://imgur.com/a/ATtZj
Here is a short video of the noise: https://www.youtube.com/watch?v=sOnIqcGI6r4
« Last Edit: August 22, 2016, 03:25:14 am by Brendan McGillicuddy »

 

Carbonate design by Bloc
SMF 2.0.17 | SMF © 2019, Simple Machines