August 25, 2019, 04:31:44 am
Welcome, Guest. Please login or register.
Did you miss your activation email
News:

Arturia Forums



Author Topic: MIDI Mapping Issue/Assistance  (Read 668 times)

daradow

  • Newbie
  • *
  • Posts: 2
  • Karma: 0
MIDI Mapping Issue/Assistance
« on: June 17, 2016, 02:55:44 am »
Hello,

I am running my DJTT Midi Fighter TWISTER and having a minor issue when mapping. The Twister has 4 banks (pages) that can be changed using the side buttons (channel 3) and the the 16 rotary dials are on channel 0 and encoders on channel 2. I can map the modular V to the encoders across the 4 different banks and they work; however, it is when pressing the CH 3 buttons shifting from say bank 1 to bank 2 that top banner for arturia presents changes from blank to 'arturia' and all the settings are changed. It seems as if only 1 bank (16 knobs) can be mapped, but upon export and examination of the midi config file, i see nothing assigned to CH3 and so I it curious why any button on Ch3 would be recognized and affect operation.

any help would be appreciated. my goal is to map the modular v dials across all 4 banks (16 rotary encoders x 4).

***UPDATED***

Realize some CC are hard coded and explains later issue.

Bigger issue is bank 2 irrespective of what buttons i code to get me there somehow triggers a preset which isn't so great. I found a work around in the stand-alone mode to switch midi to only recognize CH 1 but then it limits all the encoder buttons. This work around only works in stand-alone mode. it does not work for the VST in maschine 2.4.

thanks!

thanks in advance!
« Last Edit: June 17, 2016, 06:00:28 am by daradow »

 

Carbonate design by Bloc
SMF 2.0.13 | SMF © 2016, Simple Machines