February 25, 2021, 11:25:46 am
Welcome, Guest. Please login or register.
Did you miss your activation email
News:

Arturia Forums



Author Topic: SparkLe hardware controller not working inside Sonar as a Vst plugin  (Read 1079 times)

BongSong

  • Apprentice
  • Apprentice
  • *
  • Posts: 17
  • Karma: 0
Hello,

I have my SparkLe hardware controller working as a VST Plugin inside Sonar 8.5.3 on my laptop. All of the buttons work, play, stop, record, etc, and the 8 drum pads.

However when I hook up the SparkLe hardware controller to my new pc, used as a VST plugin inside Sonar 8.5.3, only the 8 drum pads work. Work as in when they are triggered, sounds are heard.

I am using windows 7 64bit on both computers, including the same version of Sonar 8.5.3.

Any suggestions to get the other buttons working as they do on my laptop?

I have read a few articles on the Arturia forum regarding this issue but they were incomplete.

Also, I am completely blind so can not provide any visual feedback such as lights on or off, etc.

Thanks,

James

BongSong

  • Apprentice
  • Apprentice
  • *
  • Posts: 17
  • Karma: 0
Re: SparkLe hardware controller not working inside Sonar as a Vst plugin
« Reply #1 on: December 29, 2015, 04:24:04 pm »
Here's an update.

1.
I found that when you have a project in which you are not using the Spark Vst plugin in this project, and the SparkLe drivers are checked in Midi Devices, only the 8 drum pads work. (Using SparkLe as a midi controler to controll other soft synths.)

2.
Conversely, if you are using SparkLe in your project, and the SparkLe drivers are checked in Midi devices, only the 8 drum pads will work. None of the other buttons work, play, stop, record, mute, solo, etc.

So if you want the other buttons to work, be sure to uncheck SparkLe in Midi devices.

3.
The weird thing is that although you can record midi notes coming from the SparkLe controller into Sonar via the 8 drum pads, I can't figure out how to record the midi notes from the SparkLe sequencer.

IE. Hammering out my own drum beat in a few of the 16 sequence slots, then hitting play. The midi information just isn't being passed onto Sonar.

This remains to stump me and no one has ever provided any solutions to this issue.

I wonder if it has something to do with what I recall reading on a few of the articles on the web, SparkLe having both a private and public port? I would like to delve into this further. Where does one locate these ports?

 

Carbonate design by Bloc
SMF 2.0.17 | SMF © 2019, Simple Machines