December 03, 2021, 04:01:37 pm
Welcome, Guest. Please login or register.
Did you miss your activation email

Arturia Forums

Author Topic: [Bug] Feedback loop with filter causes no sound until "resetting" instrument  (Read 2022 times)


  • Sr. Member
  • ****
  • Posts: 433
  • Karma: 1
    • Voxonitus Soundcloud
Okay! Perhaps I shouldn't have done this, but I wondered how it would sound if it even worked at all. -- Running a mix of oscillators out to a resonant LPF then running the output of that LPF back into the very same mix-group of the VCOs that were sent to it.
Well, it didn't work. It made absolutely NO sound whatsoever, though the instrument was clearly getting MIDI signal (tried both as a VSTi and standalone) ... well, so much for that idea.
But, not only did it not work as expected, but it broke all the filters as well. As in, NO patch I subsequently loaded, that used any filters, would make any sound!! That is, until I "reset" the instrument by loading up a preset that did not use any filters at all. Then the instrument started making sounds again, and I could subsequently load patches that used the filters, and they would work again.
Clearly, one should not be running feedback loops using the filters I guess LOL  :P
Still, it seems that the complete lack of audio upon loading a totally different preset is a bit of a bug, no?

Anyhow, thanks for such an awesome virtual instrument. I'll likely never get my hands on a real Mg Modular, so having a virtual one to mess about with is too sweet!

Also, I recently read that you guys  are working on updating the GUI of all your instruments to make them re-sizeable. I sure hope this is true, and VERY much look forward to a readable interface.  8)  ;D

Actually, doing some sound design last night, I discovered that it's not just creating feedback loops that causes this problem. I had it happen with another patch I'd set up. I wish I'd saved the patch to show you what had happened, but I forgot to. :( oops
Basically, something glitched out and I started getting crackling and pops, then no audio. Again, switching to a patch not involving any filters did again create sound. I encountered the problem this time while messing about between S&H, ring mod, bode shifter, two LFOs, an envelope generator, and two filters (one LPF the other multi-mode) but I don't recall exactly what I had running into what. I was using 3 VCO for audio, and a few others for additional LFO generators.
It was a pretty complex patch, really. But nothing was feeding back into anything else .. I'm pretty sure ........ it was working fine up until it glitched out, and when that happened I was merely adjusting knobs, not placing wires.
This time I was working in my DAW (Reaper) and actually had to delete that instance of Modular V and open a new one to get any patches involving the filter to make any sound.
« Last Edit: April 24, 2015, 04:40:42 pm by artao »
This space left intentionally blank.


  • Jr. Member
  • **
  • Posts: 58
  • Karma: 2
Yes, I can confirm that. I also cannot put my finger on what triggers that behaviour, but somehow overloading the filter drives it into state with no output. Indeed, loading a new preset does not help, one has to unload the plugin and load it again.

A 'panic' button, which would really reset all modules, would definitely help, and of course, more stable filters in the first place...



  • Apprentice
  • Apprentice
  • *
  • Posts: 24
  • Karma: 0
    • CL516 BLOG
You can do some feedback and stuff like that, but eventually it will just crap out like you guys mentioned.  At least all you get is silence... I usually get a crazy loud POP!  But, it is just an older software trying to do its best, so it ain't bad.  I find that applying some feedback with moderation can help to make some great sounds.


Carbonate design by Bloc
SMF 2.0.17 | SMF © 2019, Simple Machines