March 01, 2021, 07:46:40 am
Welcome, Guest. Please login or register.
Did you miss your activation email
News:

Arturia Forums



Author Topic: Midi Control Center doesn't recognize BeatStep Pro (cure found)  (Read 6011 times)

siseturist

  • Jr. Member
  • **
  • Posts: 66
  • Karma: 5
    • Soundcloud
I'm in a bit of a trouble here. I have Beatstep and Beatstep Pro. No problems with Beatstep, but Beatstep Pro settings can't be reached through Midi Control Center in OS X. At 1st it says that it needs an update - ok, update can be done after deleting the driver in Audio Midi Settings and then booting up holding rec/stop/play. Then it says that it can't understand the firmware revision (understands it in Windows version and shows the correct one) and then a popup appears saying "Failed to open the device." Then when pressing sync it says it again that an update is available - I've even reinstalled firmware several times and nothing helps.

It seems to me the bug is in Midi Control Center not in my system or BSP.

Is there a fix or is there an update coming?
« Last Edit: July 19, 2015, 01:06:58 pm by siseturist »

siseturist

  • Jr. Member
  • **
  • Posts: 66
  • Karma: 5
    • Soundcloud
Another weird thing I noticed. In Audio Midi Setup or in any software the device doesn't show up as Beatstep, but instead it's named USB MIDI Device. Is that normal?

Terrym

  • Global Moderator
  • Hero Member
  • *****
  • Posts: 1.525
  • Karma: 40
    • soundcloud.com/logicaldream
Hi, It should be named beatstpro and there should be 2 midi drivers delete both or if its highlighting when the bsp is on,delete that driver as well .
 is your firmware and mcc upto date?



terrym
TerryM
ARTURIA Tester for Keystep pro,Audiofuse range, Microfreak,Kl49mkII,DrumBrute,Spark,Analog lab3,KLE,kl88,matrix12,Semv,Beatstep,Minibrute 2,Pigments
ASC,Vcol6, Beatstep pro, VCOL7, Synclavier v.Minibrute2s

siseturist

  • Jr. Member
  • **
  • Posts: 66
  • Karma: 5
    • Soundcloud
In OS X it shows that it can't detect device or firmware but in Windows it shows it has the latest firmware, but asks to update. When I update it tells me that all went fine but still tells me there's an update, which is with the same version as the one which is on the device.

I have deleted the drivers and tried everything and it doesn't seem to change anything.

siseturist

  • Jr. Member
  • **
  • Posts: 66
  • Karma: 5
    • Soundcloud
When trying to fix it today the device didn't even show up in OS X or Windows anymore.
Then I plugged it into another USB port on my MacBook Pro and it reinstalled the driver again and now it shows up correctly - hopefully works too.

 

Carbonate design by Bloc
SMF 2.0.17 | SMF © 2019, Simple Machines