December 02, 2020, 01:24:55 pm
Welcome, Guest. Please login or register.
Did you miss your activation email
News:

Arturia Forums



Author Topic: SPARK 2.1.0.426 Lag with Logic X  (Read 16801 times)

Terrym

  • Global Moderator
  • Hero Member
  • *****
  • Posts: 1.499
  • Karma: 40
    • soundcloud.com/logicaldream
Re: SPARK 2.1.0.426 Lag with Logic X
« Reply #30 on: March 16, 2015, 07:04:49 pm »
We are testing at the moment ,still have bugs to iron out before release.



terrym
TerryM
ARTURIA Tester for Keystep pro,Audiofuse range, Microfreak,Kl49mkII,DrumBrute,Spark,Analog lab3,KLE,kl88,matrix12,Semv,Beatstep,Minibrute 2,Pigments
ASC,Vcol6, Beatstep pro, VCOL7, Synclavier v.Minibrute2s

giuseppealbrizio

  • Apprentice
  • Apprentice
  • *
  • Posts: 25
  • Karma: 0
Re: SPARK 2.1.0.426 Lag with Logic X
« Reply #31 on: March 17, 2015, 05:45:32 pm »
Thank you for replying. Looking forward to hear good news from you.


JB ARTURIA

  • Tech-Support
  • Apprentice
  • *
  • Posts: 22
  • Karma: 7
Re: SPARK 2.1.0.426 Lag with Logic X
« Reply #32 on: March 19, 2015, 12:11:31 pm »
Hi All,

There is the actual beta version a Spark :
Mac : https://owncloud.arturia.net/index.php/s/0o6USZFvuC35Fq1
Pc : https://owncloud.arturia.net/index.php/s/4fLuPsF47Go6k4K

I would like you (if you want) to test this version of Spark in Logic pro.

 - Is it working better ?

- What is the difference for you with the previous version ?

- Is it still unusable, or it can be used like that ?

If it doesn't works, it means that we'll have to deeply change the spark code and it will take lot of times.

Thanks for testing and helping us.

JB

jsmirk

  • Jr. Member
  • **
  • Posts: 74
  • Karma: 2
Re: SPARK 2.1.0.426 Lag with Logic X
« Reply #33 on: March 20, 2015, 07:58:32 am »
I've tried out this beta version on the latest version of os x and logic. The bug described in this thread seems fixed but new problems with responsiveness have shown up. Without the spark le controller, during playback, changing parameters is not smooth and jerks around. With the controller, it's worse... I can't change parameter values at all during playback - only once I hit stop and play again does the change become active... The gui knobs aren't even responding as I move the knob on the controller. This beta version seems to unfortunately not be much of a step forward.

Terrym

  • Global Moderator
  • Hero Member
  • *****
  • Posts: 1.499
  • Karma: 40
    • soundcloud.com/logicaldream
Re: SPARK 2.1.0.426 Lag with Logic X
« Reply #34 on: March 21, 2015, 04:17:13 pm »
I've tried out this beta version on the latest version of os x and logic. The bug described in this thread seems fixed but new problems with responsiveness have shown up. Without the spark le controller, during playback, changing parameters is not smooth and jerks around. With the controller, it's worse... I can't change parameter values at all during playback - only once I hit stop and play again does the change become active... The gui knobs aren't even responding as I move the knob on the controller. This beta version seems to unfortunately not be much of a step forward.

can you recheck there no lag as i still get it here? try changing pattens on the controller and have the sequencer open . I'm getting it but not as bad as before.

thanks

terrym
TerryM
ARTURIA Tester for Keystep pro,Audiofuse range, Microfreak,Kl49mkII,DrumBrute,Spark,Analog lab3,KLE,kl88,matrix12,Semv,Beatstep,Minibrute 2,Pigments
ASC,Vcol6, Beatstep pro, VCOL7, Synclavier v.Minibrute2s

giuseppealbrizio

  • Apprentice
  • Apprentice
  • *
  • Posts: 25
  • Karma: 0
Re: SPARK 2.1.0.426 Lag with Logic X
« Reply #35 on: March 22, 2015, 03:42:42 am »
Cool thank you so much. I'm downloading and I'll give you a response asap!

jsmirk

  • Jr. Member
  • **
  • Posts: 74
  • Karma: 2
Re: SPARK 2.1.0.426 Lag with Logic X
« Reply #36 on: March 22, 2015, 05:05:19 am »
I've tried out this beta version on the latest version of os x and logic. The bug described in this thread seems fixed but new problems with responsiveness have shown up. Without the spark le controller, during playback, changing parameters is not smooth and jerks around. With the controller, it's worse... I can't change parameter values at all during playback - only once I hit stop and play again does the change become active... The gui knobs aren't even responding as I move the knob on the controller. This beta version seems to unfortunately not be much of a step forward.

can you recheck there no lag as i still get it here? try changing pattens on the controller and have the sequencer open . I'm getting it but not as bad as before.

thanks

terrym

Correct, there is no hiccup or lag anymore. There is some minor gui delay when adjusting parameters, but doesn't really affect usability as I sounds to me as if the audio is being modified in priority.

My response above was inaccurate now that i've tested more thoroughly.  It seems that I can produce a bug when the spark le controller is connected: The three gui instrument parameter knobs in the Main view are always change to Instrument 1 after:
1) closing the gui
2) press play in logic, looping (gui still closed)
3) changing a parameter using the P1,P2,P3 knobs while looping (gui still closed)
4) stop looping
5) opening the gui

The gui will correct itself after selecting a new instrument (or the same one). I assume this action triggers a redraw of the gui.

So, this isn't affecting playback so much as the gui and the controller staying in sync whilst opening and closing the gui.  It initially confused me.

I've also tested some other things that used to be broken and have found they may be fixed.  Can we have a list of what items should be fixed?  I would love to continue testing. 

we're getting closer....

jsmirk

  • Jr. Member
  • **
  • Posts: 74
  • Karma: 2
Re: SPARK 2.1.0.426 Lag with Logic X
« Reply #37 on: March 22, 2015, 05:09:30 am »
btw, when can we start working on enhancements and features??  ;D

jsmirk

  • Jr. Member
  • **
  • Posts: 74
  • Karma: 2
Re: SPARK 2.1.0.426 Lag with Logic X
« Reply #38 on: March 22, 2015, 06:38:34 am »
Encountered another problem whilst working with the beta in Logic. I closed the gui, left the controller connected, set it aside and opened up some synth plugins on other tracks and it seems that eventually the spark le controller locks up and the plugin cannot connect to it.  I then tried to unplug and plug in the controller in hopes that it would be able to reconnect, but logic froze completely and I had to force quit.  This general sequence of events has now happened multiple times.

Terrym

  • Global Moderator
  • Hero Member
  • *****
  • Posts: 1.499
  • Karma: 40
    • soundcloud.com/logicaldream
Re: SPARK 2.1.0.426 Lag with Logic X
« Reply #39 on: March 22, 2015, 09:58:35 am »
Hi , This is the list i was given of fix and features. but some bug are still there.
####Features
* Step Shift and Repeat Shortcut
        - Hold a step + turn the knob "Divide" to set the repeat amount. Hold a step + turn the knob "Move" to shift the position of te step.
* SparkLE shortcut : set Shuffle amount with Select + Tempo

####Fixed Bugs
* Master channel Vu-meter is pre FX (Should be post)
* Steps "17-32" and "33-65" not displayed on the mainpage when sequence is running.
* Impossible to save an effect and a multi routing preset
* Spark not installed for the ASC
* Mixer fader jumps when clicking on it
* GUI locked on top left on the screen on PT 10.3
* Import/Export bank doesn't work
* Audio Export get deleted on plugin close

thanks

Terrym
TerryM
ARTURIA Tester for Keystep pro,Audiofuse range, Microfreak,Kl49mkII,DrumBrute,Spark,Analog lab3,KLE,kl88,matrix12,Semv,Beatstep,Minibrute 2,Pigments
ASC,Vcol6, Beatstep pro, VCOL7, Synclavier v.Minibrute2s

art34dmv

  • Newbie
  • *
  • Posts: 1
  • Karma: 0
Re: SPARK 2.1.0.426 Lag with Logic X
« Reply #40 on: March 23, 2015, 08:50:35 am »
I have done everything trying to set up sparkle with logic pro x
and cannot make it work. set up iac drive and everything..please any pointers will be appreciated

giuseppealbrizio

  • Apprentice
  • Apprentice
  • *
  • Posts: 25
  • Karma: 0
Re: SPARK 2.1.0.426 Lag with Logic X
« Reply #41 on: March 23, 2015, 03:33:12 pm »
Ok cool all is working fine regarding the issue with the "Open GUI". It seems to work better now. There are still some new issue like the impossibility to recall the instrument from the disk without the GUI open. It worked fine in the 1.7.2 version but now it seems to disappear!

By the way the main issue with the GUI Seems to be solved. Super!

giuseppealbrizio

  • Apprentice
  • Apprentice
  • *
  • Posts: 25
  • Karma: 0
Re: SPARK 2.1.0.426 Lag with Logic X
« Reply #42 on: March 25, 2015, 06:34:46 pm »
Ok a list of bug noticed after few tests:

1) Function that able to recall (kit/instr/disk section with clicking the big knob without the GUI opened completely dispappeared. Nothing happen if you press the big knob without the GUI open and the software in use.

2) The knob Loop and Divide don't move separately but if you move Divide also the Loop virtual knob moves.

3) The main GUI problem appears only if the track is armed (R). But all of us know that you have to switch off the REC button to use the controller in the best way. 


jsmirk

  • Jr. Member
  • **
  • Posts: 74
  • Karma: 2
Re: SPARK 2.1.0.426 Lag with Logic X
« Reply #43 on: March 26, 2015, 05:59:46 am »
I found a new bug in the beta. For me, this happens in standalone and logic pro x plugin. I'm able to repeat this 100% of the time.

* changing master volume causes the gui to refresh and respond slowly.
1) open Spark
2) change master volume
3) press play
Pads, meters, and steps are all affected.

jsmirk

  • Jr. Member
  • **
  • Posts: 74
  • Karma: 2
Re: SPARK 2.1.0.426 Lag with Logic X
« Reply #44 on: March 29, 2015, 08:00:28 am »
Also, this bug relating to sample start-end points still exists on Mac standalone and Logic AU:
http://forum.arturia.com/index.php?topic=83604.msg116003#msg116003
« Last Edit: March 29, 2015, 06:43:35 pm by jsmirk »

 

Carbonate design by Bloc
SMF 2.0.17 | SMF © 2019, Simple Machines