September 26, 2020, 07:53:37 am
Welcome, Guest. Please login or register.
Did you miss your activation email
News:

Arturia Forums



Author Topic: Trouble Connecting 2 MiniBrutes via USB in OSX  (Read 1267 times)

daisykutter

  • Apprentice
  • Apprentice
  • *
  • Posts: 5
  • Karma: 0
Trouble Connecting 2 MiniBrutes via USB in OSX
« on: November 10, 2014, 01:39:38 am »
I am trying to connect a second MiniBrute into my system. The problem I am having is that only 1 instance of MiniBrute appears in the MIDI Devices window in OSX. If i disconnect one of them and reconnect it, the last one connected takes over. I would appreciate any insight or advice as to how I can troubleshoot this. I am hoping it's a simple fix.

Thanks in advance!

MarctheDarc

  • Apprentice
  • Apprentice
  • *
  • Posts: 36
  • Karma: 4
Re: Trouble Connecting 2 MiniBrutes via USB in OSX
« Reply #1 on: November 10, 2014, 11:20:55 pm »
Perhaps changing the MIDI-channel on them would help?
Seeing as atm only 1 will connect at a time, just connect 1 and set it to MIDI-channel 2. Connect the other and set it to 3 (or any other than 2 and "any"). The MIDI-channel should store internally, and perhaps help OSX identify them as seperate units.
Remember, any change here will affect how DAWs and MIDI hardware route signals to them, so they will require the correct corresponding MIDI-channel to be selected.

Otherwise perhaps, connecting 1, making a manual change to the MIDI devices name in OSX, and once done connect the other.

Mind you, this is just quick thoughts. I don't own 2 and haven't had similar issues, but think it's worth a shot.

daisykutter

  • Apprentice
  • Apprentice
  • *
  • Posts: 5
  • Karma: 0
Re: Trouble Connecting 2 MiniBrutes via USB in OSX
« Reply #2 on: November 11, 2014, 01:08:16 am »
Some good ideas.

Last night I disconnected both from the computer, deleted the instance of the MiniBrute in the Midi Devices window in OSX. I reconnected one of the MiniBrutes and when it was recognized in the MIDI Devices window, I renamed it from MiniBrute to MiniBrute1. A then connected the second one hoping it would appear in addition to the first, but it did not. It simply took over MiniBrute1.

I have not tried setting each to a different MIDI channel as of yet, but will definitely give that a try as soon as I get a chance!

Thanks

daisykutter

  • Apprentice
  • Apprentice
  • *
  • Posts: 5
  • Karma: 0
Re: Trouble Connecting 2 MiniBrutes via USB in OSX
« Reply #3 on: November 12, 2014, 03:54:48 pm »
Setting them to different MIDI channels did not work. Renaming the MIDI Device instance did not work.

kickwizard

  • Full Member
  • ***
  • Posts: 227
  • Karma: 15
    • My soundcloud
Re: Trouble Connecting 2 MiniBrutes via USB in OSX
« Reply #4 on: November 12, 2014, 04:54:47 pm »
I think your going to struggle if the PID and VID are the same it will cause a collision and call the same driver as it doesnt know there is two and will only identify one device

Is there no way of you using din midi for both ? (i assume one usb and one din will give different latency)


daisykutter

  • Apprentice
  • Apprentice
  • *
  • Posts: 5
  • Karma: 0
Re: Trouble Connecting 2 MiniBrutes via USB in OSX
« Reply #5 on: November 12, 2014, 06:18:10 pm »
That's what I'm afraid of. I can see the 2 individual devices in the System Information on USB buss.

Using DIN MIDI is definitely an option. I am all out of MIDI ports at the moment so I might have to dig up my old MIDI Thru box!. I have an Edirol UM-880 and 2 MOTU Micro Lites that are all full. Interesting that the MOTU Micro Lites appear individually and it automatically renames the second one to add "#2".

Anyway, was hoping to plug and play with USB to avoid having to do so.


kickwizard

  • Full Member
  • ***
  • Posts: 227
  • Karma: 15
    • My soundcloud
Re: Trouble Connecting 2 MiniBrutes via USB in OSX
« Reply #6 on: November 12, 2014, 06:54:40 pm »
Im guessing the micros use a propritery motu driver which could rename the device name and load the driver for a second instance for an identical device

Im also guessing the brute uses an apple driver which doesn't seem to have this capability

I will be honest and could be wrong havent got a brute or mac

Good luck
« Last Edit: November 13, 2014, 11:51:59 pm by kickwizard »

daisykutter

  • Apprentice
  • Apprentice
  • *
  • Posts: 5
  • Karma: 0
Re: Trouble Connecting 2 MiniBrutes via USB in OSX
« Reply #7 on: November 14, 2014, 05:33:54 pm »
The Micro Lites do indeed require a MOTU driver. I have a ticket open with Arturia Support. As soon as I get word I will post the resolution here.

Thanks!

 

Carbonate design by Bloc
SMF 2.0.13 | SMF © 2016, Simple Machines