May 09, 2021, 10:01:40 pm
Welcome, Guest. Please login or register.
Did you miss your activation email
News:

Arturia Forums



Author Topic: Sequence is LATE in Ableton  (Read 5648 times)

audiolemon

  • Newbie
  • *
  • Posts: 1
  • Karma: 0
Sequence is LATE in Ableton
« on: August 13, 2014, 12:52:23 pm »
Hello,

I am using BeatStep (v 1.0.1.4) in Live 9 and the MIDI sequence from Beatstep is LATE by about 30 milliseconds.

For example: I make a sequence using Beatstep controlling a soft synth (it sounds awesome). I program some drums in on another track using a different VST. If I play both the drums and the sequence together the Beatstep sequence is LATE every time. I have to use a track delay of approx 30ms on the drum track and then they are synced perfectly and stay in sync. If I record in the sequence as MIDI notes into a track in LIVE you can see they are quite late. The attached picture is a recording of an 8 step FWD sequence recorded into LIVE. The first note should be on beat 1.1.1. You can see it is a 32nd note late at 128BPM.

This shouldn't happen. I have a lot of sequencers including hardware analog sequences, sequencers I built in Max/MSP and sequencers on my iPad - none of these suffer this problem.

P.S. love the upgrade that put swing on the front panel.

P.P.S. when in ALT mode the sequence starts on step 1 and Step 8 alternating (I usually use 8 Step Alt sequences). It should start on step 1 all the time.
« Last Edit: August 13, 2014, 01:23:46 pm by audiolemon »

nolongerhuman

  • Apprentice
  • Apprentice
  • *
  • Posts: 18
  • Karma: 2
Re: Sequence is LATE in Ableton
« Reply #1 on: August 14, 2014, 08:27:25 am »
Read the post I made right under yours. I, and many, many others, have the same issue.

salece

  • Newbie
  • *
  • Posts: 1
  • Karma: 0
Re: Sequence is LATE in Ableton
« Reply #2 on: October 09, 2014, 11:50:15 pm »
I'm having the exact same problem... 30ms delay. This happens when hooked up both via USB and MIDI.

I have noticed that it the latency all but disappears (drops to around 3ms) when monitor on the midi track is turned off and I just record a clip. Although this is not a workable solution as I need to be able to hear what I'm recording! I've tried all sorts of different routing to try to alleviate the problem but am getting nowhere fast.

I'm having trouble finding anything about this problem outside of these forums. Got the unit today and I absolutely love the concept but this latency makes it unusable! Hope Arturia can respond to this problem before I sell the beatstep.



xonir

  • Apprentice
  • *
  • Posts: 3
  • Karma: 0
Re: Sequence is LATE in Ableton
« Reply #3 on: October 12, 2014, 07:40:35 pm »
Same problem here!

Arturia please SOLVE the problem!

bloodmonkey

  • Newbie
  • *
  • Posts: 1
  • Karma: 0
Re: Sequence is LATE in Ableton
« Reply #4 on: November 11, 2014, 03:42:24 pm »
After hours of trying to get this thing to sync with Ableton I've decided to try and sell this thing, troubleshooting is not worth the effort. Brilliant idea, poor execution.This is definitely an Arturia/firmware related issue... Here's hoping I can get back at least half of what I paid for it. I was considering other Arturia products like the minilab or microbrute but after poor support with this product I think it's best I take my coin elsewhere.

Gothboy

  • Full Member
  • ***
  • Posts: 192
  • Karma: 3
    • Dymaxion Vehicle
Re: Sequence is LATE in Ableton
« Reply #5 on: February 20, 2015, 12:22:40 am »
Wow this is interesting never saw this post until now.....was this ever fixed?
Mac Pro 3.1,2x2.80 GHz. Intel Xeon Quad core 16GB RAM
2 OS drives: El Capitain 10.11.6\Mountain Lion 10.8.5 Ableton Live Suite 9.7.7\10.0.2
V collection 3, SparkLE 2.1, Beatstep

Gothboy

  • Full Member
  • ***
  • Posts: 192
  • Karma: 3
    • Dymaxion Vehicle
Re: Sequence is LATE in Ableton
« Reply #6 on: February 20, 2015, 02:41:19 am »
Just tried this the workaround is to use record Quantization in Ableton set to the note value of your sequence.  It then syncs perfectly in Ableton.
« Last Edit: February 20, 2015, 04:29:07 pm by Gothboy »
Mac Pro 3.1,2x2.80 GHz. Intel Xeon Quad core 16GB RAM
2 OS drives: El Capitain 10.11.6\Mountain Lion 10.8.5 Ableton Live Suite 9.7.7\10.0.2
V collection 3, SparkLE 2.1, Beatstep

Phil_G

  • Apprentice
  • Apprentice
  • *
  • Posts: 10
  • Karma: 0
Re: Sequence is LATE in Ableton
« Reply #7 on: July 28, 2016, 04:27:01 pm »
I used the BeatStep to Record into ProTools and found that it was late by 2301 samples that's .052 secs the only thing is though if you switch to control mode and give the DAW the offset the pads will be late! Might not be off by the same amount the same in ableton but in reason I also found I could not sync the sequencer to it. For those who don't know, Measure the gap from 0 to where first hit is on the recorded MIDI from the beatstep to get your negitive offset.

great-bear

  • Newbie
  • *
  • Posts: 2
  • Karma: 0
Re: Sequence is LATE in Ableton
« Reply #8 on: January 31, 2018, 02:24:22 am »
Just put "-30ms" in the Midi Clock Sync Delay in Ableton preferences - that's what this setting is for. Ableton will remember it and you can forget about the problem. You need to do this for each USB port that you will be using the beatstep with.
« Last Edit: January 31, 2018, 02:26:22 am by great-bear »

 

Carbonate design by Bloc
SMF 2.0.17 | SMF © 2019, Simple Machines