May 26, 2020, 03:10:48 pm
Welcome, Guest. Please login or register.
Did you miss your activation email
News:

Arturia Forums



Author Topic: Knob encoder acceleration setting  (Read 29243 times)

wyzzard

  • Newbie
  • *
  • Posts: 1
  • Karma: 0
Re: Knob encoder acceleration setting
« Reply #60 on: June 19, 2015, 10:06:39 pm »
Dear Arturia, any updates on this issue?

crony

  • Apprentice
  • Apprentice
  • *
  • Posts: 20
  • Karma: 0
Re: Knob encoder acceleration setting
« Reply #61 on: August 19, 2015, 11:06:10 am »
It's a shame, really...We are on the official forum, this been a bug for months, and no one is answering...
 >:(

soulstar

  • Apprentice
  • Apprentice
  • *
  • Posts: 12
  • Karma: 0
Re: Knob encoder acceleration setting
« Reply #62 on: August 24, 2015, 11:28:34 am »
It's a disgrace, I will never buy any of their products again.

BLEO

  • Apprentice
  • Apprentice
  • *
  • Posts: 23
  • Karma: 0
    • The dUmmydroMe
Re: Knob encoder acceleration setting
« Reply #63 on: September 11, 2015, 03:49:50 pm »
FYI this is exactly how the encoders work on the Beatstep Pro. Went back and watched the official video and noticed that there are some interesting cuts when the guy was using the encoders for filter sweeps. Hmmm.

BLEO

  • Apprentice
  • Apprentice
  • *
  • Posts: 23
  • Karma: 0
    • The dUmmydroMe
Re: Knob encoder acceleration setting
« Reply #64 on: September 15, 2015, 08:00:29 pm »
I haven't tried this yet, but if you're looking for a way to go from 0 to 127 fairly easily and you're just controlling a VST, this plugin could help.

http://www.thepiz.org/plugins/?p=midiCurve

You could essentially add one node and place it at x: 64, y:127 and that will essentially half the amount of twisting it takes to get to 127. Change x value to individual taste!

Not gonna help for controlling external hardware, but it's a workaround until (IF) Arturia fixes this behavior!

Bravadah

  • Newbie
  • *
  • Posts: 1
  • Karma: 0
Re: Knob encoder acceleration setting
« Reply #65 on: November 20, 2015, 03:21:18 am »
A similar solution for Linux (as the one described on Windows, using Midi Virtual ports etc) is this:

- install qmidiroute
- open qmidiroute
- If you use KXStudio  w/ JACK or their repos (Recommended), use Catia (or qjackctl if you don't have Catia) to map arturia Midi out -> qmidiroute in (otherwise, on ALSA, use aconnect -i and -o options on terminal)
- on qmidiroute, add a Map
- change input type for "controller", value from "95" to "127"
Set your desired DAW / Software / etc to use qmidimapper out (again, using Carla or qjackctl or aconnect) and you're good to go.

Same caveats apply - you lose some fine-resolution (again, you are diminishing the knob resolution at a 1/4 via software to do a full circle, so by just 1 slight knob tap you jump 4 CC changes.)

Would be so much better to have the real deal... oh my.

phimeis

  • Newbie
  • *
  • Posts: 2
  • Karma: 1
Re: Knob encoder acceleration setting
« Reply #66 on: February 25, 2016, 06:41:09 am »
This issue has been unsolved yet. My environment is below:
OSX Firmware1.2.0.3 MCC1.2.2.429 (Mode/Control Option/Absolute Channel/Global)
ABLETON LIVE 9 (Control Surface/none  MIDI/input none  MIDI/output none)
When I assign parameters(Live,AU) on the encoders, some encoder action is incorrect.
Actually, Knob2 action has include following problems:
 ・When i right turning the knob,the parameters swing to left turning suddenly
 ・Acceleration speed faster than another knob(resolution is too rough)
I tried to change mode to NRPN/RPN of MCC and absolute to Relative 1,2,3. However, hasn't been resolved.


MR79

  • Apprentice
  • Apprentice
  • *
  • Posts: 18
  • Karma: 0
Re: Knob encoder acceleration setting
« Reply #67 on: June 14, 2017, 03:07:38 pm »
Arturia still not solved this issue???

DanBailiff

  • Apprentice
  • *
  • Posts: 3
  • Karma: 0
Re: Knob encoder acceleration setting
« Reply #68 on: October 30, 2019, 02:33:29 am »
So this still seems to be an issue.

I was expecting the rotary encoder to be a 1:1 ratio. That is, turn the knob one revolution and it would go 0 to 127. Instead it appears to take two full revolutions to turn the knob. I don't want "acceleration", I want to be able to set the turn ratio for a full set of values.

I know this is an old thread, but come on, people have been asking for this fix for years now.

mi5t4

  • Newbie
  • *
  • Posts: 1
  • Karma: 0
Re: Knob encoder acceleration setting
« Reply #69 on: November 21, 2019, 09:52:24 pm »
So this still seems to be an issue.

I was expecting the rotary encoder to be a 1:1 ratio. That is, turn the knob one revolution and it would go 0 to 127. Instead it appears to take two full revolutions to turn the knob. I don't want "acceleration", I want to be able to set the turn ratio for a full set of values.

I know this is an old thread, but come on, people have been asking for this fix for years now.
I have the same problem, did you find a solution?

JZ_Chi

  • Newbie
  • *
  • Posts: 2
  • Karma: 0
Re: Knob encoder acceleration setting
« Reply #70 on: April 07, 2020, 03:45:18 pm »
Still a problem in April 2020.

On the first page of this post, the Arturia support guy said they were working on a solution... in 2014.

Best solution I found was in a Max For Live device:
https://maxforlive.com/library/device/2243/beatstep-speeddialer
But who wants to re-map a M4L device every time? And what if you are using multiple M4L devices on top of this work-around? The combination/layers of M4L logic do not always work and need to be reconfigured.

Ive seen that the KeyStep has a solution for 1:1 correlation between physical knob turn and software knob. How the encoders are different is unknown to the consumer.

Nobody wants "knob acceleration". Its unpredictable. Sometimes you want to quickly move a knob 20%. You dont want that quick movement to become a random value between 20 and 100%. Setting the acceleration to "slow" makes that 20% move something like 5-10% which absolutely nobody ever wanted.

Its sad because there is no other device with this many pads/knobs in this small of a footprint.

What a wasted opportunity. What kind of damage has this done to their reputation for the last 6 years?
« Last Edit: April 07, 2020, 03:49:37 pm by JZ_Chi »

JZ_Chi

  • Newbie
  • *
  • Posts: 2
  • Karma: 0
Re: Knob encoder acceleration setting
« Reply #71 on: April 09, 2020, 03:47:51 pm »
Arturia support wrote back with a suggestion to use a middleman between Beatstep and Ableton called Bome Midi.

Léo (Arturia Support)
Apr 9, 14:50 CEST
Hi Jason,
I'm sorry for the inconvenience,
In case the behavior observed is the same across all the encoders and if the actual behavior isn't reaching your expectations, you should be able to try the workaround suggested below by one of our users which may help improve things:
The main cause of the behaviors may be related to the acceleration mode defined, however when using the slow mode, it may require many turns to browse through the whole data range.
Applying a multiplier per step could help even if this would consequently not allow you browsing all the values (so may not apply to all the situations depending on your needs). If you'd like to give it a try, please follow the steps below:
- Install Bome’s Midi Translator Classic Edition (Shareware) and get it to translate the CC message coming from the Beatstep.
- In Relative 1 mode, the encoders send a value of 63 for each decrease and 65 for each increase, so you have to translate those values to something like 58 and 70 respectively to make the adjusted parameter change by increments of ~3.
- This means for 8 encoders you have to set up 16 translations because you have to take into account each direction of rotation.
Since the free version of Bome’s does not provide a virtual MIDI port with which to route its output to your DAW, you may have to use another utility called loopMIDI which receives the translated messages from Bome’s and can be selected in your DAW as an input port.
- Ableton’s encoder mode has to be set to Relative(linBinOffset) to respond correctly.
- Also, in Bome’s you have to check the MIDI Thru option and in your DAW, make sure to only accept input from the loopMIDI port, don't take input from the untranslated Beatstep and don’t output anything to the loopMIDI port.
This won't affect Beatstep’s sequencer mode, so the encoders still move the note one up or down per step (Main reason which explains why the Beatstep uses Stepped encoders which doesn't have any display as well).
Please let me know if this works on your end,
Looking forward to hearing from you,
Kind regards.
Léo - Arturia Support


---
Here is some other information I think others might find useful:

here are my observations of the encoder behaviors when Beatstep is set to "slow"
Arturia Beatstep and Ableton Midi macro knob mapping conditions

Absolute: stuck in a small value range in the middle

Relative (signed bit): backwards.
Clockwise = slowly downwards
Counter-Clockwise = quickly upwards

Relative (bin offset): slow in both directions

Relative (2's Comp.): Backwards and velocity sensetive
Clockwise speed = slowly downwards
Counter-Clockwise = quickly upwards

Relative (Signed Bit 2): Slow up, quickly down
Absolute 14 bit (must be CC 95 or lower)*****

Relative (lin. Signed Bit): backwards.
Clockwise = slowly downwards
Counter-Clockwise = quickly upwards

Relative (lin. BinOffset): Slow in both directions. Seems to have some velocity built in.

Relative (lin. 2's Comp.): Backwards and quick in both directions. 5 total positions/values.

Relative (lin.Signed Bit 2): Slow up, quickly down

---

The best M4L workarounds Ive found are
Multimapper32 which allows you to set curves on macro knobs
https://maxforlive.com/lib.../device/2348/multimapper32audio

and the easiest version Ive found is Beatstep Speed dialer which allows for multiplication of the encoders movement
https://maxforlive.com/.../device/2243/beatstep-speeddialer

 

Carbonate design by Bloc
SMF 2.0.13 | SMF © 2016, Simple Machines