October 17, 2017, 07:16:40 pm
Welcome, Guest. Please login or register.
Did you miss your activation email

Arturia Forums

Author Topic: Can't record in Logic Express 9.1.7  (Read 1133 times)


  • Newbie
  • *
  • Posts: 2
  • Karma: 0
Can't record in Logic Express 9.1.7
« on: September 04, 2012, 06:52:59 am »
Hello everyone, please help with this problem...

I am trying to record Spark VDM in Logic Express 9.1.7. However it does not record.

I have followed all of the instructions of how to install Spark VDM and in Logic, I can open it as a plug-in, but it wont record onto a track.

I followed the instructions on page 82 of the "Spark Creative Drum Machine" user's manual, but it still doesn't record.

In the Environment window (in Logic) I noticed that I don't have "Spark Private IN" or "Spark Public IN".

Also I have made sure that in the IAC Driver Properties window the Device Name is "IAC Driver" and the port name is "Spark1 midi OUT".

Please help as I have wasted a whole day trying to sort this out,

I look forward to your help,

P.S I also have a Novation Remote 25SL connected to Logic. That is working fine...I don't know if this effects Spark VDM.


  • Hero Member
  • *****
  • Posts: 1.543
  • Karma: 82
    • http://www.arturia.com
Re: Can't record in Logic Express 9.1.7
« Reply #1 on: September 04, 2012, 09:00:04 am »
first question, what do you want exactly to record?

I guess you want to record MIDI from Spark sequencer but I am not sure.

I think you already saw this video but if not please look at it.

This video if for recording real time MIDI (when you type on Spark Controller Pads) but this applies also on this case. The only difference is that you have to set ON the Pref called "Send MIDI from Sequencer" instead of "Send MIDI from Pads".

One thing, the name of the port is "Spark1 Midi OUT" not "Spark1 midi OUT"

Last remark, all the stuff related to Spark Private IN/OUT in the Environment is relevant when you are using Spark hardware Controller.

Soft Arturia


  • Newbie
  • *
  • Posts: 2
  • Karma: 0
Re: Can't record in Logic Express 9.1.7
« Reply #2 on: September 04, 2012, 01:37:31 pm »
Hi Kevin,

Thanks for your reply and helping out. I changed the port to "Spark1 Midi OUT" like you suggested. Then I restarted my mac. Now it works! Thanks for helping out :-)



  • Apprentice
  • *
  • Posts: 6
  • Karma: 0
Re: Can't record in Logic Express 9.1.7
« Reply #3 on: September 08, 2012, 06:33:32 pm »
We love the sounds and technology in standalone but really want to be able to plug in the AU then sequence sounds as per usual with controller input and notes playing out to Spark.

…But we've had a new Spark sitting here for a week because it doesn't play nice in a DAW :( It's made an old engineer (Air Studio's) get angry… and he's a Buddhist.

We've followed the video and this workaround but all we're getting after 2 days, is a single note (of many) played then an Arturia or Logic crash or a sticky midi note.  We've tried with the environment recabled and also left as is over AU AND IAC.

I'll post a well documented response here when it works in our Logic 9 with AU.

In other words.
Help! We ain't got long to get this working.


Carbonate design by Bloc
SMF 2.0.13 | SMF © 2016, Simple Machines