October 24, 2017, 11:59:32 am
Welcome, Guest. Please login or register.
Did you miss your activation email

Arturia Forums

Author Topic: Spark Plugin Not Working in Pro Tools  (Read 2633 times)


  • Apprentice
  • *
  • Posts: 11
  • Karma: 0
Spark Plugin Not Working in Pro Tools
« on: June 27, 2011, 03:03:13 am »
Help! Please!
   I may be new to the recording arts but I have a degree in electronics and Ive been trained and certified for every Apple System and OS since 1982. I work in all kinds of environments solving all kinds of software, hardware and network problems and I know it just cant be this ridiculously difficult to get a Spark to work in Pro Tools 9.0.3.

Let me be clear on what Im looking for. I need to know that, yes, the Spark is currently not so much compatible with Pro Tools 9.0.3 and the expected fix will be out in so may days/weeks/months OR Spark is fine, but I need to do X,Y or Z to make it work with Pro Tools OR Spark has compatibility issues with X,Y,Z hardware or software OR Pro Tools has an issue that Avid is working on and an update will be out in the next so many days/weeks/months OR that I am making all of the newbee mistakes in one go and the following clearly written English language documents will set me on the correct path so I can quit mucking around with this expensive studio and actually let the fellow who owns it ply his incredibly talented craft.

   Currently the Spark will run fine in the standalone software. Nice, but not what Im interested in. I want the Spark to put down MIDI on one track and its audio on another just like I do with the Arturia 49 Laboratory Experience. Sometimes the Spark will kind of do that, but mostly it wont. Mostly it just crashes Pro Tools.

I have dumped all the Audio MIDI Setup prefs and even created a new setup in AMS.  I have dumped the Pro Tools prefs several times. I have even reinstalled the Spark drivers and done the 1.1.1 update again.  I have run PT with zero, none, nada other plug-ins except the Arturia ones. PT crashed when I tried to bring the Spark in on an instrument track. I ran PT with just the Spark plugin. PT crashed when I launch the Spark plug-in. The Spark window opens but instead of spinning the connection indicator and making a connection with the Spark, the plug-in does nothing for about 4 seconds then bam! Pro Tools crashes.

   If I open an existing project that has the Spark already loaded in an instrument track it will make contact most of the time. If I deactivate the Spark in the instrument track, then re-activate it, Pro Tools crashes.  If I create a new instrument track inside a project that works with the Spark and then try and load the Spark into a new instrument track, PT crashes. Obviously it didnt always do this but even for the few times it did load properly it would eventually crash or not depending on the east wind and time of day.
The only difference between now and when I could at least launch Spark in PT is that I installed all of the updates for the Origin (took it from 1.0.7 to 1.3.5). Everything else is the same and incredibly stable.

I have tried using a wall wart for power and midi cables to the MOTU Express 128 and found that NOTHING will see the Spark if the USB cable is not plugged in. That too strikes me as ODD, it is a MIDI device after all. Below is the rest of the information. Of note, after I did the Spark 1.1.1 update both this last time and the very first time, it placed a grayed out update controller at the top of the Audio MIDI Setup.

Thanks for any and all help and or suggestions, we really do want to keep the spark.

PS. it looks like the pix won't load in below. Sorry.

Mac Pro 2 X 2.26 Quad-Core Intel Xeon
10.6.7  - 6 gig ram  - 4 TB over 5 drive (SATA, USB & FireWire). 
MOTU- Two 2408, HDX-SDI, Express 128
Arturia Spark, 49 Laboratory, Origin (all current updates)
Electrix Warp Factory
Focusrite and Benchmark pre's
Tascam recorders, Alsis ADAT, JLCooper controllers
Furman signal router, headphone monitor
Pro Tools 9.0.3 plus a few expensive plug-ins.

   I added a blank MIDI instrument in the pictures below just to show what the controller connections are detected as. Normally there is nothing attached to the Spark or UpDate controller. Also, I put the Analog Laboratory on MIDI cables and a wall wart since its primary usage is to control the Origin.
The UPGRADER (Spark 1.1.1 upgrade) is always grayed out but why is it even showing up?

The Spark shows TWO sets of ports. The left are the Public In and Public Out. The right are the Private Ports in and out.
The ports are of course unchangeable.
Note: When I do the MIDI test, it is only the Private In port that indicates that it is active. That may be normal but since there is no documentation on that part, I can only guess.

Pro Tools 9.0.3

The SPARK shows up as a Controller in the Predefined sub section with an option for Private and Public.  Private in is an option even though I have it unchecked. Why?

Crash Log with only the SPARK plug-in installed:

Process:         Pro Tools [2132]
Path:            /Applications/Digidesign/Pro Tools/Pro Tools.app/Contents/MacOS/Pro Tools
Identifier:      com.digidesign.ProTools
Version:         9.0.3 (9.0.3f81)
Code Type:       X86 (Native)
Parent Process:  launchd [139]

Date/Time:       2011-06-25 20:52:12.714 -0700
OS Version:      Mac OS X 10.6.7 (10J869)
Report Version:  6

Interval Since Last Report:          167363 sec
Crashes Since Last Report:           35
Per-App Interval Since Last Report:  16105 sec
Per-App Crashes Since Last Report:   30
Anonymous UUID:                      C1C84D4D-5565-425D-AD95-CEE6C0AE2A98

Exception Type:  EXC_BAD_ACCESS (SIGBUS)
Exception Codes: KERN_PROTECTION_FAILURE at 0x0000000000000001
Crashed Thread:  0  Dispatch queue: com.apple.main-thread

Thread 0 Crashed:  Dispatch queue: com.apple.main-thread
0   libSystem.B.dylib                0x94caaeb9 wcscmp + 23
1   com.arturia..SparkRTAS           0x2e32f9a2 juce::operator<(juce::String const&, juce::String const&) + 34
2   com.arturia..SparkRTAS           0x2e1899cf ARTURIA::ArturiaPreset::GetAttribute(std::multimap<juce::String, juce::String, std::less<juce::String>, std::allocator<std::pair<juce::String const, juce::String> > >&, juce::String const&) + 59
3   com.arturia..SparkRTAS           0x2e17a611 ARTURIA::ADSPreset::GetInstrumentAttribute(unsigned char, juce::String const&) + 39
4   com.arturia..SparkRTAS           0x2e17167c ARTURIA::ADSPresetManager::GetMotionTypeName(int, int, ARTURIA::ADSPreset*, ARTURIA::AJGuiInterface*) + 200
5   com.arturia..SparkRTAS           0x2e0ce7b0 ARTURIA::ADSInstrumentSelectSection::UpdateParametersName(int, int) + 632
6   com.arturia..SparkRTAS           0x2e0cf226 ARTURIA::ADSInstrumentSelectSection::ChildInternalUpdate() + 1548
7   com.arturia..SparkRTAS           0x2e0cfbbd ARTURIA::ADSInstrumentSelectSection::setGuiParameter(int, float) + 895
8   com.arturia..SparkRTAS           0x2e0cf838 non-virtual thunk to ARTURIA::ADSInstrumentSelectSection::setGuiParameter(int, float) + 40
9   com.arturia..SparkRTAS           0x2e187f3a ARTURIA::AJParameterMessenger::broadcastSetGuiParameter(int, float) + 134
10  com.arturia..SparkRTAS           0x2e187c67 ARTURIA::AJParameterMessenger::handleMessage(juce::Message const&) + 67
11  com.arturia..SparkRTAS           0x2e201b9a juce::MessageManager::deliverMessage(void*) + 138
12  com.arturia..SparkRTAS           0x2e35e7ca juce::AppDelegateRedirector::runLoopSourceCallback(void*) + 186
13  com.apple.CoreFoundation         0x962f94cb __CFRunLoopDoSources0 + 1563
14  com.apple.CoreFoundation         0x962f6f8f __CFRunLoopRun + 1071
15  com.apple.CoreFoundation         0x962f6464 CFRunLoopRunSpecific + 452
16  com.apple.CoreFoundation         0x962f6291 CFRunLoopRunInMode + 97
17  com.apple.HIToolbox              0x94397e04 RunCurrentEventLoopInMode + 392
18  com.apple.HIToolbox              0x94397bb9 ReceiveNextEventCommon + 354
19  com.apple.HIToolbox              0x94520084 _AcquireNextEvent + 54
20  com.apple.HIToolbox              0x94515d40 RunApplicationEventLoop + 228
21  com.digidesign.framework.DFW     0x031510e9 DFW_EventLoop::RunApplicationEventLoop() + 11
22  com.digidesign.framework.DFW     0x0303865b TApplication::Run() + 45
23  ...gidesign.framework.ProTools   0x01dc6ebf LaunchProTools + 4774
24  com.digidesign.ProTools          0x0000f5a2 0x1000 + 58786
25  com.digidesign.ProTools          0x0000e5b7 0x1000 + 54711
26  com.digidesign.ProTools          0x0000e4e5 0x1000 + 54501

73 threads and the frameworks listing deleted to fit the post. Can send full logs upon request

Model: MacPro4,1, BootROM MP41.0081.B07, 8 processors, Quad-Core Intel Xeon, 2.26 GHz, 6 GB, SMC 1.39f5
Graphics: NVIDIA GeForce GT 120, NVIDIA GeForce GT 120, PCIe, 512 MB
Memory Module: global_name
Bluetooth: Version 2.4.0f1, 2 service, 12 devices, 1 incoming serial ports
Network Service: Ethernet 1, Ethernet, en0
PCI Card: pci-bridge, sppci_pci2pcibridge, Slot-3
PCI Card: pci137a,5, sppci_audio, Slot-3@4,0,0
PCI Card: pci-bridge, sppci_pci2pcibridge, Slot-4
PCI Card: pci-bridge, sppci_pci2pcibridge, Slot-4@6,2,0
PCI Card: pci-bridge, sppci_pci2pcibridge, Slot-4@6,1,0
PCI Card: pci-bridge, sppci_pci2pcibridge, Slot-4@9,0,0
PCI Card: pci1033,e0, USB Enhanced Host Controller, Slot-4@10,0,1
PCI Card: pci1033,35, sppci_usbopenhost, Slot-4@10,0,0
PCI Card: pci-bridge, sppci_pci2pcibridge, Slot-4@6,0,0
PCI Card: pci-bridge, sppci_pci2pcibridge, Slot-4@7,0,0
PCI Card: pci104c,823f, sppci_ieee1394openhci, Slot-4@8,0,0
PCI Card: NVIDIA GeForce GT 120, Display, Slot-1
PCI Card: MOTU HDX-SDI, sppci_video, Slot-2
Serial ATA Device: HL-DT-ST DVD-RW GH41N, 408.7 MB
Serial ATA Device: WDC WD6400AAKS-41H2B0, 596.17 GB
Serial ATA Device: WDC WD1600AAJS-00L7A0, 149.05 GB
Serial ATA Device: Hitachi HDS722020ALA330, 1.82 TB
USB Device: Hub, 0x0409  (NEC Corporation), 0x005a, 0xfa200000
USB Device: 15 in 1 MEDIA READER USB 2.0, 0x050d  (Belkin Corporation), 0x0211, 0xfa220000
USB Device: iLok, 0x088e, 0x5036, 0xfa230000
USB Device: CFUDMA_SD Reader, 0x05dc  (Lexar Media, Inc.), 0xb035, 0xfa210000
USB Device: Keyboard Hub, 0x05ac  (Apple Inc.), 0x1006, 0x20100000
USB Device: Plantronics .Audio 646 DSP, 0x047f  (Plantronics, Inc.), 0xc001, 0x20110000
USB Device: USB Optical Mouse, 0x046d  (Logitech Inc.), 0xc064, 0x20130000
USB Device: Apple Keyboard, 0x05ac  (Apple Inc.), 0x0220, 0x20120000
USB Device: Spark Controller, 0x1c75, 0x0301, 0x1d100000
USB Device: Express  128, 0x07fd, 0x0001, 0x3d100000
USB Device: BRCM2046 Hub, 0x0a5c  (Broadcom Corp.), 0x4500, 0x5a100000
USB Device: Bluetooth USB Host Controller, 0x05ac  (Apple Inc.), 0x8215, 0x5a110000
FireWire Device: Duende Mini board, Solid State Logic, Up to 400 Mb/sec
FireWire Device: built-in_hub, Up to 800 Mb/sec
FireWire Device: Hard Drive FW/USB, LaCie, Up to 400 Mb/sec
FireWire Device: 934DS Drive 0, Oxford, Up to 800 Mb/sec


  • Hero Member
  • *****
  • Posts: 1.543
  • Karma: 82
    • http://www.arturia.com
Re: Spark Plugin Not Working in Pro Tools
« Reply #1 on: June 27, 2011, 09:25:15 am »
Hi papacriss,
There are some issues with Pro Tools in the 1.1.1.
The forthcoming update should resolve most of them.

Soft Arturia


  • Apprentice
  • *
  • Posts: 11
  • Karma: 0
Re: Spark Plugin Not Working in Pro Tools
« Reply #2 on: June 27, 2011, 10:27:28 am »
Thank you so much for the quick response Kevin. Any idea when that update will be out?


  • Hero Member
  • *****
  • Posts: 1.543
  • Karma: 82
    • http://www.arturia.com
Re: Spark Plugin Not Working in Pro Tools
« Reply #3 on: June 27, 2011, 10:29:24 am »
hopefully next week
Soft Arturia


  • Apprentice
  • *
  • Posts: 11
  • Karma: 0
Re: Spark Plugin Not Working in Pro Tools
« Reply #4 on: June 27, 2011, 10:30:34 am »
Cool. Thank you so much. We'll play with other toys until then. :-)


  • Apprentice
  • *
  • Posts: 11
  • Karma: 0
Re: Spark Plugin Not Working in Pro Tools
« Reply #5 on: July 02, 2011, 02:15:55 am »
Any news on a time frame for the update? I would love to actually see this work for us,  :)


  • Hero Member
  • *****
  • Posts: 1.543
  • Karma: 82
    • http://www.arturia.com
Re: Spark Plugin Not Working in Pro Tools
« Reply #6 on: July 04, 2011, 08:58:52 am »
It should be released at the beginning of the week (probably later today).
Soft Arturia


  • Apprentice
  • *
  • Posts: 11
  • Karma: 0
Re: Spark Plugin Not Working in Pro Tools
« Reply #7 on: July 06, 2011, 04:32:33 am »
The update worked like a champ. The Spark runs in ProTools without any issues. Well Almost. I still get the private channel warning (1st picture). If I turn off private in (picture 2), I can't recored any MIDI beats from the Spark. There is no way to turn off private out (as far as I know). Perhaps not a huge deal but it does leave me confused. I'm using just the USB cable at the moment. I'm hesitant to play around too much with it since I just need it to work until we get a few projects done, but I am willing to try anything that does not "break" our setup.
Thanks for the fix.


Carbonate design by Bloc
SMF 2.0.13 | SMF © 2016, Simple Machines