April 07, 2020, 07:14:15 pm
Welcome, Guest. Please login or register.
Did you miss your activation email
News:

Arturia Forums



Author Topic: ORIGIN ON PORT 1 CONFLICT WITH SSL MATRIX ON LOGIC  (Read 4453 times)

aledestefanis

  • Apprentice
  • Apprentice
  • *
  • Posts: 11
  • Karma: 0
ORIGIN ON PORT 1 CONFLICT WITH SSL MATRIX ON LOGIC
« on: January 25, 2010, 12:36:57 pm »
Hi everyone,
I'm having troubles with origin an ssl matrix and logic:
basically we have an ssl matrix set as a controller (Mackie controller and extender) on logic.
Now the ssl matrix has to be set on port 1 for the controller and 2 for the extender to be able to work with logic.
My trouble is that when i try to use origin, it starts working fine but for some reason sometimes it tends to crush the system erasing the settings on logic for the ports.
From what i understand from the manual i should be able to change origins port (device ID) in the midi preferences tab on origin, but this is not actually possible cause, for unknown reason i'm not able to change origin device id no more....i guess Arturia set it to standard on port 1 as i can see every preset or multi has got 1 has ID.....
Hope that topic make sense!!!!
Another thing is the origin connection that just crush with our mixing rig...i guess that too has to do with midi settings and the ssl Matrix, cause it's all working fine on another workstation where no matrix is present...
ORIGIN IS GREAT...love the FAT sound of it....really would like to sort out this issue and really hope anyone  could help us sort that out!!!!
best
alex

aledestefanis

  • Apprentice
  • Apprentice
  • *
  • Posts: 11
  • Karma: 0
Re: ORIGIN ON PORT 1 CONFLICT WITH SSL MATRIX ON LOGIC
« Reply #1 on: January 25, 2010, 08:51:27 pm »
Do u guys think i should ask for specific technical support?

Alex

aledestefanis

  • Apprentice
  • Apprentice
  • *
  • Posts: 11
  • Karma: 0
Re: ORIGIN ON PORT 1 CONFLICT WITH SSL MATRIX ON LOGIC
« Reply #2 on: January 27, 2010, 12:00:04 pm »
Please guys??!!! can anyone help me with that??!!! ::)

tomeso

  • Beta-testers
  • Jr. Member
  • *
  • Posts: 67
  • Karma: 3
Re: ORIGIN ON PORT 1 CONFLICT WITH SSL MATRIX ON LOGIC
« Reply #3 on: January 27, 2010, 02:51:18 pm »
Most of the time you do not need to connect the Origin through USB (only for sound management and upgrades). Why don't you just use a simple MIDI interface and connect Origin through MIDI?.

I am not sure what you mean by "port", you may confuse this with MIDI channels?

confused ...
Frank

"But please don't listen to me
I've already been poisoned by this industry!"
Funk Pop a Roll - XTC

aledestefanis

  • Apprentice
  • Apprentice
  • *
  • Posts: 11
  • Karma: 0
Re: ORIGIN ON PORT 1 CONFLICT WITH SSL MATRIX ON LOGIC
« Reply #4 on: January 27, 2010, 04:02:59 pm »
yeah i know...MIDI is a bit confusing  :)

by port i mean one midi in / out connection (a midi port has 16 midi channels)...i'll try what u said with the midi interface...thanks.... ;)    .but like that i won't be able to use the origin connection, wich i guess would be useful, plus usb connection i guess should be a bit faster than midi interface? but anyway it may let it work better!!!
the problem i guess is that i cannot find that device ID section under the Midi tab / global Midi settings on origin, has stated on page 48, chapter 8.1.4.1, on the origin manual.... are u guys  able to find this device ID?????

thanks for reply Frank....was starting to get worried about life on the forum  ;D

alex

tomeso

  • Beta-testers
  • Jr. Member
  • *
  • Posts: 67
  • Karma: 3
Re: ORIGIN ON PORT 1 CONFLICT WITH SSL MATRIX ON LOGIC
« Reply #5 on: January 27, 2010, 05:12:28 pm »
The MIDI page has been revised several times and I don't remember that I have seen this ID parameter in later versions. It is not present in version 1.07 or 1.1.x.

You might also want to check that the following parameters on this page are set to off:
MIDI In to USB Out
USB In to MIDI Out
MIDI In to MIDI Out

If you are using several USB devices, you might use a USB hub? Try to connect the devices to different USB ports on you computer and try to avoid the hub. If you use a USB hub, try another with a separate power supply.

USB problems are sometimes a bit tricky ... so don't loose you hope or your temper.  :-)

Cheers

Frank
"But please don't listen to me
I've already been poisoned by this industry!"
Funk Pop a Roll - XTC

Philippe

  • Moderator
  • Sr. Member
  • *****
  • Posts: 437
  • Karma: 56
Re: ORIGIN ON PORT 1 CONFLICT WITH SSL MATRIX ON LOGIC
« Reply #6 on: January 27, 2010, 05:47:22 pm »
Quote
are u guys  able to find this device ID??

The device ID is a field which is used to distinguish between 2 or more identical machines connected to the same port.

We do hope that someday every Origin user will possess 2 or 3 Origin synths in his(her) studio, but it's not exactly the case today  ;)

To fully use this ID we had some more code to write - which we didn't - that's the reason why this ID has been removed from the UI.
Origin Lead  Developer

aledestefanis

  • Apprentice
  • Apprentice
  • *
  • Posts: 11
  • Karma: 0
Re: ORIGIN ON PORT 1 CONFLICT WITH SSL MATRIX ON LOGIC
« Reply #7 on: January 28, 2010, 02:33:04 pm »
hey there,

Yes Frank all those parameters are set to off and i have origin straight on usb on my mac...

Philwick, what i actually understand is that if i have to different machines, lets say the matrix and origin on the same midi port (1) i should not have any conflicts??

The thing of the matrix is that it uses all midi channels available on the port.....something that i have noticed though is that origin seems to work fine if i switch it on after the matrix:

i guess cause origin is going to port 1 via the matrix??

cause if i plug origin on belofre the console or for example logic crash, i loose my midi settings on logic and the possibility to use the matrix as a controller and apparently origin get first on the chain to port 1....dunno guys...just running my mind trough you and see if that makes sense to anyone...

really appreciate your help guys

thanks

alex

Philippe

  • Moderator
  • Sr. Member
  • *****
  • Posts: 437
  • Karma: 56
Re: ORIGIN ON PORT 1 CONFLICT WITH SSL MATRIX ON LOGIC
« Reply #8 on: January 28, 2010, 03:22:29 pm »
Quote
Philwick, what i actually understand is that if i have to different machines, lets say the matrix and origin on the same midi port (1) i should not have any conflicts??

No. If you connect 2 machines - wether identical or not - on the same port then you'll need to assign different midi channels for channel messages (note on / off, cc..). For instance if you want your machines to play each a single sound you'll have to assign - say - the midi channel 1 for the sound on the machine 1 and  the midi channel 2 for the sound on the machine 2.

Now suppose your 2 machines are from a different vendor. Then you can control each machine with midi sysex even if they are on the same midi port because the sysex contains the vendor ID.

If now your 2 machines are from the same vendor, the sysex sent to those 2 machines will contain the same vendor ID, therefore you'll need to add to the sysex an additional information so that when machine 1 receives a sysex it can tell wether this sysex is for it or for the machine 2. That's what the device ID is made for. In this example you could have chosen to assign the device id 1 to the machine 1 and the device id 2 to the machine 2.

Now if you connect your SSL and the Origin to the same midi port, you will get into trouble if the SSL needs all the 16 channels because the SSL and Origin will responds simultaneously which is surely not what you expect.

So try to find 2 different midi ports on your setup and connect the SSL on the 1st port and Origin on the 2nd one.

2 different USB connectors should yield 2 different MIDI ports.
Origin Lead  Developer

aledestefanis

  • Apprentice
  • Apprentice
  • *
  • Posts: 11
  • Karma: 0
Re: ORIGIN ON PORT 1 CONFLICT WITH SSL MATRIX ON LOGIC
« Reply #9 on: January 28, 2010, 04:30:25 pm »
ok....makes sense.... ;)

the think is that the matrix needs port 1 and 2.....how can i set origin for exaple on port 3???

we use a macpro and logic 8........regarding midi we use ipMidi wich is basically midi over ethernet...

Philippe

  • Moderator
  • Sr. Member
  • *****
  • Posts: 437
  • Karma: 56
Re: ORIGIN ON PORT 1 CONFLICT WITH SSL MATRIX ON LOGIC
« Reply #10 on: January 28, 2010, 04:43:53 pm »
How do you connect Origin to your rig?
Origin Lead  Developer

aledestefanis

  • Apprentice
  • Apprentice
  • *
  • Posts: 11
  • Karma: 0
Re: ORIGIN ON PORT 1 CONFLICT WITH SSL MATRIX ON LOGIC
« Reply #11 on: January 28, 2010, 06:54:07 pm »
via usb....

aledestefanis

  • Apprentice
  • Apprentice
  • *
  • Posts: 11
  • Karma: 0
Re: ORIGIN ON PORT 1 CONFLICT WITH SSL MATRIX ON LOGIC
« Reply #12 on: January 29, 2010, 04:23:26 pm »
was wondering if anybody of u guys was having trouble with automap and remote sl???

starting to think that may cause probs as well...


 

Carbonate design by Bloc
SMF 2.0.13 | SMF © 2016, Simple Machines