December 18, 2017, 08:20:52 am
Welcome, Guest. Please login or register.
Did you miss your activation email
News:

Arturia Forums



Author Topic: Filter mode knob doesn't work  (Read 9463 times)

xanderhing

  • Newbie
  • *
  • Posts: 2
  • Karma: 0
Re: Filter mode knob doesn't work
« Reply #30 on: July 19, 2016, 11:52:04 pm »
I have opened a ticket to report a faulty Filter Mode switch on 1 July: Case 290315
I have not heard back from Arturia.

Has anyone had any luck with replacing the Filter mode switch?
Can a part be purchased for this? If so, what is the part number?


xanderhing

  • Newbie
  • *
  • Posts: 2
  • Karma: 0
Re: Filter mode knob doesn't work
« Reply #31 on: August 10, 2016, 07:47:04 pm »
Jerome from Arturia responded to this query.

The replacement filter knob/rotary switch can be purchased at Mouser Electronics, part:
 
http://www.mouser.com/ProductDetail/Alpha-Taiwan/SR1712F-0204-20F0A-N9-N-027/?qs=%2fha2pyFadujuSFdWxZdTftuAGiL2g07YstDMm4YthCtPhOR3DkdiOMsw6dF8rLoU2%2fYrf1MZAoa%2fEkHsKO2s21d9EnSZgSAeyStxqqgPsOdf%2fz4gkJ2MF%2fqQlPkQ%252bekI

If you're based in NYC, Main Drag Music is pretty much the only place that is willing to replace it.

Main Drag Music
330 Wythe Ave.
Brooklyn, NY 11249
www.maindragmusic.com

aaronsim.92

  • Newbie
  • *
  • Posts: 1
  • Karma: 0
Re: Filter mode knob doesn't work
« Reply #32 on: August 06, 2017, 09:59:43 am »
Oh no...I'm facing the same issue with my Minibrute  :'(
Have any of you guys managed to fix it?

virusX

  • Newbie
  • *
  • Posts: 2
  • Karma: 0
Re: Filter mode knob doesn't work
« Reply #33 on: November 27, 2017, 04:05:11 pm »
I have the same issue on my Minibrute and it's because of a faulty Filter Mode knob.
Arturia answered my message, opened a ticket and exchanged two emails with me to make a correct diagnosis.
They're sending me a Filter Mode knob today.
The process took 4 business days so I'm really happy, almost impressed, with customer support (in France btw).

EDIT: received my knob in less than one week and soldered it.
It was not very difficult except that I found the solder on the clamps of the defective knob (not the connection pins) to be resistant at less than 30W.
Everything is working fine now
« Last Edit: December 13, 2017, 04:18:57 pm by virusX »

 

Carbonate design by Bloc
SMF 2.0.13 | SMF © 2016, Simple Machines