August 16, 2022, 02:35:21 am
Welcome, Guest. Please login or register.
Did you miss your activation email
News:

Arturia Forums



Author Topic: Minifuse 2: Ground loop issues  (Read 319 times)

dr.juice

  • Newbie
  • *
  • Posts: 1
  • Karma: 0
Minifuse 2: Ground loop issues
« on: June 23, 2022, 02:49:15 am »
I sent this to Arturia tech support but I'm posting here also.

I am using a Minifuse 2 with an electric guitar.

With my headphones when I set the monitor balance to hear processed USB audio coming back, I am experiencing a horrible buzzing noise when I touch my guitar strings, which I believe is a USB Ground Loop.

I do not have this problem when the computer runs off battery. The sound is super clean then.

I tried fixing this issue by using an iFi Defender+ 3.0, which is a USB ground loop eliminator. But whenever I plug power to the iFi Defender+, the minifuse shuts off and will not turn on. To turn it back on, I have to remove the iFi dongle, and plug the minifuse on the USB cable that is connected to the computer.

The iFi defender+ 3.0 is supposed to achieve this by supplying its own 5V power and ground, but it seems the Arturia is not liking this workaround one bit and refuses to power on.

Have any of you tried using an iFi Defender+ 3.0 with the Minifuse 1 or 2? 

Any idea at this point how I can eliminate the ground loop?

Does Arturia have a ground loop fixer that I can use with the minifuse?

I thought I read somewhere there is an Arturia product (Arturia Fuse?) that actually comes with a ground loop fixer thing, but that Arturia gizmo does not come with the minifuse.

Help!

 

Carbonate design by Bloc
SMF 2.0.17 | SMF © 2019, Simple Machines