July 06, 2022, 03:21:51 am
Welcome, Guest. Please login or register.
Did you miss your activation email
News:

Arturia Forums



Author Topic: Custom key velocity not working  (Read 155 times)

loph

  • Apprentice
  • *
  • Posts: 9
  • Karma: 0
Custom key velocity not working
« on: May 22, 2022, 09:28:16 pm »
Hi!

Ever since I've bought the KeyLab 49 mkII, I wanted to love it for its awesome build quality and CV features. But I've been struggling with the keys (especially the key velocity) just as long.

Now I've noticed, the custom key velocity doesn't work on my unit. I think it worked some time in the past, but right now playing on the keyboard feels like thrashing it with hammers - each note is too loud.

I've attached a screenshot of the Midi Control Center to ilustrate the problem:

In the "Device Settings", I've chosen "Velocity Curve: Custom" (yellow circle)
I've set the "Max Velocity" to 119 (red circle)
When hitting a key on the keyboard really hard, it still gives me a 127 (Hex: 7F) value (blue circle)

All the other custom velocity settings seem to be ignored as well (so the keys are triggered too "hard"). I can reproduce that behaviour in Ableton or any other DAW. And it doesn't matter if I change the values within the Midi Control Center App or the Keyboard setup.

Am I doing something wrong here, or is something else faulty?
The Firmware is version 1.3.1

loph

  • Apprentice
  • *
  • Posts: 9
  • Karma: 0
Re: Custom key velocity not working
« Reply #1 on: May 25, 2022, 11:11:49 am »
Ok, I've found the solution:

Not only you have to pick "Velocity Curve: Custon" in the device-settings/Midi Control Center App, you also need to use the App and pick "Velocity Curve: Custom" in the Keyboard-Section of the "Controller Map".

But now with the user velocity curve, the black keys react somehow differently than the white keys (pouring in singular, very loud velocities from time to time). This is getting quite frustrating ...

 

Carbonate design by Bloc
SMF 2.0.17 | SMF © 2019, Simple Machines