July 05, 2022, 11:23:41 am
Welcome, Guest. Please login or register.
Did you miss your activation email
News:

Arturia Forums



Author Topic: Reaper  (Read 549 times)

Mortal

  • Newbie
  • *
  • Posts: 1
  • Karma: 0
Reaper
« on: February 04, 2022, 05:49:55 pm »
I purchased this device, registered it, downloaded all the drivers, updated it. I start the reaper, select the DAW control mode - Reaper, and nothing happens. The Transporte panel does not respond, but the Reaper itself does not catch anything. Can I have some step-by-step instructions for integration?
I'm hope you guys understand me, cuz i'm use translator :P

seathos93

  • Newbie
  • *
  • Posts: 1
  • Karma: 0
Re: Reaper
« Reply #1 on: March 25, 2022, 01:01:57 am »
Hmmm -- I'm researching midi controller keyboards, and the Keylab 61 Mk II is my leading candidate.  I'm also using Reaper DAW.  The lack of feedback on your question makes me wonder why.  :-\

MajorFubar

  • Global Moderator
  • Hero Member
  • *****
  • Posts: 967
  • Karma: 26
Re: Reaper
« Reply #2 on: March 25, 2022, 08:37:02 am »
This is a users' forum, you generally do not get responses from Arturia staff. So answering your question relies on someone reading it who is a Reaper user. Because Arturia keyboards are very popular with all DAWs perhaps it would be best to ask on a Reaper forum.
2022 Apple Studio Max 32/32/2TB Monterey 2020 MBA 8/8/512GB Monterey V Collection 6 Analog Lab 4 + 5 KeyLab 88 KeyStep

kenwin67

  • Apprentice
  • *
  • Posts: 3
  • Karma: 0
Re: Reaper
« Reply #3 on: June 06, 2022, 11:33:29 am »
Connect Keylab MKII to your computer via USB.
Load Reaper, go to Options->Preferences->Audio->MIDI Devices and in
"MIDI inputs to make available (selectable as track inputs, etc.)"
you will find it.
Right-click on it and check "Enable input" and "Enable input for control messages" (assigned in actions menu).
This way you can play notes and control parameters with knobs, pads and transport controls.

Kurou

  • Newbie
  • *
  • Posts: 1
  • Karma: 0
Re: Reaper
« Reply #4 on: June 11, 2022, 10:19:50 pm »
The above comment is mostly right, but you also need to enable MCU in Reaper's settings to achieve full functionality. The complete list of things you need to do are as follows.

Step 0: Click the DAW button, then click it again and hold. Where it says "Daw Mapping", scroll until you see Reaper. Click the Scroll Wheel to select it.
Step 1: Use CTRL + P to open up the preferences menu. (Options>Preferences)
Step 2: Under Audio, click MIDI Devices, and double click "KeyLab mkII 88". Make sure both squares are checked. Hit Apply to enable.
Step 3: Scroll all the way down the side bar. Click the category, "Control/OSC/web".
Step 4: Hit "Add", and under the Control Surface Mode dropdown, click "Mackie Control Universal".
Step 5: For MIDI Input, choose "MIDIIN2 (KeyLab mkII 88)". For MIDI Output, click "MIDIOUT2 (KeyLab mkII 88)".
Step 6: Hit OK to exit the preferences menu.

Now your transport and faders should all work, and everything should be mapped correctly for as long as you are in Reaper mode under the Daw button.

 

Carbonate design by Bloc
SMF 2.0.17 | SMF © 2019, Simple Machines