July 02, 2022, 12:53:24 pm
Welcome, Guest. Please login or register.
Did you miss your activation email
News:

Arturia Forums



Author Topic: [SOLVED] Keylab 49 Essential encoder knob jumping values fix [SOLVED]  (Read 1008 times)

pc131

  • Apprentice
  • *
  • Posts: 6
  • Karma: 1
Hi,

I bought cheap used Keylab 49 Essential, but after few days I noticed that first encoder (Cutoff/Pan 1) had random jumps instead of linear values (sometimes second knob also did random jumps, but much less). I started searching for the solution, I downloaded newest firmware, it didn't help.

I removed the knob plastic head and I sprayed with WD40 onto potentiometer shaft and I was turning left and right, so WD40 goes down into potentiometer. It helped, but hasn't removed all the jumps.

So I used another fluid to get the job done.

But I decided this time to do it more "properly".

I unscrewed bottom cover: (3 screws pointed with pink arrow are longer than rest)


And I lifted the cover and moved it as red arrows show (lifting cover and moving towards you is blocked by keys/keyboard).

Then as you lift the bottom cover upwards (the part that is closer to you) you will see that there are 2 ribbons holding bottom and upper parts of keyboard.
Gently pull them out.




Put aside the part with keys and these two black ribbons.

Then tak the upper part and remove plastic heads of encoders and faders (pull the with fingers):



Flip this upper part upside down and unscrew the board, which keeps the encoders and faders.
While lifting this board, be careful because the ribbon (marked in blue) holding this board to the board on the right is glued. This ribbon cannot be unplugged.



There we have our potentiometers and the first form the left is encoder Cutoff / Pan 1 which had jumping values when turning.


I used small amounts of IPA (Isopropyl alcohol) onto the shafts, so it soaked down the potentiometer. And I was turning the shafts afterward.

And now THERE IS NO JUMPING over values of the encoder ------> https://www.youtube.com/watch?v=NFSIW788zSU

The knob turns now with less resistance than others, but works as intented. Probably this could have been done without unscrewing the whole thing, but I wanted to do it this way.

Hopefully this can help someone to fix their Keylab 49 Essential (and others with similar problem)



« Last Edit: November 29, 2021, 11:24:31 pm by pc131 »

MajorFubar

  • Global Moderator
  • Hero Member
  • *****
  • Posts: 959
  • Karma: 26
Re: [SOLVED] Keylab 49 Essential encode knob jumping values fix [SOLVED]
« Reply #1 on: November 29, 2021, 02:28:24 pm »
Great useful post, glad you fixed the issues.
2022 Apple Studio Max 32/32/2TB Monterey 2020 MBA 8/8/512GB Monterey V Collection 6 Analog Lab 4 + 5 KeyLab 88 KeyStep

echenao

  • Newbie
  • *
  • Posts: 2
  • Karma: 0
  • Just a hobbier
Re: [SOLVED] Keylab 49 Essential encoder knob jumping values fix [SOLVED]
« Reply #2 on: March 24, 2022, 05:59:16 pm »
Thanks for sharing!
I'm facing the same issue, I think the MIDI controller has an factory issue in some batch.

 

Carbonate design by Bloc
SMF 2.0.17 | SMF © 2019, Simple Machines