September 17, 2021, 02:06:14 pm
Welcome, Guest. Please login or register.
Did you miss your activation email
News:

Arturia Forums



Author Topic: Arturia Plugins Take Too Long to Load  (Read 226 times)

Valhjim

  • Newbie
  • *
  • Posts: 2
  • Karma: 0
Arturia Plugins Take Too Long to Load
« on: July 26, 2021, 02:52:00 pm »
Hi,

Hope someone can help me on this: All my Arturia Plug-ins take far too long to load onto Studio One 5. I found out that Arturia folders exist in two different places on my iMac: Library/Arturia and Applications/Arturia. Both contain all of Collection V programs and VSTs. Also, these instruments are in the VST and VST3 folders in Library/Audio/Plug-ins/VST3 abd /VST
Is this all right? Maybe St1 has to look in both places and decide where to load the instruments from?

Should I delete Arturia from one of those sites on my iMac?

 
« Last Edit: July 26, 2021, 03:34:52 pm by Valhjim »

LBH

  • Hero Member
  • *****
  • Posts: 3.910
  • Karma: 45
Re: Arturia Plugins Take Too Long to Load
« Reply #1 on: July 26, 2021, 06:29:39 pm »
Hi,

Arturias plug-ins are'nt the fastest out there to load. But it's impossible to say, if yours is loading slower than can be exspected, as you don't tell about your load time and about how fast your computer is.
The DAW can also have an impact on the load time.

It's normal to have the standalone version and at least one VST version installed. Having both VST2 and VST3 plugins installed - and even having other formats installed is normal. This should not affect the load time, unless perhaps a little, if you using a very full mechanical harddisk, so the computer is being slowed down.
You only need to have the Standalone and a single plugin version installed, if you don't need to use more. You can select in the installers, which plugins should be installed.

I'm on Windows. but if you take the time to read the installers text, when you install anything, then i think you actually should be able to answer the path questions you ask yourself.
I guess that you - like i - can look in Arturia Software Center (ASC) prefereces under folders to see where the VST versions is installed on your system. It sound like you have installed on default paths.

Valhjim

  • Newbie
  • *
  • Posts: 2
  • Karma: 0
Re: Arturia Plugins Take Too Long to Load
« Reply #2 on: July 26, 2021, 07:09:57 pm »
Thank you, LBH, for your reply.

I'll check the Arturia installer as you suggest. I'm on OS Mojave with 3.4 GhZ Intel Core i5.

Arturia's plugins are the only ones that take up to 4-5 minutes to load, which suggests that the problem lies with Arturia locations, perhaps. If Studio ONe 5 were to blame, other plug-ins would take as long.

I'll check the installer and keep trying to get faster plug-in times. I'm still puzzled at the existence of 3 locations for Arturia plug-ins, though.


LBH

  • Hero Member
  • *****
  • Posts: 3.910
  • Karma: 45
Re: Arturia Plugins Take Too Long to Load
« Reply #3 on: July 26, 2021, 07:53:26 pm »
Your welcome.

I'm on OS Mojave with 3.4 GhZ Intel Core i5.
Which disk? Internal SSD? Do you have enough storage space vand enough RAM?
Have you changed locations for the plugins? Have you installed the products more than once in different locations? If so, then that can give issues.

Arturia's plugins are the only ones that take up to 4-5 minutes to load, which suggests that the problem lies with Arturia locations, perhaps. If Studio ONe 5 were to blame, other plug-ins would take as long.

I'll check the installer and keep trying to get faster plug-in times. I'm still puzzled at the existence of 3 locations for Arturia plug-ins, though.
This is way to long time. 10-15 times or so to long perhaps, if your system works optimal. That's not normal it take so long. If you use the default locations and only have installed the product once, then the locations should not give issues.

It's normal for manufactors to have multiple formats plugins, so the product can be used by so many as possible. Nothing wrong in that. It should not give issues.

You can allways try to uninstall and remove everything, and then install the product again after a restart of the computer.

This link might be helpful - also to understand about how many locations you can have: https://www.arturia.com/faq/installation/uninstall-remove-a-software

Plugins in generel use more or less time to load. You can't say, that just because one plugin load fast, then they all will or shall do that. In Studio One you can exspect that especially the DAWs own plugins load very fast.
 

MajorFubar

  • Global Moderator
  • Hero Member
  • *****
  • Posts: 734
  • Karma: 19
Re: Arturia Plugins Take Too Long to Load
« Reply #4 on: July 27, 2021, 04:38:37 pm »
I'm on a Mac and can confirm Arturia plugins take just a few seconds to load, something definitely wrong there.
2011 iMac 27" MacOS 10.13 High Sierra 2012 MBP 13" Mojave V Collection 6 Analog Lab 4 + 5 KeyStep

 

Carbonate design by Bloc
SMF 2.0.17 | SMF © 2019, Simple Machines