October 16, 2021, 04:01:31 am
Welcome, Guest. Please login or register.
Did you miss your activation email
News:

Arturia Forums



Author Topic: I have VST2 and VST3 versions but my DAW will only show VST3?  (Read 1697 times)

markireland

  • Apprentice
  • Apprentice
  • *
  • Posts: 8
  • Karma: 0
I need to run the VST2 version for my old Novation Nocturn contoller and AutoMap to work.

LBH

  • Hero Member
  • *****
  • Posts: 3.924
  • Karma: 49
Re: I have VST2 and VST3 versions but my DAW will only show VST3?
« Reply #1 on: May 13, 2021, 04:26:24 pm »
Hi,

This is about how your DAW handle VST2 and VST3 plugins that have the same id.
If your DAW can't show both versions, then it might give priority to the VST3 version, if it have access to both. In this case you either need to turn off VST3 support or remove the VST3 plugins from a path your DAW read. Then the DAW will read the VST2 instead, if it's in a location the DAW read.

Beside that, then i've used a SL MK2 Novation Automap with VST3 plugins, after i've had enabled them in the Automap server.

That said, then please keep in mind, that Novation no longer support Automap. You might exsperience functionality that normal Automap no longer work. I do have some plugins (including Arturia plugins), where normal automap no longer work - at least  for the VST2 plugin while it can work for the VST3 plugin. I can't tell, if that's about the plugin vendors programming, Windows OS version or something else though. I can use Automap MIDI or normal midi CC templates then.

 

Carbonate design by Bloc
SMF 2.0.17 | SMF © 2019, Simple Machines