July 28, 2021, 03:21:24 am
Welcome, Guest. Please login or register.
Did you miss your activation email
News:

Arturia Forums



Author Topic: Cubase 11 Keylab 49 MK2 DAW mode problem  (Read 616 times)

aliena

  • Apprentice
  • *
  • Posts: 3
  • Karma: 0
Cubase 11 Keylab 49 MK2 DAW mode problem
« on: April 05, 2021, 05:01:28 pm »
I have gone through topics in the forum but could not find an answer to my question. Am I the only Keylab 49 MK2 owner who cannot use Cubase with preset Cubase DAW mode? When I enter Cubase DAW mode transport lights light up but nothing functions. Cannot use transport nor Track select/slider/fader/knobs. I'm on 1.2.4 firmware.

I found a workaround in Youtube where I set DAW mode to Standard HUI and select Mackie HUI in Cubase for Remote Devices but

a) I can't figure out why I need to use an alternative mode while there is a Cubase DAW mode embedded
b) Even in the workaround I'm using transfor controls are active as with select/fader/knops but I cannot select track numbers beyond 1-8 as in Arturia's Youtube videos since Next, previous buttons do not function properly. So if I want to select track 09 and beyond I need to go back to the computer mouse and keyboard which is loosing all the point for me to use Keylab as a remote MIDI control device.

Is there anyone who can help me with this?

Many thanks and kind regards.

LBH

  • Hero Member
  • *****
  • Posts: 3.823
  • Karma: 39
Re: Cubase 11 Keylab 49 MK2 DAW mode problem
« Reply #1 on: April 05, 2021, 06:58:54 pm »
Hi,

This is not a feature request.

Have you created the Mackie Control setup like you can read here: https://www.arturia.com/faq/keylabmkii/keylab-mkii-tips-tricks ?
If you are on Windows then read the note about the ports.
« Last Edit: April 05, 2021, 07:03:39 pm by LBH »

aliena

  • Apprentice
  • *
  • Posts: 3
  • Karma: 0
Re: Cubase 11 Keylab 49 MK2 DAW mode problem
« Reply #2 on: April 05, 2021, 10:07:31 pm »
Many thanks for your reply and apologies for posting in the wrong section. I was looking at the technical section and wondering where my post was  ;D

I have conducted all steps one by one şn the link you have provided but apparently everyone is focused on Ableton and noone uses Cubase on the Arturia side. Things got worse when followed the instructions on the link:

1- Had more transport control button lights functioning before in Mackie HUI mode but with the suggested settings all I get was the Stop transport button light (Mackie Control with added commands)
2- Midi In signal is distrupted and now not working for Keylab MKII 49 (Not MIDIIN2 one) although I haven't made any changes to that port. All I've done was to follow steps in the instructions.
3- Tracks after 1-8 is still cannot be selected. Youtube Arturia Keylab MK2 instruction videos were showing "Click Next/Previous Buttons" where leds were lighting up when the lady pressed these buttons and selected tracks higher than 9-...but this does not happen in Cubase. All you get is 1-8. (Are we all forced to use Ableton to make use of these standard features I wonder.)

Had to revert back to my previous setup using mackie HUI instead of Cubase in DAW mode. What a shame :(

And finally, this is now a feature request actually to have a proper Cubase DAW mode please.

LBH

  • Hero Member
  • *****
  • Posts: 3.823
  • Karma: 39
Re: Cubase 11 Keylab 49 MK2 DAW mode problem
« Reply #3 on: April 05, 2021, 10:45:32 pm »
I don't have a Arturia controller, and i don't use Cubase. But afaik, then people have it working. So it look like a understanding and/ or setting issue somewhere.

Is the Bank button on, when you try to shift 8 channels?

This is from the manual:
Next / Prev: Shifts the range of the selected channels in your DAW, which allows
you to focus the encoders, faders, and buttons on a particular set of channels.
The amount of shift is determined by the Bank button:
◦ Bank button ON (lit): Next / Previous buttons shift tracks by 8 channels
◦ Bank button OFF (dark): Next / Previous buttons shift tracks by 1
channel
• Bank: Toggles the function of the Next/Prev buttons.

flyjat76

  • Apprentice
  • *
  • Posts: 29
  • Karma: 0
Re: Cubase 11 Keylab 49 MK2 DAW mode problem
« Reply #4 on: April 06, 2021, 06:23:12 pm »
I use a KeyLab Mk2 with Cubase 10.5, has worked fine since I bought it last summer.

I just followed the guide as posted above.

My only issue is an occasional conflict between the rotary encoders in Analog Lab mode & the Cubase Track QCs which may have an easy fix but I haven’t looked into it too deeply yet.

There is a known bug that Arturia are working on (I know that as I submitted a ticket) where if more than 1 Arturia instrument is loaded in a project then the Preset Browsing function via the KeyLab Mk2 won’t function correctly. The selector knob & buttons work fine for all selected tracks but the LED display will be frozen to the 1st instrument loaded.

aliena

  • Apprentice
  • *
  • Posts: 3
  • Karma: 0
Re: Cubase 11 Keylab 49 MK2 DAW mode problem
« Reply #5 on: April 06, 2021, 08:05:54 pm »
I don't have a Arturia controller, and i don't use Cubase. But afaik, then people have it working. So it look like a understanding and/ or setting issue somewhere.

Is the Bank button on, when you try to shift 8 channels?

This is from the manual:
Next / Prev: Shifts the range of the selected channels in your DAW, which allows
you to focus the encoders, faders, and buttons on a particular set of channels.
The amount of shift is determined by the Bank button:
◦ Bank button ON (lit): Next / Previous buttons shift tracks by 8 channels
◦ Bank button OFF (dark): Next / Previous buttons shift tracks by 1
channel
• Bank: Toggles the function of the Next/Prev buttons.

One again thank you for your valuable time. I guess this is one of those moments where both of us are correct :)

I have gone through the setup from scratch once again. But this time rather than deleting my old setup created with Mackie HUI device, I created a second one with Mackie Control. It started to work. However the points I've mentioned in my above post are still problematic. And on the course, I've discovered there is no longer a Transport command "Use Metronome" in Cubase Device Menu. This means somethings must have changed from Cubase 10 to 11 on the DAW software side and Instructions on Web & Manuals need to be changed.  Which also means the more people migrate to new version they will realise mappings are not functioning properly. This will either lead to Arturia updating firmware to be compatible with the new version or people will start abandoning Cubase. (Since I'm on 30 days trial period I will have to take this route inevitably)

daniel78

  • Apprentice
  • *
  • Posts: 9
  • Karma: 0
Re: Cubase 11 Keylab 49 MK2 DAW mode problem
« Reply #6 on: April 21, 2021, 07:55:52 pm »
I'm trying to evaluate Cubase 11, and want something that works well with my keylab mk2. I too am having issues with the Mackie Control in Cubase.

The basic stuff works fine if i follow the online setup instructions.
However:
No track name is displayed when i select a track - in fact, the LCD display does not even respond to changing tracks.
Like Aliena said, the prev & next buttons dont seem to work, so i cant get past track 8. Instead they seem to be togging full left/right panning.

both of these are deal breakers... not sure if i need to switch DAWs or switch controller.

When i use knobs or sliders, the display *does* updats and shows "Track 3" or whatever, but still not the actual track name. Do any cubase users know if there is something im missing to get my user defined track names to display? Live and Bitwig both correctly display custom track names on the Keylab.

 

Carbonate design by Bloc
SMF 2.0.17 | SMF © 2019, Simple Machines