December 03, 2021, 11:27:20 pm
Welcome, Guest. Please login or register.
Did you miss your activation email
News:

Arturia Forums



Author Topic: Newly Bought Arturia Keylab MkII 88 Not Working  (Read 287 times)

bhaskarville

  • Newbie
  • *
  • Posts: 1
  • Karma: 0
Newly Bought Arturia Keylab MkII 88 Not Working
« on: August 22, 2021, 02:57:19 pm »
Hi Guys,

My newly bought Arturia Keylab MkII 88 isn't behaving the way it should.

I have no idea what's wrong.

So basically this is what's happening.

I play something on Keyscape, and suddenly random notes start playing on their own. These are not the notes I'm playing, but some random notes all over the keyboard. It's almost as if the keyboard got possessed.

The worst part is that the keyboard starts playing random chords even when I'm not even touching the keys. The VST keeps playing whatever randomly. I'm attaching a video of this to give you all an idea.

I am at my wits' end. If any of you have faced this issue before, please help me.

Thank You!

LBH

  • Hero Member
  • *****
  • Posts: 3.942
  • Karma: 49
Re: Newly Bought Arturia Keylab MkII 88 Not Working
« Reply #1 on: August 23, 2021, 08:22:57 pm »
Hi.

I can't use your video to understand anything as it's so blury, that i can't read anything.

If you are sure it's the controller that send out midi messages (You can check in a midi monitor), and if you are sure the controller is set up correct in your DAW, and you don't have the issue when you play a standalone application, then you can:

1. Reset the controller following the instructions in the manual carefully

If still and issue
2. Contact Arturia support and if needed return the unit.

FYI - I don't have an Arturia controller.

 

Carbonate design by Bloc
SMF 2.0.17 | SMF © 2019, Simple Machines