June 16, 2021, 04:26:16 pm
Welcome, Guest. Please login or register.
Did you miss your activation email
News:

Arturia Forums



Author Topic: FL Studio + keylab 88 MKII, analog lab instruments not playing individually  (Read 407 times)

DocJ

  • Newbie
  • *
  • Posts: 2
  • Karma: 0
Hi!
I recently bought a keylab 88 mkII and I'm trying to play different Analog lab instruments in FL Studio. It seems like I can't play the sounds of the different channels individually. They always play together. I saw that this was an issue a couple years ago. Is there a new solution to this?
Thank you!

DocJ

  • Newbie
  • *
  • Posts: 2
  • Karma: 0
I have to add that everything is set up as required.

radford

  • Apprentice
  • *
  • Posts: 8
  • Karma: 0
If you have FL studio 20.8, they include a new midi script API that can forward midi commands to the active channel plugin. FL studio even includes a user script you can configure your keyboard to to forward all midi commands to Port 10. With this, you would just configure the port of analog lab to Port 10.

Their script, however, does suppress sustain and expression pedals. There's an easy workaround.

Anyway, if all this is confusing, I explain in this video how to  configure keylab with FL studio (including analog lab)

https://youtu.be/TXZ3u1srTmw

Scripts located here:
https://github.com/rjuang/flstudio-arturia-keylab-mk2


Hope that helps
« Last Edit: December 28, 2020, 06:02:31 am by radford »

 

Carbonate design by Bloc
SMF 2.0.17 | SMF © 2019, Simple Machines