May 16, 2021, 04:41:59 am
Welcome, Guest. Please login or register.
Did you miss your activation email
News:

Arturia Forums



Author Topic: Sustain not working as expected  (Read 1464 times)

zerosmusic

  • Newbie
  • *
  • Posts: 1
  • Karma: 0
Sustain not working as expected
« on: November 14, 2020, 07:37:19 pm »
Hey,

I've noticed in Piano V2 I cannot get the sustain to behave properly. I've tried standalone, vst, and in analoglab. I'm using a Keylab 88 MKII and have no issues with any other VSTs.

If you could provide some support, I'd really appreciate that.

LBH

  • Hero Member
  • *****
  • Posts: 3.765
  • Karma: 38
Re: Sustain not working as expected
« Reply #1 on: November 14, 2020, 08:38:38 pm »
Hi and welcome to Arturia forums?

What's exspected? And what's happening?

Is your pedal connected to the controllers Sustain input?
Keep in mind, that Piano V2 both have Sustain and Sostenuto pedal beside Soft pedal. Be sure you control the correct one.
« Last Edit: November 14, 2020, 08:43:22 pm by LBH »

shmihe

  • Newbie
  • *
  • Posts: 1
  • Karma: 0
Re: Sustain not working as expected
« Reply #2 on: December 22, 2020, 01:09:05 am »
Having the same problem, sustain pedal has erratic behavior in Piano V2 - after latest update.

Pedal works fine and as expected with many other synths (V Collection 7), as well as other brand pianos/samplers/VSTs.

I have had this issue before, and the resulting solution was a new version (repaired) released from Arturia.

Sustain is either not working, works for a bit  here and there, then/and/or gets stuck until multiple foot taps releases it. Not positive, but it seems like only certain keys/notes are causing this.

neilmacneil

  • Apprentice
  • *
  • Posts: 4
  • Karma: 0
Re: Sustain not working as expected
« Reply #3 on: January 08, 2021, 11:51:30 am »
Having the same issues with piano v2.  My pedal/keyboard is sending midi, and I can even re-map it the sustain pedal but the pedal triggers no sustain. 

gazmo22

  • Newbie
  • *
  • Posts: 1
  • Karma: 0
Re: Sustain not working as expected
« Reply #4 on: January 13, 2021, 03:01:11 pm »
i am having the same issues all of a sudden with mu sustain pedal and Piano V2. Its been working great for a year or so and now all of a sudden has stopped!!!
I am using Piano V2 within the V collection 7 from Splice. Any ideas on how to fix this?

dpfranz

  • Apprentice
  • *
  • Posts: 7
  • Karma: 0
Re: Sustain not working as expected
« Reply #5 on: January 25, 2021, 12:11:07 am »
I noticed this today; running Piano V2 through NI Komplete Kontrol, using KK s61 Mk II controller.

Sustain pedal works sometimes, sometimes not. I thought, maybe there's a bad wire in the pedal (M-Audio SP 2) - took it apart; nope, all looks good.

Switched to the sustain pedal that came with my Kurzweil PC3K8 - same issue; works sometimes, sometimes not.

Switch VST to NI The Grandeur - sustain pedal works consistently.

chrisjh@gmail.com

  • Newbie
  • *
  • Posts: 1
  • Karma: 0
Re: Sustain not working as expected
« Reply #6 on: January 27, 2021, 04:38:30 am »
I'm having the same problem - my sustain pedal works in all other V Collection 8 VSTs, but never in Piano V2 (including when selecting Piano within Analog Lab V).

I've just opened a ticket with Arturia technical support - if they are able to help me solve this, I'll come back here with the solution.

redcurrantuk

  • Newbie
  • *
  • Posts: 1
  • Karma: 0
Re: Sustain not working as expected
« Reply #7 on: February 02, 2021, 06:19:35 pm »
Having exactly the same problem after update. Pedal activity shows correctly on screen but works erratically. hangs, or doesn't work at all. Other instruments fine. Piano worked fine before. I am using standalone Piano V2 and same issue whether using Oxygen Keyboard + Pedals or Komplete Kontrol S88. Worked before.

edward.schwarz@gmail.com

  • Newbie
  • *
  • Posts: 2
  • Karma: 0
Re: Sustain not working as expected
« Reply #8 on: March 28, 2021, 04:54:47 pm »
 am also having this problem:

Piano V2 version 2.7.1.1263, from V-Collection 5
Max OSX Catalina
Ableton Live 11
AKAI ADVANCE 49 controller

- Not getting SUSTAIN. Sustain pedal works fin with same setup using other piano plugins.
- When I step on the pedal, the MIDI Setup automatically loads a MIDI profile called USETR1 and inserts the CC64 as "Pitch Center".
- On the "ACTION" panel in the UI, the "Global Tension" control-knob lights up

Really big problem, currently the Piano V2 is kinda unusable without sustain pedal support.

scabbyBottoms

  • Newbie
  • *
  • Posts: 1
  • Karma: 0
Re: Sustain not working as expected
« Reply #9 on: April 28, 2021, 02:32:56 am »
This appears to be a Logic issue.

Mine was working for moths then just stopped one day.

Solution:

delete these files and re-boot logic.

com.apple.logic10.plist
com.apple.logic.pro.cs

fixed it for me.

 

Carbonate design by Bloc
SMF 2.0.17 | SMF © 2019, Simple Machines